]> git.pld-linux.org Git - packages/sip5.git/blob - sip5.spec
rebuild with python 3.10
[packages/sip5.git] / sip5.spec
1 Summary:        SIP - Python/C++ Bindings Generator
2 Name:           sip5
3 Version:        5.5.0
4 Release:        3
5 License:        GPL v2
6 #Source0Download:        https://pypi.org/project/sip/
7 Source0:        https://files.pythonhosted.org/packages/source/s/sip/sip-%{version}.tar.gz
8 # Source0-md5:  657c52aff0a180fc0f481e210bc9a2ba
9 URL:            https://www.riverbankcomputing.com/software/sip
10 Patch0:         python3.10.patch
11 BuildRequires:  python3-devel
12 BuildRequires:  python3-setuptools
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 SIP is a collection of tools that makes it very easy to create Python
17 bindings for C and C++ libraries. It was originally developed in 1998
18 to create PyQt, the Python bindings for the Qt toolkit, but can be
19 used to create bindings for any C or C++ library. For example it is
20 also used to generate wxPython, the Python bindings for wxWidgets.
21
22 %prep
23 %setup -q -n sip-%{version}
24 %patch0 -p1
25
26 %build
27 %py3_build
28
29 %install
30 rm -rf $RPM_BUILD_ROOT
31 %py3_install
32
33 %clean
34 rm -rf $RPM_BUILD_ROOT
35
36 %files
37 %defattr(644,root,root,755)
38 %doc README
39 %attr(755,root,root) %{_bindir}/sip*
40 %dir %{py3_sitedir}/sipbuild
41 %{py3_sitedir}/sip-%{version}-py*.egg-info
42 %{py3_sitedir}/sipbuild/*.py
43 %attr(755,root,root) %{py3_sitedir}/sipbuild/*.so
44 %{py3_sitedir}/sipbuild/__pycache__
45 %dir %{py3_sitedir}/sipbuild/distinfo
46 %{py3_sitedir}/sipbuild/distinfo/*.py
47 %{py3_sitedir}/sipbuild/distinfo/__pycache__
48 %dir %{py3_sitedir}/sipbuild/legacy
49 %{py3_sitedir}/sipbuild/legacy/*.py
50 %{py3_sitedir}/sipbuild/legacy/__pycache__
51 %dir %{py3_sitedir}/sipbuild/module
52 %{py3_sitedir}/sipbuild/module/*.py
53 %{py3_sitedir}/sipbuild/module/__pycache__
54 %dir %{py3_sitedir}/sipbuild/tools
55 %{py3_sitedir}/sipbuild/tools/*.py
56 %{py3_sitedir}/sipbuild/tools/__pycache__
57 %{py3_sitedir}/sipbuild/module/source
This page took 0.050838 seconds and 3 git commands to generate.