]> git.pld-linux.org Git - packages/sip.git/blob - sip.spec
- pass LIBDIR_QT for lib64 support
[packages/sip.git] / sip.spec
1 %include        /usr/lib/rpm/macros.python
2 Summary:        Python bindings generator for C++ class libraries
3 Summary(pl):    Generator powi±zañ Pythona z bibliotekami klas C++
4 Name:           sip
5 Version:        3.11
6 %define         _snap           20040218
7 Release:        0.%{_snap}.6
8 License:        GPL
9 Group:          Development/Languages/Python
10 # Source0:      http://www.river-bank.demon.co.uk/download/sip/%{name}-x11-gpl-%{version}.tar.gz
11 # http://www.river-bank.demon.co.uk/download/snapshots/sip/sip-snapshot-20040218.tar.gz
12 Source0:        http://www.river-bank.demon.co.uk/download/snapshots/sip/%{name}-snapshot-%{_snap}.tar.gz
13 # Source0-md5:  73dd4a8be8e75fb1a44e46280030e0f2
14 URL:            http://www.riverbankcomputing.co.uk/sip/index.php
15 BuildRequires:  python-devel >= 2.2
16 BuildRequires:  qt-devel >= 3.1.2
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  tmake
19 %pyrequires_eq  python
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sipfilesdir    %{_datadir}/sip
23
24 %description
25 Generates Python bindings for C++ class libraries from a set of class
26 specification files. Also includes a runtime support library needed by
27 all generated bindings.
28
29 %description -l pl
30 Generuje powi±zania Pythona z bibliotekami klas C++ ze zbioru plików
31 ze specyfikacjami klas. Zawiera te¿ bibliotekê potrzebn± do
32 uruchomienia wszystkich wygenerowanych powi±zañ.
33
34 %prep
35 #%%setup -q -n %{name}-x11-gpl-%{version}
36 %setup -q -n %{name}-snapshot-%{_snap}
37
38 %build
39 # configure.py notes:
40 # - macros overrides must be last
41 # - cannot pass CXXFLAGS+="%{rpmcflags}" or so - builtin -O2 overrides rpmcflags
42 QTDIR=%{_prefix} \
43 TMAKEPATH=/usr/share/tmake \
44 python configure.py \
45         -b %{_bindir} \
46         -d %{py_sitedir} \
47         -e %{py_incdir} \
48         -l qt-mt \
49         LIBDIR_QT="%{_libdir}"
50
51 %{__make} -C sipgen \
52         CC="%{__cc}" \
53         CFLAGS="%{rpmcflags} -pipe -w" \
54         LINK="%{__cc}"
55
56 %{__make} -C siplib \
57         CXX="%{__cxx}" \
58         CXXFLAGS="%{rpmcflags} -fPIC -pipe -w" \
59         LINK="%{__cxx}"
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_sipfilesdir}
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc ChangeLog NEWS README THANKS
74 %attr(755,root,root) %{_bindir}/*
75 %attr(755,root,root) %{py_sitedir}/libsip.so
76 %{py_sitedir}/sipconfig.py
77 %{py_incdir}/*.h
78 %dir %{_sipfilesdir}
This page took 0.074733 seconds and 4 git commands to generate.