]> git.pld-linux.org Git - packages/sip.git/blob - sip.spec
- fixed src URL
[packages/sip.git] / sip.spec
1 %include        /usr/lib/rpm/macros.python
2 Summary:        Python bindings generator for C++ class libraries
3 Summary(pl):    Generator powi±zañ Pythona z bibliotekami klas C++
4 Name:           sip
5 Version:        3.5
6 Release:        1
7 License:        GPL
8 Group:          Development/Languages/Python
9 Source0:        http://www.river-bank.demon.co.uk/download/sip/%{name}-x11-gpl-%{version}.tar.gz
10 URL:            http://www.riverbankcomputing.co.uk/sip/index.php
11 Requires:       python >= 2.2
12 BuildRequires:  qt-devel
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  python
15 BuildRoot:      %{tmpdir}/%{name}-x11-gpl-%{version}-root-%(id -u -n)
16
17 %description
18 Generates Python bindings for C++ class libraries from a set of class
19 specification files. Also includes a runtime support library needed by
20 all generated bindings.
21
22 %description -l pl
23 Generuje powi±zania Pythona z bibliotekami klas C++ ze zbioru plików
24 ze specyfikacjami klas. Zawiera te¿ bibliotekê potrzebn± do
25 uruchomienia wszystkich wygenerowanych powi±zañ.
26
27 %prep
28 %setup -q -n %{name}-x11-gpl-%{version}
29
30 %build
31
32 #QMAKESPEC=%{_prefix}/X11R6/share/qt/mkspecs/linux-g++
33 #export QMAKESPEC
34 install -d  $RPM_BUILD_ROOT%{_libdir}/python2.2/site-packages
35 install -d $RPM_BUILD_ROOT%{_includedir}/python2.2
36
37 python build.py  -i %{_includedir}/qt -q %{_prefix} -l qt-mt -m %{_bindir}/make -b $RPM_BUILD_ROOT%{_bindir}/ -d $RPM_BUILD_ROOT%{_libdir}/python2.2/site-packages -e $RPM_BUILD_ROOT%{_includedir}/python2.2
38 %{__make}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42 install -d  $RPM_BUILD_ROOT%{_libdir}/python2.2/site-packages
43 install -d $RPM_BUILD_ROOT%{_includedir}/python2.2
44
45 %{__make} install
46
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc ChangeLog  NEWS  README  THANKS
54 %attr(755,root,root) %{_bindir}/*
55 %{_includedir}/*/*.h
56 %attr(755,root,root) %{py_sitedir}/lib*.*
This page took 0.028796 seconds and 4 git commands to generate.