]> git.pld-linux.org Git - packages/sip.git/blob - sip.spec
- merged updates (sic) from RA-branch (but up to 3.7)
[packages/sip.git] / sip.spec
1 # TODO:
2 # - %build shouldn't use $RPM_BUILD_ROOT
3 # - libsip.so.* is built with evil RPATH (inside buildroot)
4 %include        /usr/lib/rpm/macros.python
5 Summary:        Python bindings generator for C++ class libraries
6 Summary(pl):    Generator powi±zañ Pythona z bibliotekami klas C++
7 Name:           sip
8 Version:        3.7
9 Release:        0.1
10 License:        GPL
11 Group:          Development/Languages/Python
12 Source0:        http://www.river-bank.demon.co.uk/download/sip/%{name}-x11-gpl-%{version}.tar.gz
13 # Source0-md5:  f186952fe88097caa3b25503e3583ce7
14 URL:            http://www.riverbankcomputing.co.uk/sip/index.php
15 BuildRequires:  python-devel >= 2.2
16 BuildRequires:  qt-devel >= 3.1.2
17 BuildRequires:  rpm-pythonprov
18 %pyrequires_eq  python
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         _sipfilesdir    %{_datadir}/sip
22
23 %description
24 Generates Python bindings for C++ class libraries from a set of class
25 specification files. Also includes a runtime support library needed by
26 all generated bindings.
27
28 %description -l pl
29 Generuje powi±zania Pythona z bibliotekami klas C++ ze zbioru plików
30 ze specyfikacjami klas. Zawiera te¿ bibliotekê potrzebn± do
31 uruchomienia wszystkich wygenerowanych powi±zañ.
32
33 %prep
34 %setup -q -n %{name}-x11-gpl-%{version}
35
36 %build
37 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{py_incdir}}
38
39 echo 'yes' | python build.py \
40         -i %{_includedir}/qt -q %{_prefix} -l qt-mt -m /usr/bin/make \
41         -b $RPM_BUILD_ROOT%{_bindir} -d $RPM_BUILD_ROOT%{py_sitedir} \
42         -e $RPM_BUILD_ROOT%{py_incdir}
43
44 %{__make}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 install -d $RPM_BUILD_ROOT{%{py_sitedir},%{py_incdir},%{_sipfilesdir}}
49
50 %{__make} install
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc ChangeLog NEWS README THANKS
58 %attr(755,root,root) %{_bindir}/*
59 %attr(755,root,root) %{py_sitedir}/lib*.*
60 %{py_incdir}/*.h
61 %dir %{_sipfilesdir}
This page took 0.041273 seconds and 4 git commands to generate.