]> git.pld-linux.org Git - packages/sip.git/blob - sip.spec
- new packages -devel and python-sip
[packages/sip.git] / sip.spec
1 Summary:        Python bindings generator for C++ class libraries
2 Summary(pl):    Generator powi±zañ Pythona z bibliotekami klas C++
3 Name:           sip
4 Version:        4.3.2
5 Release:        2
6 Epoch:          2
7 License:        redistributable (see LICENSE)
8 Group:          Development/Languages/Python
9 Source0:        http://www.river-bank.demon.co.uk/download/sip/%{name}-%{version}.tar.gz
10 # Source0-md5:  993c890998e337d4df71c5d4b0db52b9
11 URL:            http://www.riverbankcomputing.co.uk/sip/index.php
12 BuildRequires:  python-devel >= 2.3
13 BuildRequires:  qt-devel >= 3.1.2
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  tmake
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _sipfilesdir    %{_datadir}/sip
19
20 %description
21 Generates Python bindings for C++ class libraries from a set of class
22 specification files.
23
24 %description -l pl
25 Generuje powi±zania Pythona z bibliotekami klas C++ ze zbioru plików
26 ze specyfikacjami klas.
27
28 %package devel
29 Summary:        sip - development files needed to build bindings
30 Summary(pl):    sip - pliki programistyczne potrzebne do budowania powi±zañ
31 Group:          Development/Libraries
32 Requires:       %{name} = %{epoch}:%{version}-%{release}
33 Requires:       python-devel >= 2.3
34 %pyrequires_eq  python-libs
35
36 %description devel
37 Development files needed to build bindings for C++ classes.
38
39 %description devel -l pl
40 Pliki programistyczne potrzebne do budowania powi±zañ z klasami C++.
41
42 %package -n python-sip
43 Summary:        Python module needed by generated bindings
44 Summary(pl):    Modu³ Pythona wymagany przez wygenerowane powi±zania
45 Group:          Libraries/Python
46 %pyrequires_eq  python-libs
47
48 %description -n python-sip
49 Generates Python bindings for C++ class libraries from a set of class
50 specification files. This package includes runtime library needed by
51 all generated bindings.
52
53 %description -n python-sip -l pl
54 Generuje powi±zania Pythona z bibliotekami klas C++ ze zbioru plików
55 ze specyfikacjami klas. Ten pakiet zawiera bibliotekê potrzebn± do
56 uruchomienia wszystkich wygenerowanych powi±zañ.
57
58 %prep
59 %setup -q
60
61 %build
62 # configure.py notes:
63 # - macros overrides must be last
64 # - cannot pass CXXFLAGS+="%{rpmcflags}" or so - builtin -O2 overrides rpmcflags
65 QTDIR=%{_prefix} \
66 TMAKEPATH=%{_datadir}/tmake \
67 python configure.py \
68         -b %{_bindir} \
69         -d %{py_sitedir} \
70         -e %{py_incdir} \
71         -l qt-mt \
72         -v %{_sipfilesdir} \
73         LIBDIR_QT="%{_libdir}" \
74         LIBDIR_X11="%{_prefix}/X11R6/%{_lib}" \
75         CC="%{__cc}" \
76         CXX="%{__cxx}" \
77         CFLAGS="%{rpmcflags}" \
78         CXXFLAGS="%{rpmcxxflags}" \
79         LINK="%{__cxx}" \
80         LINK_SHLIB="%{__cxx}"
81
82 %{__make}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT%{_sipfilesdir}
87
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %files
95 %defattr(644,root,root,755)
96 %doc ChangeLog LICENSE NEWS THANKS doc/*
97 %attr(755,root,root) %{_bindir}/*
98
99 %files devel
100 %defattr(644,root,root,755)
101 %{py_sitedir}/sip*.py
102 %{py_incdir}/*.h
103 %dir %{_sipfilesdir}
104
105 %files -n python-sip
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{py_sitedir}/sip.so
This page took 0.046364 seconds and 4 git commands to generate.