]> git.pld-linux.org Git - packages/sip.git/blob - sip.spec
- removed %%include /usr/lib/rpm/macros.python
[packages/sip.git] / sip.spec
1 Summary:        Python bindings generator for C++ class libraries
2 Summary(pl):    Generator powi±zañ Pythona z bibliotekami klas C++
3 Name:           sip
4 Version:        4.0.1
5 #%%define               _snap           20040218
6 #Release:       0.%{_snap}.7
7 Release:        1
8 Epoch:          2
9 License:        GPL
10 Group:          Development/Languages/Python
11 Source0:        http://www.river-bank.demon.co.uk/download/sip/%{name}-%{version}.tar.gz
12 # Source0-md5:  a2aa4ef53cb4f18e7ce25bc2e123548e
13 # Source0:      http://www.river-bank.demon.co.uk/download/snapshots/sip/%{name}-snapshot-%{_snap}.tar.gz
14 URL:            http://www.riverbankcomputing.co.uk/sip/index.php
15 BuildRequires:  python-devel >= 2.2
16 BuildRequires:  qt-devel >= 3.1.2
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  tmake
19 %pyrequires_eq  python
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sipfilesdir    %{_datadir}/sip
23
24 %description
25 Generates Python bindings for C++ class libraries from a set of class
26 specification files. Also includes a runtime support library needed by
27 all generated bindings.
28
29 %description -l pl
30 Generuje powi±zania Pythona z bibliotekami klas C++ ze zbioru plików
31 ze specyfikacjami klas. Zawiera te¿ bibliotekê potrzebn± do
32 uruchomienia wszystkich wygenerowanych powi±zañ.
33
34 %prep
35 %setup -q 
36 #%%setup -q -n %{name}-snapshot-%{_snap}
37
38 %build
39 # configure.py notes:
40 # - macros overrides must be last
41 # - cannot pass CXXFLAGS+="%{rpmcflags}" or so - builtin -O2 overrides rpmcflags
42 QTDIR=%{_prefix} \
43 TMAKEPATH=/usr/share/tmake \
44 python configure.py \
45         -b %{_bindir} \
46         -d %{py_sitedir} \
47         -e %{py_incdir} \
48         -l qt-mt \
49         LIBDIR_QT="%{_libdir}" \
50         LIBDIR_X11="/usr/X11R6/%{_lib}"
51
52 %{__make} -C sipgen \
53         CC="%{__cc}" \
54         CFLAGS="%{rpmcflags} -pipe -w" \
55         LINK="%{__cc}"
56
57 %{__make} -C siplib \
58         CC="%{__cc}" \
59         CXX="%{__cxx}" \
60         CFLAGS="%{rpmcflags} -fPIC -pipe -w -D_REENTRANT" \
61         CXXFLAGS="%{rpmcflags} -fPIC -pipe -w -D_REENTRANT" \
62         LINK="%{__cxx}"
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT%{_sipfilesdir}
67
68 %{__make} install \
69         DESTDIR=$RPM_BUILD_ROOT
70
71 %clean
72 rm -rf $RPM_BUILD_ROOT
73
74 %files
75 %defattr(644,root,root,755)
76 %doc ChangeLog NEWS README THANKS
77 %attr(755,root,root) %{_bindir}/*
78 %attr(755,root,root) %{py_sitedir}/sip.so
79 %{py_sitedir}/sipconfig.py
80 %{py_incdir}/*.h
81 %dir %{_sipfilesdir}
This page took 0.064845 seconds and 4 git commands to generate.