]> git.pld-linux.org Git - packages/sip.git/blob - sip.spec
- up to 4.16.3
[packages/sip.git] / sip.spec
1 Summary:        Python bindings generator for C++ class libraries
2 Summary(pl.UTF-8):      Generator powiązań Pythona z bibliotekami klas C++
3 Name:           sip
4 Version:        4.16.3
5 Release:        1
6 Epoch:          2
7 License:        SIP (redistributable, see LICENSE) or GPL v2 or GPL v3
8 Group:          Development/Languages/Python
9 Source0:        http://downloads.sourceforge.net/pyqt/sip-%{version}.tar.gz
10 # Source0-md5:  884d60b6f17fc5b910da4665caf6fd85
11 URL:            http://www.riverbankcomputing.com/software/sip/
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  python-devel >= 2.3
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.167
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _sipfilesdir    %{_datadir}/sip
19
20 %description
21 Generates Python bindings for C++ class libraries from a set of class
22 specification files. It supports Python v2 and v3.
23
24 %description -l pl.UTF-8
25 Generuje powiązania Pythona z bibliotekami klas C++ ze zbioru plików
26 ze specyfikacjami klas. Obsługiwany jest Python 2 i 3.
27
28 %package -n python-sip
29 Summary:        Python module needed by generated bindings
30 Summary(pl.UTF-8):      Moduł Pythona wymagany przez wygenerowane powiązania
31 Group:          Libraries/Python
32 %pyrequires_eq  python-libs
33
34 %description -n python-sip
35 Generates Python bindings for C++ class libraries from a set of class
36 specification files. This package includes runtime library needed by
37 all generated bindings.
38
39 %description -n python-sip -l pl.UTF-8
40 Generuje powiązania Pythona z bibliotekami klas C++ ze zbioru plików
41 ze specyfikacjami klas. Ten pakiet zawiera bibliotekę potrzebną do
42 uruchomienia wszystkich wygenerowanych powiązań.
43
44 %package -n python-sip-devel
45 Summary:        Development files needed to build bindings
46 Summary(pl.UTF-8):      Pliki programistyczne potrzebne do budowania powiązań
47 Group:          Development/Libraries
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49 Requires:       python-devel >= 2.3
50 %pyrequires_eq  python-libs
51
52 %description -n python-sip-devel
53 Development files needed to build bindings for C++ classes.
54
55 %description -n python-sip-devel -l pl.UTF-8
56 Pliki programistyczne potrzebne do budowania powiązań z klasami C++.
57
58 %prep
59 %setup -q
60
61 %build
62 # configure.py notes:
63 # - macros overrides must be last
64 # - cannot pass CXXFLAGS+="%{rpmcflags}" or so - builtin -O2 overrides rpmcflags
65 %{__python} configure.py \
66         -b %{_bindir} \
67         -e %{py_incdir} \
68         -v %{_sipfilesdir} \
69         -d %{py_sitedir} \
70         CC="%{__cc}" \
71         CXX="%{__cxx}" \
72         CFLAGS="%{rpmcflags} %{rpmcppflags}" \
73         CXXFLAGS="%{rpmcxxflags} %{rpmcppflags}" \
74         LINK="%{__cxx}" \
75         LINK_SHLIB="%{__cxx}"
76
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 install -d $RPM_BUILD_ROOT%{_sipfilesdir}
82
83 %{__make} install \
84         DESTDIR=$RPM_BUILD_ROOT
85
86 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
87 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc LICENSE NEWS README doc/html
95 %attr(755,root,root) %{_bindir}/sip
96
97 %files -n python-sip
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{py_sitedir}/sip.so
100 %dir %{_sipfilesdir}
101
102 %files -n python-sip-devel
103 %defattr(644,root,root,755)
104 %{py_sitedir}/sipconfig.py
105 %{py_sitedir}/sipconfig.py[co]
106 %{py_sitedir}/sipdistutils.py
107 %{py_sitedir}/sipdistutils.py[co]
108 %{py_incdir}/sip.h
This page took 0.0732 seconds and 3 git commands to generate.