]> git.pld-linux.org Git - packages/sip.git/blob - sip.spec
- Version 2:3.10.1-1
[packages/sip.git] / sip.spec
1 %include        /usr/lib/rpm/macros.python
2 Summary:        Python bindings generator for C++ class libraries
3 Summary(pl):    Generator powi±zañ Pythona z bibliotekami klas C++
4 Name:           sip
5 Epoch:          2
6 Version:        3.10.1
7 #%%define               _snap           20040218
8 #%Release:      0.%{_snap}.7
9 Release:        1
10 License:        GPL
11 Group:          Development/Languages/Python
12 Source0:        http://www.river-bank.demon.co.uk/download/sip/%{name}-%{version}.tar.gz
13 # Source0-md5:  7d7faa17422cd3e7b27d449ffbc9cd0f
14 # Source0:      http://www.river-bank.demon.co.uk/download/snapshots/sip/%{name}-snapshot-%{_snap}.tar.gz
15 URL:            http://www.riverbankcomputing.co.uk/sip/index.php
16 BuildRequires:  python-devel >= 2.2
17 BuildRequires:  qt-devel >= 3.1.2
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  tmake
20 %pyrequires_eq  python
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _sipfilesdir    %{_datadir}/sip
24
25 %description
26 Generates Python bindings for C++ class libraries from a set of class
27 specification files. Also includes a runtime support library needed by
28 all generated bindings.
29
30 %description -l pl
31 Generuje powi±zania Pythona z bibliotekami klas C++ ze zbioru plików
32 ze specyfikacjami klas. Zawiera te¿ bibliotekê potrzebn± do
33 uruchomienia wszystkich wygenerowanych powi±zañ.
34
35 %prep
36 %setup -q 
37 #%%setup -q -n %{name}-snapshot-%{_snap}
38
39 %build
40 # configure.py notes:
41 # - macros overrides must be last
42 # - cannot pass CXXFLAGS+="%{rpmcflags}" or so - builtin -O2 overrides rpmcflags
43 QTDIR=%{_prefix} \
44 TMAKEPATH=/usr/share/tmake \
45 python configure.py \
46         -b %{_bindir} \
47         -d %{py_sitedir} \
48         -e %{py_incdir} \
49         -l qt-mt \
50         LIBDIR_QT="%{_libdir}" \
51         LIBDIR_X11="/usr/X11R6/%{_lib}"
52
53 %{__make} -C sipgen \
54         CC="%{__cc}" \
55         CFLAGS="%{rpmcflags} -pipe -w" \
56         LINK="%{__cc}"
57
58 %{__make} -C siplib \
59         CC="%{__cc}" \
60         CXX="%{__cxx}" \
61         CFLAGS="%{rpmcflags} -fPIC -pipe -w -D_REENTRANT" \
62         CXXFLAGS="%{rpmcflags} -fPIC -pipe -w -D_REENTRANT" \
63         LINK="%{__cxx}"
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT%{_sipfilesdir}
68
69 %{__make} install \
70         DESTDIR=$RPM_BUILD_ROOT
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %files
76 %defattr(644,root,root,755)
77 %doc ChangeLog NEWS README THANKS
78 %attr(755,root,root) %{_bindir}/*
79 %attr(755,root,root) %{py_sitedir}/libsip.so
80 %{py_sitedir}/sipconfig.py
81 %{py_incdir}/*.h
82 %dir %{_sipfilesdir}
This page took 0.074038 seconds and 3 git commands to generate.