]> git.pld-linux.org Git - packages/sip.git/blob - sip.spec
- Autoupdated to 4.4.3-1.
[packages/sip.git] / sip.spec
1 Summary:        Python bindings generator for C++ class libraries
2 Summary(pl):    Generator powi±zañ Pythona z bibliotekami klas C++
3 Name:           sip
4 Version:        4.4.3
5 Release:        1
6 Epoch:          2
7 License:        redistributable (see LICENSE)
8 Group:          Development/Languages/Python
9 Source0:        http://www.riverbankcomputing.com/Downloads/sip4/sip-%{version}.tar.gz
10 # Source0-md5:  7465a9cf8e1f280425ab8f9f6e85b888
11 URL:            http://www.riverbankcomputing.co.uk/sip/index.php
12 BuildRequires:  libstdc++-devel
13 BuildRequires:  python-devel >= 2.3
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.167
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %define         _sipfilesdir    %{_datadir}/sip
19
20 %description
21 Generates Python bindings for C++ class libraries from a set of class
22 specification files.
23
24 %description -l pl
25 Generuje powi±zania Pythona z bibliotekami klas C++ ze zbioru plików
26 ze specyfikacjami klas.
27
28 %package -n python-sip
29 Summary:        Python module needed by generated bindings
30 Summary(pl):    Modu³ Pythona wymagany przez wygenerowane powi±zania
31 Group:          Libraries/Python
32 %pyrequires_eq  python-libs
33
34 %description -n python-sip
35 Generates Python bindings for C++ class libraries from a set of class
36 specification files. This package includes runtime library needed by
37 all generated bindings.
38
39 %description -n python-sip -l pl
40 Generuje powi±zania Pythona z bibliotekami klas C++ ze zbioru plików
41 ze specyfikacjami klas. Ten pakiet zawiera bibliotekê potrzebn± do
42 uruchomienia wszystkich wygenerowanych powi±zañ.
43
44 %package -n python-sip-devel
45 Summary:        Development files needed to build bindings
46 Summary(pl):    Pliki programistyczne potrzebne do budowania powi±zañ
47 Group:          Development/Libraries
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49 Requires:       python-devel >= 2.3
50 %pyrequires_eq  python-libs
51
52 %description -n python-sip-devel
53 Development files needed to build bindings for C++ classes.
54
55 %description -n python-sip-devel -l pl
56 Pliki programistyczne potrzebne do budowania powi±zañ z klasami C++.
57
58 %prep
59 %setup -q
60
61 %build
62 # configure.py notes:
63 # - macros overrides must be last
64 # - cannot pass CXXFLAGS+="%{rpmcflags}" or so - builtin -O2 overrides rpmcflags
65 python configure.py \
66         -b %{_bindir} \
67         -e %{py_incdir} \
68         -v %{_sipfilesdir} \
69         CC="%{__cc}" \
70         CXX="%{__cxx}" \
71         CFLAGS="%{rpmcflags}" \
72         CXXFLAGS="%{rpmcxxflags}" \
73         LINK="%{__cxx}" \
74         LINK_SHLIB="%{__cxx}"
75
76 %{__make}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 install -d $RPM_BUILD_ROOT%{_sipfilesdir}
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc ChangeLog LICENSE NEWS THANKS doc/*
91 %attr(755,root,root) %{_bindir}/*
92
93 %files -n python-sip
94 %defattr(644,root,root,755)
95 %attr(755,root,root) %{py_sitedir}/sip.so
96
97 %files -n python-sip-devel
98 %defattr(644,root,root,755)
99 %{py_sitedir}/sip*.py
100 %{py_incdir}/*.h
101 %dir %{_sipfilesdir}
This page took 0.061397 seconds and 3 git commands to generate.