]> git.pld-linux.org Git - packages/sip.git/blob - sip.spec
- updated to 4.3.1
[packages/sip.git] / sip.spec
1 Summary:        Python bindings generator for C++ class libraries
2 Summary(pl):    Generator powi±zañ Pythona z bibliotekami klas C++
3 Name:           sip
4 Version:        4.3.1
5 Release:        1
6 Epoch:          2
7 License:        redistributable (see LICENSE)
8 Group:          Development/Languages/Python
9 Source0:        http://www.river-bank.demon.co.uk/download/sip/%{name}-%{version}.tar.gz
10 # Source0-md5:  c561d8dc19fbe3a8bffc4b10bd56910f
11 URL:            http://www.riverbankcomputing.co.uk/sip/index.php
12 BuildRequires:  python-devel >= 2.3
13 BuildRequires:  qt-devel >= 3.1.2
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  tmake
16 Requires:       python-devel >= 2.3
17 %pyrequires_eq  python-libs
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %define         _sipfilesdir    %{_datadir}/sip
21
22 %description
23 Generates Python bindings for C++ class libraries from a set of class
24 specification files. Also includes a runtime support library needed by
25 all generated bindings.
26
27 %description -l pl
28 Generuje powi±zania Pythona z bibliotekami klas C++ ze zbioru plików
29 ze specyfikacjami klas. Zawiera te¿ bibliotekê potrzebn± do
30 uruchomienia wszystkich wygenerowanych powi±zañ.
31
32 %prep
33 %setup -q 
34
35 %build
36 # configure.py notes:
37 # - macros overrides must be last
38 # - cannot pass CXXFLAGS+="%{rpmcflags}" or so - builtin -O2 overrides rpmcflags
39 QTDIR=%{_prefix} \
40 TMAKEPATH=/usr/share/tmake \
41 python configure.py \
42         -b %{_bindir} \
43         -d %{py_sitedir} \
44         -e %{py_incdir} \
45         -l qt-mt \
46         LIBDIR_QT="%{_libdir}" \
47         LIBDIR_X11="/usr/X11R6/%{_lib}"
48
49 %{__make} -C sipgen \
50         CC="%{__cc}" \
51         CFLAGS="%{rpmcflags} -pipe -w" \
52         LINK="%{__cc}"
53
54 %{__make} -C siplib \
55         CC="%{__cc}" \
56         CXX="%{__cxx}" \
57         CFLAGS="%{rpmcflags} -fPIC -pipe -w -D_REENTRANT" \
58         CXXFLAGS="%{rpmcflags} -fPIC -pipe -w -D_REENTRANT" \
59         LINK="%{__cxx}"
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT%{_sipfilesdir}
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %clean
69 rm -rf $RPM_BUILD_ROOT
70
71 %files
72 %defattr(644,root,root,755)
73 %doc ChangeLog LICENSE NEWS THANKS doc/*
74 %attr(755,root,root) %{_bindir}/*
75 %attr(755,root,root) %{py_sitedir}/sip.so
76 %{py_sitedir}/sipconfig.py
77 %{py_incdir}/*.h
78 %dir %{_sipfilesdir}
This page took 0.03001 seconds and 3 git commands to generate.