]> git.pld-linux.org Git - packages/sigar.git/blob - sigar.spec
- added missing -l in %description
[packages/sigar.git] / sigar.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 #
5 Summary:        SIGAR - System Information Gatherer And Reporter
6 Summary(pl.UTF-8):      SIGAR - narzędzie do zbierania i raportowania informacji systemowych
7 Name:           sigar
8 Version:        1.4.0.0
9 Release:        0.1
10 License:        GPL v2
11 Group:          Libraries
12 Source0:        http://dl.sourceforge.net/sigar/hyperic-%{name}-%{version}-src.tar.gz
13 # Source0-md5:  0e3718c99c183f194578ba39cf207a65
14 Source1:        http://jan.kneschke.de/assets/2007/2/16/hyperic-%{name}-1.3.0.0-src-cmake.tar.gz
15 # Source1-md5:  b77d087ab92c07d40706716d7496d1f6
16 URL:            http://sigar.hyperic.com/
17 BuildRequires:  ant >= 1.6.5
18 BuildRequires:  cmake
19 BuildRequires:  jdk >= 1.3
20 BuildRequires:  perl-base >= 5.6.1
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 The Sigar API provides a portable interface for gathering system
25 information such as:
26 - System memory, swap, CPU, load average, uptime, logins
27 - Per-process memory, CPU, credential info, state, arguments,
28   environment, open files
29 - File system detection and metrics
30 - Network interface detection, configuration info and metrics
31 - Network route and connection tables
32
33 This information is available in most operating systems, but each OS
34 has their own way(s) providing it. SIGAR provides developers with one
35 API to access this information regardless of the underlying platform.
36 The core API is implemented in pure C with bindings currently
37 implemented for Java, Perl and C#.
38
39 %description -l pl.UTF-8
40 Sigar API udostępnia przenośny interfejs do zbierania informacji
41 systemowych, takich jak:
42 - systemowa pamięć, swap, procesor, obciążenie, czas pracy, logowania
43 - informacje dla procesów: pamięć, wykorzystanie procesora,
44   uprawnienia, stan, argumenty, środowisko, otwarte pliki
45 - wykrywanie i pomiary systemów plików
46 - wykrywanie informacji sieciowych, informacje o konfiguracji i
47   pomiary
48 - tablice tras i połączeń sieciowych
49
50 Informacje te są dostępne w większości systemów operacyjnych, ale
51 każdy system ma własny sposób udostępniania ich. SIGAR udostępnia
52 programistom jedno API pozwalające na dostęp dotych informacji
53 niezależnie od platformy. Podstawowe API jest zaimplementowane w
54 czystym C, z wiązaniami dla Javy, Perla i C#.
55
56 %prep
57 %setup -q -n hyperic-%{name}-%{version}-src -a1
58
59 %build
60 %cmake .
61 %{__make}
62
63 cd bindings/java
64 %ant
65 chmod a+rx sigar-bin/lib/lib*.so
66
67 %if %{with tests}
68 %java -jar sigar-bin/lib/sigar.jar test
69 %endif
70 cd ../..
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74 install -d $RPM_BUILD_ROOT
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc ChangeLog LICENSES README
This page took 0.072284 seconds and 4 git commands to generate.