]> git.pld-linux.org Git - packages/shotwell.git/blob - shotwell.spec
- added gphoto2-Add-missing-cheader-attributes-of-delegate-s patch to fix build with...
[packages/shotwell.git] / shotwell.spec
1 #
2 # Conditional build:
3 %bcond_with     apport  # Ubuntu apport hook
4 %bcond_without  opencv  # faces detection using OpenCV
5 %bcond_with     unity   # Ubuntu Unity integration
6 #
7 Summary:        Photo manager for GNOME
8 Summary(pl.UTF-8):      Zarządca zdjęć dla GNOME
9 Name:           shotwell
10 Version:        0.30.17
11 Release:        2
12 License:        LGPL v2+ and CC-BY-SA
13 Group:          X11/Applications
14 Source0:        https://download.gnome.org/sources/shotwell/0.30/%{name}-%{version}.tar.xz
15 # Source0-md5:  da1f096b97075ad79b74194fe2d7292e
16 Patch0:         %{name}-gphoto2-Add-missing-cheader-attributes-of-delegate-s.patch
17 URL:            https://wiki.gnome.org/Apps/Shotwell
18 BuildRequires:  cairo-devel
19 BuildRequires:  gcr-devel >= 3
20 BuildRequires:  gcr-ui-devel >= 3
21 BuildRequires:  gdk-pixbuf2-devel >= 2.0
22 BuildRequires:  gettext-tools >= 0.19.7
23 BuildRequires:  gexiv2-devel >= 0.11
24 BuildRequires:  glib2-devel >= 1:2.40.0
25 BuildRequires:  gstreamer-devel >= 1.0.0
26 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
27 BuildRequires:  gtk+3-devel >= 3.22
28 BuildRequires:  gtk-webkit4-devel >= 2.26
29 BuildRequires:  json-glib-devel >= 1.0
30 BuildRequires:  libexif-devel >= 1:0.6.16
31 BuildRequires:  libgdata-devel
32 BuildRequires:  libgee-devel >= 0.8.5
33 BuildRequires:  libgphoto2-devel >= 2.5.0
34 BuildRequires:  libraw-devel >= 0.14.7-2
35 BuildRequires:  libsoup-devel >= 2.26.0
36 %{?with_unity:BuildRequires:    libunity-devel}
37 BuildRequires:  libxml2-devel >= 1:2.6.32
38 BuildRequires:  meson >= 0.43.0
39 BuildRequires:  ninja >= 1.5
40 %{?with_opencv:BuildRequires:   opencv-devel >= 1:3.4.0}
41 BuildRequires:  pkgconfig >= 1:0.22
42 BuildRequires:  rpmbuild(macros) >= 1.736
43 BuildRequires:  sqlite3-devel >= 3.5.9
44 BuildRequires:  tar >= 1:1.22
45 BuildRequires:  vala-gcr-ui
46 BuildRequires:  udev-glib-devel >= 1:145
47 BuildRequires:  vala >= 2:0.28.0
48 BuildRequires:  vala-gcr >= 3
49 BuildRequires:  vala-gexiv2 >= 0.11
50 BuildRequires:  vala-libgee >= 0.8.5
51 BuildRequires:  xz
52 BuildRequires:  yelp-tools
53 Requires(post,postun):  desktop-file-utils
54 Requires(post,postun):  glib2 >= 1:2.40.0
55 Requires(post,postun):  gtk-update-icon-cache
56 Requires(post,postun):  hicolor-icon-theme
57 Requires:       gexiv2 >= 0.11
58 Requires:       glib2 >= 1:2.40.0
59 Requires:       gtk+3 >= 3.22
60 Requires:       gtk-webkit4 >= 2.26
61 Requires:       hicolor-icon-theme
62 Requires:       json-glib >= 1.0
63 Requires:       libexif >= 1:0.6.16
64 Requires:       libgee >= 0.8.5
65 Requires:       libgphoto2 >= 2.5.0
66 Requires:       libraw >= 0.14.7-2
67 Requires:       libsoup >= 2.26.0
68 Requires:       libxml2 >= 1:2.6.32
69 %{?with_opencv:Requires:        opencv >= 1:3.4.0}
70 Requires:       sqlite3 >= 3.5.9
71 Requires:       udev-glib >= 1:145
72 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
73
74 %description
75 Shotwell is a digital photo organizer designed for the GNOME desktop
76 environment. It allows you to import photos from disk or camera,
77 organize them in various ways, view them in full-window or fullscreen
78 mode, and export them to share with others.
79
80 %description -l pl.UTF-8
81 Shotwell to organizator zdjęć cyfrowych, zaprojektowany dla środowiska
82 graficznego GNOME. Pozwala importować zdjęcia z dysku lub aparatu,
83 organizować je na różne sposoby, przeglądać w trybie okienkowym lub
84 pełnoekranowym oraz eksportować, aby podzielić się nimi z innymi.
85
86 %prep
87 %setup -q
88 %patch0 -p1
89
90 %build
91 %meson build \
92         --default-library=shared \
93         %{?with_opencv:-Dface-detection=true} \
94         %{!?with_apport:-Dinstall-apport-hook=false} \
95         %{?with_unity:-Dunity-support=true}
96
97 %ninja_build -C build
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %ninja_install -C build
103
104 # API not exported, so no need for development symlinks
105 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libshotwell-*.so
106
107 %find_lang shotwell --with-gnome
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 /sbin/ldconfig
114 %update_icon_cache hicolor
115 %update_desktop_database
116 %glib_compile_schemas
117
118 %postun
119 /sbin/ldconfig
120 %update_icon_cache hicolor
121 %update_desktop_database_postun
122 %glib_compile_schemas
123
124 %files -f shotwell.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS COPYING MAINTAINERS NEWS README.md THANKS
127 %attr(755,root,root) %{_bindir}/shotwell
128 %attr(755,root,root) %{_libdir}/libshotwell-authenticator.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libshotwell-authenticator.so.0
130 %attr(755,root,root) %{_libdir}/libshotwell-plugin-common.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libshotwell-plugin-common.so.0
132 %attr(755,root,root) %{_libdir}/libshotwell-plugin-dev-1.0.so.*.*.*
133 %attr(755,root,root) %ghost %{_libdir}/libshotwell-plugin-dev-1.0.so.0
134 %if "%{_libexecdir}" != "%{_libdir}"
135 %dir %{_libexecdir}/%{name}
136 %endif
137 %if %{with opencv}
138 %attr(755,root,root) %{_libexecdir}/%{name}/shotwell-facedetect
139 %endif
140 %attr(755,root,root) %{_libexecdir}/%{name}/shotwell-settings-migrator
141 %attr(755,root,root) %{_libexecdir}/%{name}/shotwell-video-thumbnailer
142 %dir %{_libdir}/%{name}
143 %dir %{_libdir}/%{name}/plugins
144 %dir %{_libdir}/%{name}/plugins/builtin
145 %attr(755,root,root) %{_libdir}/%{name}/plugins/builtin/libshotwell-publishing.so
146 %attr(755,root,root) %{_libdir}/%{name}/plugins/builtin/libshotwell-publishing-extras.so
147 %attr(755,root,root) %{_libdir}/%{name}/plugins/builtin/libshotwell-transitions.so
148 %if %{with opencv}
149 %dir %{_datadir}/%{name}
150 %{_datadir}/%{name}/facedetect-haarcascade.xml
151 %endif
152 %if %{with apport}
153 %{_datadir}/apport/package-hooks/shotwell.py
154 %endif
155 %{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
156 %{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
157 %{_datadir}/metainfo/shotwell.appdata.xml
158 %{_desktopdir}/shotwell.desktop
159 %{_desktopdir}/shotwell-viewer.desktop
160 %{_iconsdir}/hicolor/*x*/apps/shotwell.png
161 %{_iconsdir}/hicolor/symbolic/apps/shotwell-symbolic.svg
162 %{_mandir}/man1/shotwell.1*
This page took 0.063752 seconds and 3 git commands to generate.