]> git.pld-linux.org Git - packages/shotwell.git/blob - shotwell.spec
666db8dd119c8fd5a9bbf28c0a92267da1ab935e
[packages/shotwell.git] / shotwell.spec
1 #
2 # Conditional build:
3 %bcond_with     apport  # Ubuntu apport hook
4 %bcond_without  opencv  # faces detection using OpenCV
5 %bcond_with     unity   # Ubuntu Unity integration
6 #
7 Summary:        Photo manager for GNOME
8 Summary(pl.UTF-8):      Zarządca zdjęć dla GNOME
9 Name:           shotwell
10 Version:        0.30.16
11 Release:        1
12 License:        LGPL v2+ and CC-BY-SA
13 Group:          X11/Applications
14 Source0:        https://download.gnome.org/sources/shotwell/0.30/%{name}-%{version}.tar.xz
15 # Source0-md5:  57fdf3d2f5cb30c070710eabebbfea16
16 URL:            https://wiki.gnome.org/Apps/Shotwell
17 BuildRequires:  cairo-devel
18 BuildRequires:  gcr-devel >= 3
19 BuildRequires:  gcr-ui-devel >= 3
20 BuildRequires:  gdk-pixbuf2-devel >= 2.0
21 BuildRequires:  gettext-tools >= 0.19.7
22 BuildRequires:  gexiv2-devel >= 0.11
23 BuildRequires:  glib2-devel >= 1:2.40.0
24 BuildRequires:  gstreamer-devel >= 1.0.0
25 BuildRequires:  gstreamer-plugins-base-devel >= 1.0.0
26 BuildRequires:  gtk+3-devel >= 3.22
27 BuildRequires:  gtk-webkit4-devel >= 2.26
28 BuildRequires:  json-glib-devel >= 1.0
29 BuildRequires:  libexif-devel >= 1:0.6.16
30 BuildRequires:  libgdata-devel
31 BuildRequires:  libgee-devel >= 0.8.5
32 BuildRequires:  libgphoto2-devel >= 2.5.0
33 BuildRequires:  libraw-devel >= 0.14.7-2
34 BuildRequires:  libsoup-devel >= 2.26.0
35 %{?with_unity:BuildRequires:    libunity-devel}
36 BuildRequires:  libxml2-devel >= 1:2.6.32
37 BuildRequires:  meson >= 0.43.0
38 BuildRequires:  ninja >= 1.5
39 %{?with_opencv:BuildRequires:   opencv-devel >= 1:3.4.0}
40 BuildRequires:  pkgconfig >= 1:0.22
41 BuildRequires:  rpmbuild(macros) >= 1.736
42 BuildRequires:  sqlite3-devel >= 3.5.9
43 BuildRequires:  tar >= 1:1.22
44 BuildRequires:  vala-gcr-ui
45 BuildRequires:  udev-glib-devel >= 1:145
46 BuildRequires:  vala >= 2:0.28.0
47 BuildRequires:  vala-gcr >= 3
48 BuildRequires:  vala-gexiv2 >= 0.11
49 BuildRequires:  vala-libgee >= 0.8.5
50 BuildRequires:  xz
51 BuildRequires:  yelp-tools
52 Requires(post,postun):  desktop-file-utils
53 Requires(post,postun):  glib2 >= 1:2.40.0
54 Requires(post,postun):  gtk-update-icon-cache
55 Requires(post,postun):  hicolor-icon-theme
56 Requires:       gexiv2 >= 0.11
57 Requires:       glib2 >= 1:2.40.0
58 Requires:       gtk+3 >= 3.22
59 Requires:       gtk-webkit4 >= 2.26
60 Requires:       hicolor-icon-theme
61 Requires:       json-glib >= 1.0
62 Requires:       libexif >= 1:0.6.16
63 Requires:       libgee >= 0.8.5
64 Requires:       libgphoto2 >= 2.5.0
65 Requires:       libraw >= 0.14.7-2
66 Requires:       libsoup >= 2.26.0
67 Requires:       libxml2 >= 1:2.6.32
68 %{?with_opencv:Requires:        opencv >= 1:3.4.0}
69 Requires:       sqlite3 >= 3.5.9
70 Requires:       udev-glib >= 1:145
71 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
72
73 %description
74 Shotwell is a digital photo organizer designed for the GNOME desktop
75 environment. It allows you to import photos from disk or camera,
76 organize them in various ways, view them in full-window or fullscreen
77 mode, and export them to share with others.
78
79 %description -l pl.UTF-8
80 Shotwell to organizator zdjęć cyfrowych, zaprojektowany dla środowiska
81 graficznego GNOME. Pozwala importować zdjęcia z dysku lub aparatu,
82 organizować je na różne sposoby, przeglądać w trybie okienkowym lub
83 pełnoekranowym oraz eksportować, aby podzielić się nimi z innymi.
84
85 %prep
86 %setup -q
87
88 %build
89 %meson build \
90         --default-library=shared \
91         %{?with_opencv:-Dface-detection=true} \
92         %{!?with_apport:-Dinstall-apport-hook=false} \
93         %{?with_unity:-Dunity-support=true}
94
95 %ninja_build -C build
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99
100 %ninja_install -C build
101
102 # API not exported, so no need for development symlinks
103 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libshotwell-*.so
104
105 %find_lang shotwell --with-gnome
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %post
111 /sbin/ldconfig
112 %update_icon_cache hicolor
113 %update_desktop_database
114 %glib_compile_schemas
115
116 %postun
117 /sbin/ldconfig
118 %update_icon_cache hicolor
119 %update_desktop_database_postun
120 %glib_compile_schemas
121
122 %files -f shotwell.lang
123 %defattr(644,root,root,755)
124 %doc AUTHORS COPYING MAINTAINERS NEWS README.md THANKS
125 %attr(755,root,root) %{_bindir}/shotwell
126 %attr(755,root,root) %{_libdir}/libshotwell-authenticator.so.*.*.*
127 %attr(755,root,root) %ghost %{_libdir}/libshotwell-authenticator.so.0
128 %attr(755,root,root) %{_libdir}/libshotwell-plugin-common.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libshotwell-plugin-common.so.0
130 %attr(755,root,root) %{_libdir}/libshotwell-plugin-dev-1.0.so.*.*.*
131 %attr(755,root,root) %ghost %{_libdir}/libshotwell-plugin-dev-1.0.so.0
132 %if "%{_libexecdir}" != "%{_libdir}"
133 %dir %{_libexecdir}/%{name}
134 %endif
135 %if %{with opencv}
136 %attr(755,root,root) %{_libexecdir}/%{name}/shotwell-facedetect
137 %endif
138 %attr(755,root,root) %{_libexecdir}/%{name}/shotwell-settings-migrator
139 %attr(755,root,root) %{_libexecdir}/%{name}/shotwell-video-thumbnailer
140 %dir %{_libdir}/%{name}
141 %dir %{_libdir}/%{name}/plugins
142 %dir %{_libdir}/%{name}/plugins/builtin
143 %attr(755,root,root) %{_libdir}/%{name}/plugins/builtin/libshotwell-publishing.so
144 %attr(755,root,root) %{_libdir}/%{name}/plugins/builtin/libshotwell-publishing-extras.so
145 %attr(755,root,root) %{_libdir}/%{name}/plugins/builtin/libshotwell-transitions.so
146 %if %{with opencv}
147 %dir %{_datadir}/%{name}
148 %{_datadir}/%{name}/facedetect-haarcascade.xml
149 %endif
150 %if %{with apport}
151 %{_datadir}/apport/package-hooks/shotwell.py
152 %endif
153 %{_datadir}/glib-2.0/schemas/org.yorba.shotwell.gschema.xml
154 %{_datadir}/glib-2.0/schemas/org.yorba.shotwell-extras.gschema.xml
155 %{_datadir}/metainfo/shotwell.appdata.xml
156 %{_desktopdir}/shotwell.desktop
157 %{_desktopdir}/shotwell-viewer.desktop
158 %{_iconsdir}/hicolor/*x*/apps/shotwell.png
159 %{_iconsdir}/hicolor/symbolic/apps/shotwell-symbolic.svg
160 %{_mandir}/man1/shotwell.1*
This page took 0.08348 seconds and 2 git commands to generate.