]> git.pld-linux.org Git - packages/shaderc.git/blob - shaderc.spec
up to 2019.0
[packages/shaderc.git] / shaderc.spec
1 # TODO: glslc docs using asciidoctor
2 Summary:        Collection of tools, libraries and tests for shader compilation
3 Summary(pl.UTF-8):      Zestaw narzędzi, bibliotek i testów do kompilacji shaderów
4 Name:           shaderc
5 Version:        2019.0
6 Release:        1
7 License:        Apache v2.0
8 Group:          Libraries
9 #Source0Download: https://github.com/google/shaderc/releases
10 Source0:        https://github.com/google/shaderc/archive/v%{version}.tar.gz
11 # Source0-md5:  8eb2b40712db2762a5cc40b568fd8ad9
12 #Source0:       https://github.com/google/shaderc/archive/v%{version}/%{name}-%{version}.tar.gz
13 Patch0:         %{name}-system-libs.patch
14 Patch1:         %{name}-shared.patch
15 URL:            https://github.com/google/shaderc
16 # for docs
17 #BuildRequires: asciidoctor
18 BuildRequires:  cmake >= 2.8.12
19 BuildRequires:  glslang-devel >= 7.12.3352
20 BuildRequires:  python >= 2
21 BuildRequires:  spirv-tools
22 BuildRequires:  spirv-tools-devel >= 1:2019.4
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 A collection of tools, libraries and tests for shader compilation. At
27 the moment it includes:
28  - glslc, a command line compiler for GLSL/HLSL to SPIR-V, and
29  - libshaderc, a library API for doing the same.
30
31 Shaderc wraps around core functionality in glslang and SPIRV-Tools.
32 Shaderc aims to to provide:
33  - a command line compiler with GCC- and Clang-like usage, for better
34    integration with build systems
35  - an API where functionality can be added without breaking existing
36    clients
37  - an API supporting standard concurrency patterns across multiple
38    operating systems
39  - increased functionality such as file #include support
40
41 %description -l pl.UTF-8
42 Zestaw narzędzi, bibliotek i testów do kompilacji shaderów. Obecnie
43 zawiera:
44  - glslc - kompilator linii poleceń dla GLSL/HLSL do SPIR-V
45  - libshaderc - biblioteka do tego samego
46
47 Shaderc obudowuje podstawową funkcjonalność glslang i SPIRV-Tools.
48 Celem shaderc jest zapewnienie:
49  - kompilatora linii poleceń używalnego podobnie do GCC czy Clang
50    (w celu lepszej integracji z systemami budowania)
51  - API, do którego można dodawać funkcjonalność bez psucia
52    istniejących klientów
53  - API obsługującego standardowe wzorce współbieżności na wielu
54    systemach operacyjnych
55  - zwiększonej funkcjonalności, np. obsługi #include
56
57 %package devel
58 Summary:        Header files for shaderc library
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki shaderc
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62
63 %description devel
64 Header files for shaderc library.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe biblioteki shaderc.
68
69 %package static
70 Summary:        Static shaderc libraries
71 Summary(pl.UTF-8):      Statyczne biblioteki shaderc
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Static shaderc libraries.
77
78 %description static -l pl.UTF-8
79 Statyczne biblioteki shaderc.
80
81 %prep
82 %setup -q
83 %patch0 -p1
84 %patch1 -p1
85
86 %build
87 install -d build
88 cd build
89 %cmake .. \
90         -DSHADERC_SKIP_TESTS=ON
91
92 %{__make}
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96
97 %{__make} -C build install \
98         DESTDIR=$RPM_BUILD_ROOT
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %post   -p /sbin/ldconfig
104 %postun -p /sbin/ldconfig
105
106 %files
107 %defattr(644,root,root,755)
108 %doc AUTHORS CHANGES CONTRIBUTORS README.md  glslc/README.asciidoc
109 %attr(755,root,root) %{_bindir}/glslc
110 %attr(755,root,root) %{_libdir}/libshaderc.so.1
111
112 %files devel
113 %defattr(644,root,root,755)
114 %attr(755,root,root) %{_libdir}/libshaderc.so
115 %{_includedir}/shaderc
116 %{_pkgconfigdir}/shaderc.pc
117 %{_pkgconfigdir}/shaderc_combined.pc
118 %{_pkgconfigdir}/shaderc_static.pc
119
120 %files static
121 %defattr(644,root,root,755)
122 %{_libdir}/libshaderc.a
123 %{_libdir}/libshaderc_combined.a
This page took 0.067924 seconds and 3 git commands to generate.