]> git.pld-linux.org Git - packages/serf.git/blob - serf.spec
rel 6
[packages/serf.git] / serf.spec
1 #
2 # Conditional build:
3 %bcond_without  kerberos5       # GSSAPI support
4 %bcond_with     tests           # perform "scons check" (uses localhost network, fails on apr side when IPV6 is enabled and localhost resolves only to IPV4 addresses)
5 #
6 Summary:        A high-performance asynchronous HTTP client library
7 Summary(pl.UTF-8):      Wysokowydajna biblioteka asynchronicznego klienta HTTP
8 Name:           serf
9 Version:        1.3.9
10 Release:        6
11 License:        Apache v2.0
12 Group:          Libraries
13 Source0:        https://www.apache.org/dist/serf/%{name}-%{version}.tar.bz2
14 # Source0-md5:  370a6340ff20366ab088012cd13f2b57
15 Patch0:         %{name}-scons.patch
16 Patch1:         openssl3.patch
17 Patch2:         bio-ctrl.patch
18 Patch3:         python3.patch
19 URL:            https://serf.apache.org/
20 BuildRequires:  apr-devel
21 BuildRequires:  apr-util-devel
22 %{?with_kerberos5:BuildRequires:        heimdal-devel}
23 BuildRequires:  openssl-devel >= 0.9.7d
24 BuildRequires:  scons >= 2.3.0
25 BuildRequires:  zlib-devel
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The serf library is a C-based HTTP client library built upon the
30 Apache Portable Runtime (APR) library. It multiplexes connections,
31 running the read/write communication asynchronously. Memory copies and
32 transformations are kept to a minimum to provide high performance
33 operation.
34
35 %description -l pl.UTF-8
36 Biblioteka serf to napisana w C biblioteka klienta HTTP stworzona w
37 oparciu o bibliotekę Apache Portable Runtime (APR). Obsługuje
38 połączenia naprzemiennie, wywołując asynchronicznie komunikację
39 odczyt-zapis. Kopiowanie i transformacje w pamięci są ograniczone do
40 minimum w celu zapewnienia wydajnego działania.
41
42 %package devel
43 Summary:        Header files for serf
44 Summary(pl.UTF-8):      Pliki nagłówkowe serf
45 Group:          Development/Libraries
46 Requires:       %{name} = %{version}-%{release}
47 Requires:       apr-devel
48 Requires:       apr-util-devel
49 %{?with_kerberos5:Requires:     heimdal-devel}
50 Requires:       openssl-devel >= 0.9.7d
51
52 %description devel
53 C header files for the serf library.
54
55 %description devel -l pl.UTF-8
56 Pliki nagłówkowe dla biblioteki serf.
57
58 %package static
59 Summary:        Static libraries for serf
60 Summary(pl.UTF-8):      Biblioteki statyczne serf
61 Group:          Development/Libraries
62 Requires:       %{name}-devel = %{version}-%{release}
63
64 %description static
65 Static serf libraries.
66
67 %description static -l pl.UTF-8
68 Statyczne biblioteki serf.
69
70 %prep
71 %setup -q
72 %patch0 -p1
73 %patch1 -p1
74 %patch2 -p1
75 %patch3 -p0
76
77 %build
78 %scons \
79         PREFIX=%{_prefix} \
80         LIBDIR=%{_libdir} \
81         GSSAPI=/usr
82
83 %if %{with tests}
84 %scons check
85 %endif
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %scons install \
91         PREFIX=%{_prefix} \
92         LIBDIR=%{_libdir} \
93         --install-sandbox=$RPM_BUILD_ROOT
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/ldconfig
99 %postun -p /sbin/ldconfig
100
101 %files
102 %defattr(644,root,root,755)
103 %doc CHANGES NOTICE README
104 %attr(755,root,root) %{_libdir}/libserf-1.so.*.*.*
105 %attr(755,root,root) %ghost %{_libdir}/libserf-1.so.1
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/libserf-1.so
110 %{_includedir}/serf-1
111 %{_pkgconfigdir}/serf-1.pc
112
113 %files static
114 %defattr(644,root,root,755)
115 %{_libdir}/libserf-1.a
This page took 0.070393 seconds and 3 git commands to generate.