]> git.pld-linux.org Git - packages/serf.git/blob - serf.spec
b062e2bc0b85cee2fd2dc8a354dd939654829455
[packages/serf.git] / serf.spec
1 #
2 # Conditional build:
3 %bcond_without  kerberos5       # GSSAPI support
4 %bcond_with     tests           # perform "scons check" (uses localhost network, fails on apr side when IPV6 is enabled and localhost resolves only to IPV4 addresses)
5 #
6 Summary:        A high-performance asynchronous HTTP client library
7 Summary(pl.UTF-8):      Wysokowydajna biblioteka asynchronicznego klienta HTTP
8 Name:           serf
9 Version:        1.3.9
10 Release:        5
11 License:        Apache v2.0
12 Group:          Libraries
13 Source0:        https://www.apache.org/dist/serf/%{name}-%{version}.tar.bz2
14 # Source0-md5:  370a6340ff20366ab088012cd13f2b57
15 Patch0:         %{name}-scons.patch
16 Patch1:         openssl3.patch
17 Patch2:         bio-ctrl.patch
18 URL:            https://serf.apache.org/
19 BuildRequires:  apr-devel
20 BuildRequires:  apr-util-devel
21 %{?with_kerberos5:BuildRequires:        heimdal-devel}
22 BuildRequires:  openssl-devel >= 0.9.7d
23 BuildRequires:  scons >= 2.3.0
24 BuildRequires:  zlib-devel
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The serf library is a C-based HTTP client library built upon the
29 Apache Portable Runtime (APR) library. It multiplexes connections,
30 running the read/write communication asynchronously. Memory copies and
31 transformations are kept to a minimum to provide high performance
32 operation.
33
34 %description -l pl.UTF-8
35 Biblioteka serf to napisana w C biblioteka klienta HTTP stworzona w
36 oparciu o bibliotekę Apache Portable Runtime (APR). Obsługuje
37 połączenia naprzemiennie, wywołując asynchronicznie komunikację
38 odczyt-zapis. Kopiowanie i transformacje w pamięci są ograniczone do
39 minimum w celu zapewnienia wydajnego działania.
40
41 %package devel
42 Summary:        Header files for serf
43 Summary(pl.UTF-8):      Pliki nagłówkowe serf
44 Group:          Development/Libraries
45 Requires:       %{name} = %{version}-%{release}
46 Requires:       apr-devel
47 Requires:       apr-util-devel
48 %{?with_kerberos5:Requires:     heimdal-devel}
49 Requires:       openssl-devel >= 0.9.7d
50
51 %description devel
52 C header files for the serf library.
53
54 %description devel -l pl.UTF-8
55 Pliki nagłówkowe dla biblioteki serf.
56
57 %package static
58 Summary:        Static libraries for serf
59 Summary(pl.UTF-8):      Biblioteki statyczne serf
60 Group:          Development/Libraries
61 Requires:       %{name}-devel = %{version}-%{release}
62
63 %description static
64 Static serf libraries.
65
66 %description static -l pl.UTF-8
67 Statyczne biblioteki serf.
68
69 %prep
70 %setup -q
71 %patch0 -p1
72 %patch1 -p1
73 %patch2 -p1
74
75 %build
76 %scons \
77         PREFIX=%{_prefix} \
78         LIBDIR=%{_libdir} \
79         GSSAPI=/usr
80
81 %if %{with tests}
82 %scons check
83 %endif
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87
88 %scons install \
89         PREFIX=%{_prefix} \
90         LIBDIR=%{_libdir} \
91         --install-sandbox=$RPM_BUILD_ROOT
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc CHANGES NOTICE README
102 %attr(755,root,root) %{_libdir}/libserf-1.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libserf-1.so.1
104
105 %files devel
106 %defattr(644,root,root,755)
107 %attr(755,root,root) %{_libdir}/libserf-1.so
108 %{_includedir}/serf-1
109 %{_pkgconfigdir}/serf-1.pc
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/libserf-1.a
This page took 0.059547 seconds and 2 git commands to generate.