]> git.pld-linux.org Git - packages/selinux-python.git/blob - selinux-python.spec
adcfed1a1c6b26b35dc7783095435e20968adb9a
[packages/selinux-python.git] / selinux-python.spec
1 Summary:        SELinux Python policy utilities
2 Summary(pl.UTF-8):      Narzędzia do polityk SELinuksa napisane w Pythonie
3 Name:           selinux-python
4 Version:        2.9
5 Release:        1
6 License:        GPL v2 (sepolgen), GPL v2+ (semodule, sepolicy)
7 Group:          Applications/System
8 #Source0Download: https://github.com/SELinuxProject/selinux/wiki/Releases
9 Source0:        https://github.com/SELinuxProject/selinux/releases/download/20190315/%{name}-%{version}.tar.gz
10 # Source0-md5:  e9dfedd1139dd9998f5a09abfb670454
11 URL:            https://github.com/SELinuxProject/selinux/wiki
12 BuildRequires:  libsepol-static >= 2.7
13 BuildRequires:  python3-modules
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.714
16 Requires:       policycoreutils >= 2.7
17 Requires:       python3-sepolicy = %{version}-%{release}
18 Obsoletes:      policycoreutils-sepolicy < 2.7
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Security-enhanced Linux is a patch of the Linux kernel and a number of
23 utilities with enhanced security functionality designed to add
24 mandatory access controls to Linux. The Security-enhanced Linux kernel
25 contains new architectural components originally developed to improve
26 the security of the Flask operating system. These architectural
27 components provide general support for the enforcement of many kinds
28 of mandatory access control policies, including those based on the
29 concepts of Type Enforcement, Role-based Access Control, and
30 Multi-level Security.
31
32 This package contains Python based SELinux policy utilities.
33
34 %description -l pl.UTF-8
35 Security-enhanced Linux jest prototypem jądra Linuksa i wielu
36 aplikacji użytkowych o funkcjach podwyższonego bezpieczeństwa.
37 Zaprojektowany jest tak, aby w prosty sposób ukazać znaczenie
38 obowiązkowej kontroli dostępu dla społeczności linuksowej. Ukazuje
39 również jak taką kontrolę można dodać do istniejącego systemu typu
40 Linux. Jądro SELinux zawiera nowe składniki architektury pierwotnie
41 opracowane w celu ulepszenia bezpieczeństwa systemu operacyjnego
42 Flask. Te elementy zapewniają ogólne wsparcie we wdrażaniu wielu typów
43 polityk obowiązkowej kontroli dostępu, włączając te wzorowane na: Type
44 Enforcement (TE), kontroli dostępu opartej na rolach (RBAC) i
45 zabezpieczeniach wielopoziomowych.
46
47 Ten pakiet zawiera narzędzia do polityk SELinuksa napisane w Pythonie.
48
49 %package -n bash-completion-%{name}
50 Summary:        Bash completion for semanage and sepolicy commands
51 Summary(pl.UTF-8):      Bashowe dopełnianie składni poleceń semanage i sepolicy
52 Group:          Applications/Shells
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       bash-completion >= 2
55
56 %description -n bash-completion-%{name}
57 Bash completion for semanage and sepolicy commands.
58
59 %description -n bash-completion-%{name} -l pl.UTF-8
60 Bashowe dopełnianie składni poleceń semanage i sepolicy.
61
62 %package -n python3-sepolgen
63 Summary:        sepolgen - Python 3 module for policy generation
64 Summary(pl.UTF-8):      Moduł Pythona 3 sepolgen do generowania polityki
65 License:        GPL v2
66 Group:          Python/Libraries
67 Requires:       python3-selinux >= 2.7
68 Suggests:       python3-setools
69 Obsoletes:      python-sepolgen-common < 2.9-1
70 BuildArch:      noarch
71
72 %description -n python3-sepolgen
73 sepolgen - Python module for policy generation.
74
75 %description -n python3-sepolgen -l pl.UTF-8
76 Moduł Pythona sepolgen do generowania polityki.
77
78 %package -n python3-sepolicy
79 Summary:        Python modules for SELinux policy manipulation
80 Summary(pl.UTF-8):      Moduły Pythona do operowania na politykach SELinuksa
81 Group:          Python/Libraries
82 # seobject and sepolicy use translations from policycoreutils domain
83 Requires:       policycoreutils >= 2.7
84 Requires:       python3-IPy
85 Requires:       python3-dbus
86 Requires:       python3-semanage >= 2.7
87 Requires:       python3-sepolgen = %{version}-%{release}
88 Requires:       python3-setools
89 Requires:       python3-slip-dbus
90 # for sepolicy.gui additionally:
91 Requires:       gtk+3 >= 3
92 Requires:       python3-pygobject3 >= 3
93 Conflicts:      policycoreutils-sepolicy < 2.7
94
95 %description -n python3-sepolicy
96 Python modules for SELinux policy manipulation.
97
98 %description -n python3-sepolicy -l pl.UTF-8
99 Moduły Pythona do operowania na politykach SELinuksa.
100
101 %prep
102 %setup -q
103
104 %build
105 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
106 %{__make} \
107         CC="%{__cc}" \
108         LIBDIR="%{_libdir}"
109
110 %install
111 rm -rf $RPM_BUILD_ROOT
112
113 %{__make} install \
114         DESTDIR=$RPM_BUILD_ROOT \
115         PYTHONLIBDIR=%{py3_sitescriptdir} \
116         LIBSEPOLA=%{_libdir}/libsepol.a
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %files
122 %defattr(644,root,root,755)
123 %attr(755,root,root) %{_bindir}/audit2allow
124 %attr(755,root,root) %{_bindir}/audit2why
125 %attr(755,root,root) %{_bindir}/chcat
126 %attr(755,root,root) %{_bindir}/sepolgen
127 %attr(755,root,root) %{_bindir}/sepolgen-ifgen
128 %attr(755,root,root) %{_bindir}/sepolgen-ifgen-attr-helper
129 %attr(755,root,root) %{_bindir}/sepolicy
130 %attr(755,root,root) %{_sbindir}/semanage
131 %{_mandir}/man1/audit2allow.1*
132 %{_mandir}/man1/audit2why.1*
133 %{_mandir}/man8/chcat.8*
134 %{_mandir}/man8/sepolgen.8*
135 %{_mandir}/man8/sepolicy*.8*
136 %{_mandir}/man8/semanage*.8*
137 %lang(ru) %{_mandir}/ru/man*/*
138
139 %files -n bash-completion-%{name}
140 %defattr(644,root,root,755)
141 %{bash_compdir}/semanage
142 %{bash_compdir}/sepolicy
143
144 %files -n python3-sepolgen
145 %defattr(644,root,root,755)
146 %{py3_sitescriptdir}/sepolgen
147 %dir /var/lib/sepolgen
148 %config(noreplace) %verify(not md5 mtime size) /var/lib/sepolgen/perm_map
149
150 %files -n python3-sepolicy
151 %defattr(644,root,root,755)
152 %{py3_sitescriptdir}/seobject.py
153 %dir %{py3_sitedir}/sepolicy
154 /usr/lib64/python3.7/site-packages/sepolicy/__pycache__
155 %{py3_sitedir}/sepolicy/*.py
156 %{py3_sitedir}/sepolicy/sepolicy.glade
157 %dir %{py3_sitedir}/sepolicy/help
158 /usr/lib64/python3.7/site-packages/sepolicy/help/__pycache__
159 %{py3_sitedir}/sepolicy/help/__init__.py
160 %{py3_sitedir}/sepolicy/help/*.png
161 %{py3_sitedir}/sepolicy/help/*.txt
162 %dir %{py3_sitedir}/sepolicy/templates
163 /usr/lib64/python3.7/site-packages/sepolicy/templates/__pycache__
164 %{py3_sitedir}/sepolicy/templates/*.py
165 %{py3_sitedir}/sepolicy-1.1-py*.egg-info
This page took 0.047422 seconds and 2 git commands to generate.