]> git.pld-linux.org Git - packages/selinux-python.git/blob - selinux-python.spec
rebuild with python 3.10
[packages/selinux-python.git] / selinux-python.spec
1 Summary:        SELinux Python policy utilities
2 Summary(pl.UTF-8):      Narzędzia do polityk SELinuksa napisane w Pythonie
3 Name:           selinux-python
4 Version:        3.1
5 Release:        2
6 License:        GPL v2 (sepolgen), GPL v2+ (semodule, sepolicy)
7 Group:          Applications/System
8 #Source0Download: https://github.com/SELinuxProject/selinux/wiki/Releases
9 Source0:        https://github.com/SELinuxProject/selinux/releases/download/20200710/%{name}-%{version}.tar.gz
10 # Source0-md5:  ec75687b680e0dd63e3ded05bd41cb5a
11 URL:            https://github.com/SELinuxProject/selinux/wiki
12 BuildRequires:  libsepol-static >= 3.1
13 BuildRequires:  python3-modules
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.714
16 # audit2allow requires sepolgen,selinux modules
17 # chcat requires selinux,seobject modules and "policycoreutils" translations domain
18 # semanage requires seobject module (part of semanage in fact) and "policycoreutils" translations domain
19 Requires:       policycoreutils >= 3.1
20 Requires:       python3-selinux >= 3.1
21 Requires:       python3-sepolicy = %{version}-%{release}
22 Obsoletes:      policycoreutils-sepolicy < 2.7
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Security-enhanced Linux is a patch of the Linux kernel and a number of
27 utilities with enhanced security functionality designed to add
28 mandatory access controls to Linux. The Security-enhanced Linux kernel
29 contains new architectural components originally developed to improve
30 the security of the Flask operating system. These architectural
31 components provide general support for the enforcement of many kinds
32 of mandatory access control policies, including those based on the
33 concepts of Type Enforcement, Role-based Access Control, and
34 Multi-level Security.
35
36 This package contains Python based SELinux policy utilities.
37
38 %description -l pl.UTF-8
39 Security-enhanced Linux jest prototypem jądra Linuksa i wielu
40 aplikacji użytkowych o funkcjach podwyższonego bezpieczeństwa.
41 Zaprojektowany jest tak, aby w prosty sposób ukazać znaczenie
42 obowiązkowej kontroli dostępu dla społeczności linuksowej. Ukazuje
43 również jak taką kontrolę można dodać do istniejącego systemu typu
44 Linux. Jądro SELinux zawiera nowe składniki architektury pierwotnie
45 opracowane w celu ulepszenia bezpieczeństwa systemu operacyjnego
46 Flask. Te elementy zapewniają ogólne wsparcie we wdrażaniu wielu typów
47 polityk obowiązkowej kontroli dostępu, włączając te wzorowane na: Type
48 Enforcement (TE), kontroli dostępu opartej na rolach (RBAC) i
49 zabezpieczeniach wielopoziomowych.
50
51 Ten pakiet zawiera narzędzia do polityk SELinuksa napisane w Pythonie.
52
53 %package -n bash-completion-%{name}
54 Summary:        Bash completion for semanage and sepolicy commands
55 Summary(pl.UTF-8):      Bashowe dopełnianie składni poleceń semanage i sepolicy
56 Group:          Applications/Shells
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       bash-completion >= 2
59
60 %description -n bash-completion-%{name}
61 Bash completion for semanage and sepolicy commands.
62
63 %description -n bash-completion-%{name} -l pl.UTF-8
64 Bashowe dopełnianie składni poleceń semanage i sepolicy.
65
66 %package -n python3-sepolgen
67 Summary:        sepolgen - Python 3 module for policy generation
68 Summary(pl.UTF-8):      Moduł Pythona 3 sepolgen do generowania polityki
69 License:        GPL v2
70 Group:          Libraries/Python
71 Requires:       python3-selinux >= 3.1
72 Suggests:       python3-setools
73 Obsoletes:      python-sepolgen-common < 2.9-1
74 BuildArch:      noarch
75
76 %description -n python3-sepolgen
77 sepolgen - Python module for policy generation.
78
79 %description -n python3-sepolgen -l pl.UTF-8
80 Moduł Pythona sepolgen do generowania polityki.
81
82 %package -n python3-sepolicy
83 Summary:        Python modules for SELinux policy manipulation
84 Summary(pl.UTF-8):      Moduły Pythona do operowania na politykach SELinuksa
85 Group:          Libraries/Python
86 # seobject uses selinux,semanage,sepolicy,setools +IPy modules and "policycoreutils" translations domain
87 # seobject and sepolicy use translations from policycoreutils domain
88 Requires:       policycoreutils >= 3.1
89 Requires:       python3-IPy
90 Requires:       python3-dbus
91 Requires:       python3-semanage >= 3.1
92 Requires:       python3-sepolgen = %{version}-%{release}
93 Requires:       python3-setools
94 Requires:       python3-slip-dbus
95 # for sepolicy.gui additionally:
96 Requires:       gtk+3 >= 3
97 Requires:       python3-pygobject3 >= 3
98 Conflicts:      policycoreutils-sepolicy < 2.7
99
100 %description -n python3-sepolicy
101 Python modules for SELinux policy manipulation.
102
103 %description -n python3-sepolicy -l pl.UTF-8
104 Moduły Pythona do operowania na politykach SELinuksa.
105
106 %prep
107 %setup -q
108
109 %build
110 CFLAGS="%{rpmcflags} %{rpmcppflags}" \
111 %{__make} \
112         CC="%{__cc}" \
113         LIBDIR="%{_libdir}"
114
115 %install
116 rm -rf $RPM_BUILD_ROOT
117
118 %{__make} install \
119         DESTDIR=$RPM_BUILD_ROOT \
120         PYTHONLIBDIR=%{py3_sitescriptdir} \
121         LIBSEPOLA=%{_libdir}/libsepol.a
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %files
127 %defattr(644,root,root,755)
128 %attr(755,root,root) %{_bindir}/audit2allow
129 %attr(755,root,root) %{_bindir}/audit2why
130 %attr(755,root,root) %{_bindir}/chcat
131 %attr(755,root,root) %{_bindir}/sepolgen
132 %attr(755,root,root) %{_bindir}/sepolgen-ifgen
133 %attr(755,root,root) %{_bindir}/sepolgen-ifgen-attr-helper
134 %attr(755,root,root) %{_bindir}/sepolicy
135 %attr(755,root,root) %{_sbindir}/semanage
136 %{_mandir}/man1/audit2allow.1*
137 %{_mandir}/man1/audit2why.1*
138 %{_mandir}/man8/chcat.8*
139 %{_mandir}/man8/semanage*.8*
140 %{_mandir}/man8/sepolgen.8*
141 %{_mandir}/man8/sepolicy*.8*
142 %lang(ru) %{_mandir}/ru/man1/audit2allow.1*
143 %lang(ru) %{_mandir}/ru/man1/audit2why.1*
144 %lang(ru) %{_mandir}/ru/man8/chcat.8*
145 %lang(ru) %{_mandir}/ru/man8/semanage*.8*
146 %lang(ru) %{_mandir}/ru/man8/sepolgen.8*
147 %lang(ru) %{_mandir}/ru/man8/sepolicy*.8*
148
149 %files -n bash-completion-%{name}
150 %defattr(644,root,root,755)
151 %{bash_compdir}/semanage
152 %{bash_compdir}/sepolicy
153
154 %files -n python3-sepolgen
155 %defattr(644,root,root,755)
156 %{py3_sitescriptdir}/sepolgen
157 %dir /var/lib/sepolgen
158 %config(noreplace) %verify(not md5 mtime size) /var/lib/sepolgen/perm_map
159
160 %files -n python3-sepolicy
161 %defattr(644,root,root,755)
162 %{py3_sitescriptdir}/seobject.py
163 %dir %{py3_sitedir}/sepolicy
164 %{py3_sitedir}/sepolicy/__pycache__
165 %{py3_sitedir}/sepolicy/*.py
166 %{py3_sitedir}/sepolicy/sepolicy.glade
167 %dir %{py3_sitedir}/sepolicy/help
168 %{py3_sitedir}/sepolicy/help/__pycache__
169 %{py3_sitedir}/sepolicy/help/__init__.py
170 %{py3_sitedir}/sepolicy/help/*.png
171 %{py3_sitedir}/sepolicy/help/*.txt
172 %dir %{py3_sitedir}/sepolicy/templates
173 %{py3_sitedir}/sepolicy/templates/__pycache__
174 %{py3_sitedir}/sepolicy/templates/*.py
175 %{py3_sitedir}/sepolicy-%{version}-py*.egg-info
This page took 0.073872 seconds and 3 git commands to generate.