]> git.pld-linux.org Git - packages/sed.git/blob - sed.spec
72f44e08c6d19ada82bc9f64da4a1b0da183b0c9
[packages/sed.git] / sed.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make check"
4
5 Summary:        A GNU stream text editor
6 Summary(de.UTF-8):      GNU Stream-Text Editor
7 Summary(es.UTF-8):      Editor de stream de la GNU
8 Summary(fr.UTF-8):      Éditeur de flot de GNU
9 Summary(ja.UTF-8):      GNU ストリームテキストエディター
10 Summary(pl.UTF-8):      Edytor GNU strumienia tekstu
11 Summary(pt_BR.UTF-8):   Editor de stream da GNU
12 Summary(ru.UTF-8):      Потоковый редактор текста GNU
13 Summary(tr.UTF-8):      GNU dosya işleme aracı
14 Summary(uk.UTF-8):      Потоковий редактор тексту GNU
15 Name:           sed
16 Version:        4.8
17 Release:        1
18 License:        GPL v3+
19 Group:          Applications/Text
20 Source0:        http://ftp.gnu.org/gnu/sed/%{name}-%{version}.tar.xz
21 # Source0-md5:  6d906edfdb3202304059233f51f9a71d
22 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
23 # Source1-md5:  5cd651063bfc00a82d820ba018672351
24 Patch0:         %{name}-info.patch
25 URL:            http://www.gnu.org/software/sed/
26 BuildRequires:  acl-devel
27 BuildRequires:  autoconf >= 2.64
28 BuildRequires:  automake >= 1:1.11.1
29 BuildRequires:  gettext-tools >= 0.19.2
30 BuildRequires:  libselinux-devel
31 BuildRequires:  tar >= 1:1.22
32 BuildRequires:  texinfo
33 BuildRequires:  xz
34 %if %{with tests}
35 BuildRequires:  bash
36 %if "%(locale -a | grep -q '^ru_RU\.utf8$' ; echo $?)" == "1"
37 BuildRequires:  glibc-localedb-all
38 %endif
39 %endif
40 Obsoletes:      ssed
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _bindir         /bin
44
45 %description
46 The sed (Stream EDitor) editor is a stream or batch (non-interactive)
47 editor. Sed takes text as input, performs an operation or set of
48 operations on the text and outputs the modified text. The operations
49 that sed performs (substitutions, deletions, insertions, etc.) can be
50 specified in a script file or from the command line.
51
52 %description -l de.UTF-8
53 sed (Stream EDitor) ist ein Stream- oder Batch- (nicht-interaktiver)
54 Editor. Sed nimmt als Eingabe einen Text, führt darauf Operationen
55 aus, und gibt einen veränderten Text aus. Die Operationen, die sed
56 ausführt (Ersetzen, Löschen, Einfügen, usw.) können über eine
57 Skriptdatei oder über die Kommandozeile angegeben werden.
58
59 %description -l es.UTF-8
60 Sed copia los archivos nombrados (archivos de la entrada padrón por
61 por defecto) para la salida padrón, editado de acuerdo con un script
62 de comandos.
63
64 %description -l fr.UTF-8
65 sed copie les fichiers indiqués (l'entrée standard par défaut),
66 modifiés en fonction d'un script de commandes, vers la sortie
67 standard.
68
69 %description -l ja.UTF-8
70 sed (Stream Editor)
71 エディターはストリームまたはバッチ(非インタラクティブ)
72 エディターです。sed は入力としてテキストを用い、テキストの操作または
73 操作のセットをテキストとに対して行い、修正されたテキストを出力します。
74 sed が行う操作 (置換、削除、挿入、その他) はスクリプトファイルか、
75 コマンドラインから指定されます。
76
77 %description -l pl.UTF-8
78 Sed (Stream EDitor) jest edytorem strumieni lub wsadowym
79 (nieinteraktywnym) edytorem. Sed pobiera tekst na wejściu, przetwarza
80 go według zestawu operacji i oddaje na wyjściu przetworzony tekst.
81 Operacje, które ma wykonywać, mogą być zapisane w postaci skryptu lub
82 podane w linii poleceń.
83
84 %description -l pt_BR.UTF-8
85 O sed copia os arquivos indicados (ou a entrada padrão caso não
86 especificado) para a saída padrão, editado de acordo com um roteiro de
87 comandos.
88
89 %description -l ru.UTF-8
90 sed (Stream EDitor) - это потоковый или пакетный (не-интерактивный)
91 редактор. sed исполняет операции над подаваемым ему на вход текстом и
92 выдает модифицированный текст. Операции, которые sed выполняет
93 (подстановки, удаления, вставки и др.) могут быть заданы в файле
94 сценария или с командной строки.
95
96 %description -l tr.UTF-8
97 Sed, belirtilen dosyaları, verilen komutlara göre işleyerek standart
98 çıktıya kopyalar. Genellikle, metin dosyalarında bir katarın yerine
99 başka bir katar yazmakta kullanılır.
100
101 %description -l uk.UTF-8
102 sed (Stream EDitor) - це потоковий чи пакетний (не-інтерактивний)
103 редактор. sed виконує операції над текстом, що подається йому на вхід
104 та виводить модифікований текст. Операції, які sed виконує
105 (підстановки, видалення, вставки та ін.) можуть бути задані в файлі
106 сценарію чи з командного рядка.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111
112 # /etc/resolv.conf is stubbed on builders, change to something readable
113 %{__sed} -i -e 's,"/etc/resolv\.conf","/etc/passwd",' gnulib-tests/test-read-file.c
114
115 %build
116 %configure \
117         --disable-silent-rules
118 %{__make}
119
120 # LC_ALL=C overrides LANG which is required to run tests
121 unset LC_ALL
122 %{?with_tests:%{__make} check SHELL=/bin/bash}
123
124 %install
125 rm -rf $RPM_BUILD_ROOT
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
130 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.sed-non-english-man-pages
131
132 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
133
134 %find_lang %{name}
135
136 %clean
137 rm -rf $RPM_BUILD_ROOT
138
139 %post -p /sbin/postshell
140 -/usr/sbin/fix-info-dir -c %{_infodir}
141
142 %postun -p /sbin/postshell
143 -/usr/sbin/fix-info-dir -c %{_infodir}
144
145 %files -f %{name}.lang
146 %defattr(644,root,root,755)
147 %doc AUTHORS BUGS ChangeLog NEWS README THANKS
148 %attr(755,root,root) %{_bindir}/sed
149 %{_mandir}/man1/sed.1*
150 %lang(de) %{_mandir}/de/man1/sed.1*
151 %lang(fi) %{_mandir}/fi/man1/sed.1*
152 %lang(hu) %{_mandir}/hu/man1/sed.1*
153 %lang(ja) %{_mandir}/ja/man1/sed.1*
154 %lang(pl) %{_mandir}/pl/man1/sed.1*
155 %{_infodir}/sed.info*
This page took 0.05129 seconds and 2 git commands to generate.