]> git.pld-linux.org Git - packages/sddm.git/blob - sddm.spec
update BR
[packages/sddm.git] / sddm.spec
1 Summary:        QML based X11 desktop manager
2 Name:           sddm
3 Version:        0.12.0
4 Release:        1
5 License:        GPLv2+ and CC-BY-SA
6 Group:          X11/Applications
7 Source0:        https://github.com/sddm/sddm/archive/v%{version}.tar.gz
8 # Source0-md5:  e3261ac93a50c71c973cc79b85387765
9 Source10:       %{name}.pam
10 Source11:       %{name}-autologin.pam
11 Source12:       tmpfiles-%{name}.conf
12 # sample sddm.conf generated with sddm --example-config, and entries commented-out
13 Source13:       %{name}.conf
14 Source14:       Xsession
15 URL:            https://github.com/sddm/sddm
16 BuildRequires:  Qt5Core-devel
17 BuildRequires:  Qt5DBus-devel
18 BuildRequires:  Qt5Network-devel
19 BuildRequires:  Qt5Qml-devel
20 BuildRequires:  Qt5Quick-devel
21 BuildRequires:  Qt5Test-devel
22 BuildRequires:  cmake
23 BuildRequires:  docutils
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libxcb-devel
26 BuildRequires:  pam-devel
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-docutils
29 BuildRequires:  qt5-build
30 BuildRequires:  qt5-linguist
31 BuildRequires:  qt5-qmake
32 BuildRequires:  rpmbuild(macros) >= 1.202
33 BuildRequires:  systemd-devel
34 BuildRequires:  systemd-units
35 Provides:       XDM
36 Provides:       group(sddm)
37 Provides:       service(graphical-login) = sddm
38 Provides:       user(sddm)
39 Requires(post,preun,postun):    systemd-units >= 38
40 Requires(postun):       /usr/sbin/groupdel
41 Requires(postun):       /usr/sbin/userdel
42 Requires(pre):  /bin/id
43 Requires(pre):  /usr/sbin/groupadd
44 Requires(pre):  /usr/sbin/useradd
45 Requires:       systemd-units >= 38
46 Requires:       xinitrc-ng >= 1.0
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 SDDM is a modern display manager for X11 aiming to be fast, simple and
51 beautiful. It uses modern technologies like QtQuick, which in turn
52 gives the designer the ability to create smooth, animated user
53 interfaces.
54
55 %prep
56 %setup -q
57
58 %build
59 install -d build
60 cd build
61 %cmake \
62         -DBUILD_MAN_PAGES:BOOL=ON \
63         -DENABLE_JOURNALD:BOOL=ON \
64         -DUSE_QT5:BOOL=ON \
65         ..
66 %{__make}
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT%{_localstatedir}/{lib,run}/sddm
71 %{__make} -C build install/fast \
72         DESTDIR=$RPM_BUILD_ROOT
73
74 install -Dpm 644 %{SOURCE10} $RPM_BUILD_ROOT/etc/pam.d/sddm
75 install -Dpm 644 %{SOURCE11} $RPM_BUILD_ROOT/etc/pam.d/sddm-autologin
76 install -Dpm 644 %{SOURCE12} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/sddm.conf
77 install -Dpm 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/sddm.conf
78 install -Dpm 644 %{SOURCE14} $RPM_BUILD_ROOT%{_datadir}/sddm/scripts/Xsession
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %pre
84 %groupadd -g 323 -r -f sddm
85 %useradd -u 323 -r -d %{_localstatedir}/lib/sddm -s /bin/false -c "Simple Desktop Display Manager" -g sddm sddm
86
87 %preun
88 %systemd_preun sddm.service
89
90 %post
91 %systemd_post sddm.service
92
93 %postun
94 if [ "$1" = "0" ]; then
95         %userremove sddm
96         %groupremove sddm
97 fi
98 %systemd_reload
99
100 %files
101 %defattr(644,root,root,755)
102 %doc README.md CONTRIBUTORS
103 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sddm.conf
104 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sddm
105 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sddm-autologin
106 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/sddm-greeter
107 # it's under %{_sysconfdir}, sure, but it's not a config file
108 /etc/dbus-1/system.d/org.freedesktop.DisplayManager.conf
109 %attr(755,root,root) %{_bindir}/sddm
110 %attr(755,root,root) %{_bindir}/sddm-greeter
111 %attr(755,root,root) %{_libexecdir}/sddm-helper
112 %{systemdtmpfilesdir}/sddm.conf
113 %attr(711, root, sddm) %dir %{_localstatedir}/run/sddm
114 %attr(1770, sddm, sddm) %dir %{_localstatedir}/lib/sddm
115 %{systemdunitdir}/sddm.service
116 %{_libdir}/qt5/qml/SddmComponents/
117 %dir %{_datadir}/sddm
118 %{_datadir}/sddm/faces
119 %{_datadir}/sddm/flags
120 %dir %{_datadir}/sddm/scripts
121 %attr(755,root,root) %{_datadir}/sddm/scripts/*
122 %{_datadir}/sddm/themes
123 %{_datadir}/sddm/translations
124 %{_mandir}/man1/sddm.1*
125 %{_mandir}/man1/sddm-greeter.1*
126 %{_mandir}/man5/sddm.conf.5*
127 %{_mandir}/man5/sddm-state.conf.5*
This page took 0.083373 seconds and 3 git commands to generate.