]> git.pld-linux.org Git - packages/sdcc.git/blob - sdcc.spec
- updated to 3.6.0
[packages/sdcc.git] / sdcc.spec
1 #
2 # Conditional build:
3 %bcond_without  doc             # don't rebuild documentation
4
5 Summary:        C compiler for Intel 8051 and Zilog Z80
6 Summary(pl.UTF-8):      Kompilator C dla Intel 8051 i Zilog Z80
7 Name:           sdcc
8 Version:        3.6.0
9 Release:        1
10 License:        GPL v2+ (tools), GPL v2+ with linking exception (runtime)
11 Group:          Development/Languages
12 Source0:        http://downloads.sourceforge.net/sdcc/%{name}-src-%{version}.tar.bz2
13 # Source0-md5:  4c4cf17d8d2b2d37af66c5b7511f62d8
14 URL:            http://sdcc.sourceforge.net/
15 BuildRequires:  bison
16 BuildRequires:  boost-devel
17 BuildRequires:  flex
18 BuildRequires:  gc-devel
19 BuildRequires:  gputils
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  python >= 1:2.4
22 BuildRequires:  sed >= 4.0
23 %if %{with doc}
24 BuildRequires:  latex2html
25 BuildRequires:  lyx >= 1.4.4
26 BuildRequires:  texlive-fonts-cmsuper
27 BuildRequires:  texlive-fonts-type1-urw
28 BuildRequires:  texlive-format-pdflatex
29 BuildRequires:  texlive-latex-ams
30 BuildRequires:  texlive-makeindex
31 BuildRequires:  texlive-tex-babel
32 BuildRequires:  texlive-xetex
33 %endif
34 Obsoletes:      ucsim
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _noautostrip    .*%{_datadir}/%{name}/.*
38
39 %description
40 SDCC is retargettable, optimizing ANSI-C compiler. The current version
41 targets the Intel 8051 and recently the Zilog Z80 based MCUs. SDCC can
42 be retargeted for other 8 bit MCUs or PICs and some day soon will be.
43 Supported data types are short (8 bits, 1 byte), char (8 bits, 1
44 byte), int (16 bits, 2 bytes), long (32 bit, 4 bytes) and float (4
45 byte IEEE). SDCC also comes with the source level debugger SDCDB.
46
47 %description -l pl.UTF-8
48 SDCC jest optymalizującym kompilatorem ANSI C dla wielu platform.
49 Aktualna wersja obsługuje procesory Intel 8051 oraz Zilog Z80. SDCC
50 może być łatwo zmodyfikowany by obsługiwać inne 8-bitowe jednostki.
51 Obsługiwane typy danych to short (8 bitów, 1 bajt), char (8 bitów, 1
52 bajt), int (16 bitów, 2 bajty), long (32 bity, 4 bajty) oraz float (4
53 bajty IEEE). SDCC dostarcza również debugger oparty na emulatorze
54 ucsim.
55
56 %package -n emacs-sdcdb
57 Summary:        SDCDB debugger support for Emacs
58 Summary(pl.UTF-8):      Obsługa debuggera SDCDB dla Emacsa
59 Group:          Development/Tools
60 Requires:       %{name} = %{version}-%{release}
61 Requires:       emacs
62
63 %description -n emacs-sdcdb
64 SDCDB debugger support for Emacs.
65
66 %description -n emacs-sdcdb -l pl.UTF-8
67 Obsługa debuggera SDCDB dla Emacsa.
68
69 %prep
70 %setup -q
71
72 %{__sed} -i -e '1s,/usr/bin/env python,/usr/bin/python,' support/scripts/as2gbmap.py
73
74 %build
75 %configure \
76         PDFOPT=/bin/cp \
77         %{__enable_disable doc} \
78         --enable-libgc \
79         --enable-ucsim \
80         --enable-xa \
81         --enable-serio \
82         --enable-statistic
83
84 %{__make} -j1
85
86 %{__make} -C device/lib -j1 model-mcs51-stack-auto model-mcs51-xstack-auto
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
91
92 %{__make} install \
93         "DESTDIR=$RPM_BUILD_ROOT" \
94         "docdir=%{_docdir}/%{name}-%{version}" \
95         "STRIP=/bin/true"
96
97 %{__mv} $RPM_BUILD_ROOT%{_bindir}/*.el $RPM_BUILD_ROOT%{_datadir}/emacs/site-lisp
98
99 %{__rm} $RPM_BUILD_ROOT%{_infodir}/bfd.info*
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %files
105 %defattr(644,root,root,755)
106 %doc %{_docdir}/%{name}-%{version}
107 %attr(755,root,root) %{_bindir}/as2gbmap
108 %attr(755,root,root) %{_bindir}/makebin
109 %attr(755,root,root) %{_bindir}/packihx
110 %attr(755,root,root) %{_bindir}/s51
111 %attr(755,root,root) %{_bindir}/sdar
112 %attr(755,root,root) %{_bindir}/sdas*
113 %attr(755,root,root) %{_bindir}/sdcc
114 %attr(755,root,root) %{_bindir}/sdcclib
115 %attr(755,root,root) %{_bindir}/sdcdb
116 %attr(755,root,root) %{_bindir}/sdcpp
117 %attr(755,root,root) %{_bindir}/sdld*
118 %attr(755,root,root) %{_bindir}/sdnm
119 %attr(755,root,root) %{_bindir}/sdobjcopy
120 %attr(755,root,root) %{_bindir}/sdranlib
121 %attr(755,root,root) %{_bindir}/shc08
122 %attr(755,root,root) %{_bindir}/sstm8
123 %attr(755,root,root) %{_bindir}/sz80
124 %{_datadir}/%{name}
125
126 %files -n emacs-sdcdb
127 %defattr(644,root,root,755)
128 %{_datadir}/emacs/site-lisp/sdcdb.el
129 %{_datadir}/emacs/site-lisp/sdcdbsrc.el
This page took 0.053445 seconds and 3 git commands to generate.