]> git.pld-linux.org Git - packages/scsh.git/blob - scsh.spec
- updated URLs, more verbose files, release 2
[packages/scsh.git] / scsh.spec
1 Summary:        Unix shell embedded within Scheme
2 Summary(pl.UTF-8):      Uniksowa powłoka osadzona w Scheme
3 Name:           scsh
4 Version:        0.6.7
5 Release:        2
6 License:        BSD-like
7 Group:          Applications/Shells
8 #Source0Download: https://scsh.net/download/download.html
9 Source0:        https://ftp.scsh.net/pub/scsh/0.6/%{name}-%{version}.tar.gz
10 # Source0-md5:  69c88ca86a8aaaf0f87d253b99d339b5
11 Patch0:         %{name}-build.patch
12 Patch1:         %{name}-link.patch
13 URL:            https://scsh.net/
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  rpmbuild(macros) >= 1.213
17 Requires(post,preun):   grep
18 Requires(preun):        fileutils
19 ExcludeArch:    %{x8664} alpha ia64 ppc64 s390x sparc64
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _bindir /bin
23
24 %description
25 Scsh is a variant of Scheme 48 (an R5RS compliant new-tech Scheme
26 system). Scsh is designed for writing real-life standalone Unix
27 programs and shell scripts. Scsh spans a wide range of application,
28 from "script" applications usually handled with perl or sh, to more
29 standard systems applications usually written in C.
30
31 %description -l pl.UTF-8
32 scsh to odmiana Scheme 48 (systemu new-tech Scheme zgodnego z R5RS).
33 scsh zostął zaprojektowany do pisania rzeczywistych, samodzielnych
34 programów i skryptów powłoki pod Uniksem. scsh obejmuje szeroki zakres
35 zastosowań, od aplikacji "skryptowych" zwykle obsługiwanych przy
36 pomocy Perla lub sh do bardziej standardowych aplikacji systemowych
37 zwykle pisanych w C.
38
39 %package devel
40 Summary:        Development scsh files
41 Summary(pl.UTF-8):      Programistyczne pliki scsh
42 Group:          Development/Libraries
43
44 %description devel
45 Unix shell embedded within Scheme - development files.
46
47 %description devel -l pl.UTF-8
48 Pliki programistyczne scsh - uniksowej powłoki osadzonej w Scheme.
49
50 %prep
51 %setup -q
52 %patch0 -p1
53 %patch1 -p1
54
55 %build
56 cp -f /usr/share/automake/config.sub .
57 %{__autoconf}
58 %configure
59 %{__make}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name}/{doc,env},%{_includedir},%{_mandir}/man1}
64
65 %{__make} install \
66         DESTDIR=$RPM_BUILD_ROOT
67
68 %{__mv} $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a $RPM_BUILD_ROOT%{_libdir}
69
70 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/doc
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 umask 022
77 if [ ! -f /etc/shells ]; then
78         echo "%{_bindir}/scsh" >> /etc/shells
79 else
80         grep -q '^%{_bindir}/scsh$' /etc/shells || echo "%{_bindir}/scsh" >> /etc/shells
81 fi
82
83 %preun
84 if [ "$1" = "0" ]; then
85         umask 022
86         grep -v '^%{_bindir}/scsh$' /etc/shells > /etc/shells.new
87         mv -f /etc/shells.new /etc/shells
88 fi
89
90 %files
91 %defattr(644,root,root,755)
92 %doc doc/*/html/* doc/*.txt
93 %attr(755,root,root) %{_bindir}/scsh
94 %dir %{_libdir}/scsh
95 %{_libdir}/scsh/big
96 %{_libdir}/scsh/cig
97 %{_libdir}/scsh/env
98 %{_libdir}/scsh/link
99 %{_libdir}/scsh/misc
100 %{_libdir}/scsh/opt
101 %{_libdir}/scsh/rts
102 %{_libdir}/scsh/scsh
103 %{_libdir}/scsh/srfi
104 %{_libdir}/scsh/*.image
105 %attr(755,root,root) %{_libdir}/scsh/scshvm
106 %{_mandir}/man1/scsh.1*
107
108 %files devel
109 %defattr(644,root,root,755)
110 %{_includedir}/scheme48.h
111 %{_includedir}/write-barrier.h
112 %{_libdir}/libscsh.a
113 %{_libdir}/libscshvm.a
This page took 0.079395 seconds and 3 git commands to generate.