]> git.pld-linux.org Git - packages/scons.git/blob - scons.spec
876dac95e7269d1cc5ee0415d038ee87286ff82e
[packages/scons.git] / scons.spec
1 Summary:        An Open Source software construction tool
2 Summary(pl.UTF-8):      OpenSourcowe narzędzie do tworzenia oprogramowania
3 Name:           scons
4 Version:        3.0.5
5 Release:        1
6 License:        MIT
7 Group:          Development/Tools
8 Source0:        http://downloads.sourceforge.net/scons/%{name}-%{version}.tar.gz
9 # Source0-md5:  9f9c163e8bd48cf8cd92f03e85ca6395
10 URL:            http://www.scons.org/
11 BuildRequires:  python-devel >= 1:2.4
12 BuildRequires:  rpm-pythonprov
13 BuildRequires:  sed >= 4.0
14 %pyrequires_eq  python-modules
15 Requires:       python >= 1:2.4
16 Requires:       python-devel-tools >= 1:2.4
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 SCons is an Open Source software construction tool - that is, a build
22 tool; an improved substitute for the classic Make utility; a better
23 way to build software. SCons is based on the design which won the
24 Software Carpentry build tool design competition in August 2000.
25
26 SCons "configuration files" are Python scripts, eliminating the need
27 to learn a new build tool syntax. SCons maintains a global view of all
28 dependencies in a tree, and can scan source (or other) files for
29 implicit dependencies, such as files specified on #include lines.
30 SCons uses MD5 signatures to rebuild only when the contents of a file
31 have really changed, not just when the timestamp has been touched.
32 SCons supports side-by-side variant builds, and is easily extended
33 with user-defined Builder and/or Scanner objects.
34
35 %description -l pl.UTF-8
36 SCons to wypuszczone z ogólnodostępnymi źródłami narzędzie do
37 budowania oprogramowania; jest to ulepszony zamiennik klasycznego
38 narzędzia Make. SCons jest oparte na opracowaniu, które wygrało
39 konkurs Software Carpentry owania w sierpniu 2000.
40
41 "Pliki konfiguracyjne" SCons to skrypty Pythona, co eliminuje potrzebę
42 uczenia się składni nowego narzędzia. SCons zachowuje globalny widok
43 wszystkich zależności w drzewie i może przeszukiwać pliki źródeł (lub
44 inne) w poszukiwaniu niejawnych zależności, takich jak pliki podane w
45 liniach #include. SCons używa sygnatur MD5, aby przebudowywać tylko
46 wtedy, kiedy naprawdę się zmieniła zawartość pliku, a nie przy samej
47 zmianie czasu modyfikacji. SCons obsługuje budowanie wariantowe i jest
48 łatwo rozszerzalny przez zdefiniowane przez użytkownika obiekty
49 Builder i/lub Scanner.
50
51 %prep
52 %setup -q
53
54 %{__sed} -i -e "s,'lib','share',g" script/{scons,sconsign}
55 %{__sed} -i -e '1s,#!.*python,#!%{__python},' script/scons*
56
57 %build
58 %{__python} setup.py build
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__python} setup.py install \
64         --no-version-script \
65         --optimize=2 \
66         --root=$RPM_BUILD_ROOT \
67         --install-data=%{_datadir} \
68         --install-lib=%{py_sitescriptdir} \
69         --install-scripts=%{_bindir}
70
71 find $RPM_BUILD_ROOT%{py_sitescriptdir} -name \*.py -exec %{__rm} {} \;
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 # LICENSE.txt must be packaged (see LICENSE.txt file)
79 %doc CHANGES.txt LICENSE.txt README.txt RELEASE.txt
80 %attr(755,root,root) %{_bindir}/scons*
81 %{py_sitescriptdir}/SCons
82 %{_mandir}/man1/scons*.1*
83 %if "%{py_ver}" > "2.4"
84 %{py_sitescriptdir}/scons-%{version}-py*.egg-info
85 %endif
This page took 0.065083 seconds and 2 git commands to generate.