]> git.pld-linux.org Git - packages/scm.git/blob - scm.spec
- updated to 5f4, slib 3c1
[packages/scm.git] / scm.spec
1 %define slib_ver        3c1
2 Summary:        Scheme implementation
3 Summary(pl.UTF-8):      Implementacja Scheme
4 Name:           scm
5 Version:        5f4
6 Release:        1
7 License:        LGPL v3+
8 Group:          Development/Languages/Scheme
9 Source0:        http://groups.csail.mit.edu/mac/ftpdir/scm/%{name}-%{version}.zip
10 # Source0-md5:  d16a55cb8f4c3e56e66d34a0eae908f3
11 Source1:        http://groups.csail.mit.edu/mac/ftpdir/scm/slib-%{slib_ver}.tar.gz
12 # Source1-md5:  dec6dddb3a966e5be609848c8d08b57b
13 Patch0:         %{name}-info.patch
14 Patch1:         %{name}-install.patch
15 Patch3:         x32.patch
16 Patch5:         %{name}-make.patch
17 URL:            http://people.csail.mit.edu/jaffer/SCM
18 BuildRequires:  sed >= 4.0
19 BuildRequires:  texinfo
20 Requires:       scm-slib >= %{slib_ver}
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 SCM is a portable Scheme language implementation. SCM conforms to
25 Revised^5 Report on the Algorithmic Language Scheme and the IEEE P1178
26 specification.
27
28 %description -l pl.UTF-8
29 SCM jest przenośną implementacją języka Scheme. SCM jest zgodna ze
30 specyfikacją Revised^5 Report on the Algorithmic Language Scheme oraz
31 IEEE P1178.
32
33 %prep
34 %setup -q -c -a1
35 %patch0 -p0
36 %patch1 -p0
37 %patch3 -p0
38 %patch5 -p0
39
40 ln -s slib-%{slib_ver} slib
41
42 %{__sed} -i -e 's/install-lib install-infoz /install-lib install-info /' scm/Makefile
43
44 %{__sed} -i -e 's,/lib/,/%{_lib}/,g' scm/{Link,build,mkimpcat}.scm
45
46 %build
47 cd scm
48 # not autoconf-generated
49 ./configure \
50         --prefix=%{_prefix} \
51         --libdir=%{_libdir}
52
53 %{__make} -j1 scmflags
54 # hack to avoid remaking scmflags.h
55 touch scmflags
56
57 %{__make} scmlit \
58         CC="%{__cc} %{rpmcflags}" \
59         LD="%{__cc} %{rpmldflags} %{rpmcflags}"
60
61 # call just after making scmlit, before making scm
62 # (requires built scmlit, but "make all" makes existing scmlit outdated to make)
63 %{__make} -j1 scm.info Xlibscm.info hobbit.info
64
65 %{__make} all \
66         CC="%{__cc} %{rpmcflags}" \
67         LD="%{__cc} %{rpmldflags} %{rpmcflags}"
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71
72 %{__make} -C scm install \
73         DESTDIR=$RPM_BUILD_ROOT
74
75 # let rpm autogenerate depecdencies
76 chmod 755 $RPM_BUILD_ROOT%{_libdir}/scm/*.so
77
78 # creation handled by (noarch) scm-slib package
79 touch $RPM_BUILD_ROOT%{_libdir}/scm/slibcat
80 # at least require[s].scm expects slib in ../slib relative to %{_libdir}/scm
81 ln -sf ../share/slib $RPM_BUILD_ROOT%{_libdir}/slib
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/postshell
87 -/usr/sbin/fix-info-dir -c %{_infodir}
88
89 %postun -p /sbin/postshell
90 -/usr/sbin/fix-info-dir -c %{_infodir}
91
92 %files
93 %defattr(644,root,root,755)
94 %doc scm/{ANNOUNCE,ChangeLog,QUICKREF,README}
95 %attr(755,root,root) %{_bindir}/scm
96 %attr(755,root,root) %{_bindir}/scmlit
97 %dir %{_libdir}/scm
98 %attr(755,root,root) %{_libdir}/scm/*.so
99 %attr(755,root,root) %{_libdir}/scm/build
100 %{_libdir}/scm/*.scm
101 %{_libdir}/scm/*.h
102 %{_libdir}/scm/COPYING
103 %{_libdir}/scm/COPYING.LESSER
104 %ghost %{_libdir}/scm/slibcat
105 %{_libdir}/slib
106 %{_includedir}/scm.h
107 %{_includedir}/scmfig.h
108 %{_includedir}/scmflags.h
109 %{_mandir}/man1/scm.1*
110 %{_infodir}/Xlibscm.info*
111 %{_infodir}/hobbit.info*
112 %{_infodir}/scm.info*
This page took 0.109962 seconds and 4 git commands to generate.