]> git.pld-linux.org Git - packages/scintilla.git/blob - scintilla.spec
- rebuild with expat 2.1.0
[packages/scintilla.git] / scintilla.spec
1 Summary:        Free source code editing component for GTK+ and Win32
2 Summary(pl.UTF-8):      Wolnodostępna kontrolka edycyjna dla GTK+ i Win32
3 Name:           scintilla
4 Version:        2.27
5 %define fver    %(echo %{version} | tr -d .)
6 Release:        5
7 License:        BSD-like
8 Group:          Libraries
9 Source0:        http://downloads.sourceforge.net/scintilla/%{name}%{fver}.tgz
10 # Source0-md5:  f8a4175cb24d24dee32b05400aaea6ce
11 Patch0:         %{name}-make.patch
12 URL:            http://scintilla.org/
13 BuildRequires:  gtk+2-devel >= 1:2.0.0
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool
16 BuildRequires:  pkgconfig
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 Scintilla is a free source code editing component. It comes with
21 complete source code and a license that permits use in any free
22 project or commercial product. As well as features found in standard
23 text editing components, Scintilla includes features especially useful
24 when editing and debugging source code. These include support for
25 syntax styling, error indicators, code completion and call tips. The
26 selection margin can contain markers like those used in debuggers to
27 indicate breakpoints and the current line. Styling choices are more
28 open than with many editors, allowing the use of proportional fonts,
29 bold and italics, multiple foreground and background colours and
30 multiple fonts.
31
32 %description -l pl.UTF-8
33 Scintilla to wolnodostępna kontrolka do edycji kodu. Przychodzi z
34 pełnym kodem źródłowym i licencja pozwalającą na używanie w dowolnym
35 projekcie darmowym lub komercyjnym. Oprócz możliwości obecnych w
36 standardowych kontrolkach do edycji tekstu, Scintilla ma dodatkowe,
37 przydatne szczególnie przy edycji i szukaniu błędów w kodzie
38 źródłowym. Możliwości te obejmują obsługę stylu składni, podświetlanie
39 błędów, dopełnianie kodu i podpowiedzi. Marginesy mogą zawierać
40 znaczniki podobne do tych używanych do oznaczenia breakpointów lub
41 bieżącej linii w debuggerach. Wybór stylu jest bardziej otwarty niż w
42 wielu edytorach, pozwalając na użycie fontów proporcjonalnych,
43 pogrubionych i pochylonych, wielu kolorów pisma i tła oraz wielu
44 fontów.
45
46 %package devel
47 Summary:        scintilla header files
48 Summary(pl.UTF-8):      Pliki nagłówkowe scintilli
49 Group:          Development/Libraries
50 Requires:       %{name} = %{version}-%{release}
51 Requires:       gtk+2-devel >= 1:2.0.0
52 Requires:       libstdc++-devel
53
54 %description devel
55 scintilla header files.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe scintilli.
59
60 %package static
61 Summary:        Static scintilla library
62 Summary(pl.UTF-8):      Statyczna biblioteka scintilla
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static scintilla library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka scintilla.
71
72 %prep
73 %setup -q -n %{name}
74 %patch0 -p1
75
76 %build
77 %{__make} -C gtk \
78         CC="%{__cxx}" \
79         CCOMP="%{__cc}" \
80         OPTFLAGS="%{rpmcflags}" \
81         libdir="%{_libdir}" \
82         %{?debug:DEBUG=1}
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT%{_includedir}/%{name}
87
88 %{__make} -C gtk install \
89         libdir="%{_libdir}" \
90         DESTDIR=$RPM_BUILD_ROOT
91
92 install include/*.h $RPM_BUILD_ROOT%{_includedir}/%{name}
93
94 %clean
95 rm -rf $RPM_BUILD_ROOT
96
97 %post   -p /sbin/ldconfig
98 %postun -p /sbin/ldconfig
99
100 %files
101 %defattr(644,root,root,755)
102 %doc License.txt doc/*
103 %attr(755,root,root) %{_libdir}/libscintilla.so.*.*.*
104 %attr(755,root,root) %ghost %{_libdir}/libscintilla.so.0
105
106 %files devel
107 %defattr(644,root,root,755)
108 %attr(755,root,root) %{_libdir}/libscintilla.so
109 %{_libdir}/libscintilla.la
110 %{_includedir}/scintilla
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libscintilla.a
This page took 0.06935 seconds and 3 git commands to generate.