]> git.pld-linux.org Git - packages/schroedinger.git/blob - schroedinger.spec
- updated URL
[packages/schroedinger.git] / schroedinger.spec
1 # TODO: CUDA (as bcond)
2 #
3 # Conditional build:
4 %bcond_with     opengl  # OpenGL rendering backend (disabled by default) [missing files as of 1.0.11]
5 #
6 Summary:        Library for decoding and encoding video in the Dirac format
7 Summary(pl.UTF-8):      Biblioteka do dekodowania i kodowania obrazu w formacie Dirac
8 Name:           schroedinger
9 Version:        1.0.11
10 Release:        3
11 License:        MPL 1.1 or LGPL v2 or GPL v2 or MIT
12 Group:          Libraries
13 # formerly http://diracvideo.org/download/schroedinger/
14 Source0:        %{name}-%{version}.tar.gz
15 # Source0-md5:  da6af08e564ca1157348fb8d92efc891
16 Patch0:         %{name}-opt.patch
17 URL:            https://github.com/dschleef/schroedinger
18 %{?with_opengl:BuildRequires:   OpenGL-devel}
19 BuildRequires:  autoconf >= 2.58
20 BuildRequires:  automake >= 1.6
21 %{?with_opengl:BuildRequires:   glew-devel >= 1.5}
22 BuildRequires:  gtk-doc >= 1.0
23 BuildRequires:  libstdc++-devel
24 BuildRequires:  libtool >= 2:1.5
25 BuildRequires:  orc-devel >= 0.4.16
26 BuildRequires:  pkgconfig
27 BuildRequires:  rpmbuild(macros) >= 1.98
28 %{?with_opengl:Requires:        glew >= 1.5}
29 Requires:       orc >= 0.4.16
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Library for decoding and encoding video in the Dirac format. It is
34 implemented in ANSI C and optimized through the use of liboil.
35 libschroedinger is written as a collaboration between the BBC Research
36 and Development, David Schleef and Fluendo.
37
38 %description -l pl.UTF-8
39 Biblioteka do dekodowania i kodowania obrazu w formacie Dirac. Jest
40 zaimplementowana w ANSI C i zoptymalizowana poprzez użycie liboil.
41 Jest pisana we współpracy między BBC Research and Development, Davidem
42 Schleefem i Fluendo.
43
44 %package devel
45 Summary:        Header files for Schroedinger library
46 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Schroedinger
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 %{?with_opengl:Requires:        glew-devel >= 1.5}
50 Requires:       libstdc++-devel
51 Requires:       orc-devel >= 0.4.16
52
53 %description devel
54 Header files for Schroedinger library.
55
56 %description devel -l pl.UTF-8
57 Pliki nagłówkowe biblioteki Schroedinger.
58
59 %package static
60 Summary:        Static Schroedinger library
61 Summary(pl.UTF-8):      Statyczna biblioteka Schroedinger
62 Group:          Development/Libraries
63 Requires:       %{name}-devel = %{version}-%{release}
64
65 %description static
66 Static Schroedinger library.
67
68 %description static -l pl.UTF-8
69 Statyczna biblioteka Schroedinger.
70
71 %package apidocs
72 Summary:        API documentation for Schroedinger library
73 Summary(pl.UTF-8):      Dokumentacja API biblioteki Schroedinger
74 Group:          Documentation
75
76 %description apidocs
77 API documentation for Schroedinger library.
78
79 %description apidocs -l pl.UTF-8
80 Dokumentacja API biblioteki Schroedinger.
81
82 %prep
83 %setup -q
84 %patch0 -p1
85
86 %{__rm} m4/libtool.m4 m4/lt*.m4
87
88 %build
89 %{__libtoolize}
90 %{__aclocal} -I m4
91 %{__autoconf}
92 %{__autoheader}
93 %{__automake}
94 %configure \
95         --with-html-dir=%{_gtkdocdir} \
96         %{?with_opengl:--with-opengl}
97 %{__make}
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 # obsoleted by pkg-config
106 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libschroedinger-1.0.la
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %post   -p /sbin/ldconfig
112 %postun -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %doc AUTHORS COPYING COPYING.MIT NEWS TODO
117 %attr(755,root,root) %{_libdir}/libschroedinger-1.0.so.*.*.*
118 %attr(755,root,root) %ghost %{_libdir}/libschroedinger-1.0.so.0
119
120 %files devel
121 %defattr(644,root,root,755)
122 %attr(755,root,root) %{_libdir}/libschroedinger-1.0.so
123 %{_includedir}/schroedinger-1.0
124 %{_pkgconfigdir}/schroedinger-1.0.pc
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libdir}/libschroedinger-1.0.a
129
130 %files apidocs
131 %defattr(644,root,root,755)
132 %{_gtkdocdir}/schroedinger
This page took 0.425951 seconds and 3 git commands to generate.