]> git.pld-linux.org Git - packages/satyr.git/blob - satyr.spec
project moved to github
[packages/satyr.git] / satyr.spec
1 #
2 # Conditional build:
3 %bcond_without  python3 # CPython 3.x binding
4 #
5 Summary:        Tools to create anonymous, machine-friendly problem reports
6 Summary(pl.UTF-8):      Analizator śladów wywołań tworzonych przez GDB
7 Name:           satyr
8 Version:        0.20
9 Release:        1
10 License:        GPL v2+
11 Group:          Development/Tools
12 Source0:        https://fedorahosted.org/released/abrt/%{name}-%{version}.tar.xz
13 # Source0-md5:  ebb66f06caa001f7acfa366affca5c52
14 Patch0:         %{name}-rpm5.patch
15 Patch1:         %{name}-rpm45.patch
16 URL:            https://github.com/abrt/satyr
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  elfutils-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  libtool
22 BuildRequires:  pkgconfig
23 BuildRequires:  python-devel >= 1:2.6
24 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
25 BuildRequires:  rpm-devel >= 4.5
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.219
28 BuildRequires:  sphinx-pdg
29 BuildRequires:  tar >= 1:1.22
30 BuildRequires:  xz
31 Requires:       %{name}-libs = %{version}-%{release}
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 # satyr-python(3) man page exists in both python packages
35 %define         _duplicate_files_terminate_build        0
36
37 %description
38 Satyr is a library that can be used to create and process
39 microreports. Microreports consist of structured data suitable to be
40 analyzed in a fully automated manner, though they do not necessarily
41 contain sufficient information to fix the underlying problem. The
42 reports are designed not to contain any potentially sensitive data to
43 eliminate the need for review before submission. Included is a tool
44 that can create microreports and perform some basic operations on
45 them.
46
47 %description -l pl.UTF-8
48 Satyr to biblioteka do tworzenia i przetwarzania mikroraportów.
49 Mikroraporty składają się ze strukturalnych danych nadających się do
50 analizy w sposób całkowicie automatyczny, ale niekoniecznie
51 zawierających pełne informacje do naprawienia problemu. Raporty są
52 zaprojektowane tak, żeby nie zawierały żadnych potencjalnie wrażliwych
53 danych, aby nie było potrzeby przeglądania ich przed wysłaniem. Do
54 pakietu jest dołączone narzędzie potrafiące tworzyć mikroraporty i
55 wykonywać na nich podstawowe operacje.
56
57 %package libs
58 Summary:        Satyr library - automatic problem management with anonymous reports
59 Summary(pl.UTF-8):      Biblioteka Satyr do automatycznego zarządzania problemami z anonimowymi zgłoszeniami
60 Group:          Libraries
61
62 %description libs
63 Satyr library - automatic problem management with anonymous reports.
64
65 %description libs -l pl.UTF-8
66 Biblioteka Satyr do automatycznego zarządzania problemami z
67 anonimowymi złoszeniami.
68
69 %package devel
70 Summary:        Header files for Satyr library
71 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Satyr
72 Group:          Development/Libraries
73 Requires:       %{name}-libs = %{version}-%{release}
74
75 %description devel
76 Header files for Satyr library.
77
78 %description devel -l pl.UTF-8
79 Pliki nagłówkowe biblioteki Satyr.
80
81 %package -n python-satyr
82 Summary:        Python 2 bindings for Satyr library
83 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki Satyr
84 Group:          Libraries/Python
85 Requires:       %{name}-libs = %{version}-%{release}
86 Requires:       python-modules
87
88 %description -n python-satyr
89 Python 2 bindings for Satyr library.
90
91 %description -n python-satyr -l pl.UTF-8
92 Wiązania Pythona 2 do biblioteki Satyr.
93
94 %package -n python3-satyr
95 Summary:        Python 3 bindings for Satyr library
96 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki Satyr
97 Group:          Libraries/Python
98 Requires:       %{name}-libs = %{version}-%{release}
99 Requires:       python3-modules
100
101 %description -n python3-satyr
102 Python 3 bindings for Satyr library.
103
104 %description -n python3-satyr -l pl.UTF-8
105 Wiązania Pythona 3 do biblioteki Satyr.
106
107 %prep
108 %setup -q
109 %if "%{_rpmversion}" >= "5.0"
110 %patch0 -p1
111 %else
112 %patch1 -p1
113 %endif
114
115 printf '%s' '%{version}' > satyr-version
116
117 %build
118 %{__libtoolize}
119 %{__aclocal}
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123 %configure \
124         --disable-silent-rules \
125         %{!?with_python3:--without-python3}
126
127 %{__make}
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
136         $RPM_BUILD_ROOT%{py_sitedir}/satyr/*.la
137
138
139 %py_postclean
140
141 %if %{with python3}
142 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
143 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
144 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/satyr/*.la
145 %endif
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post   libs -p /sbin/ldconfig
151 %postun libs -p /sbin/ldconfig
152
153 %files
154 %defattr(644,root,root,755)
155 %doc NEWS README
156 %attr(755,root,root) %{_bindir}/satyr
157 %{_mandir}/man1/satyr.1*
158
159 %files libs
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_libdir}/libsatyr.so.*.*
162 %attr(755,root,root) %ghost %{_libdir}/libsatyr.so.3
163
164 %files devel
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libsatyr.so
167 %{_includedir}/satyr
168 %{_pkgconfigdir}/satyr.pc
169
170 %files -n python-satyr
171 %defattr(644,root,root,755)
172 %dir %{py_sitedir}/satyr
173 %{py_sitedir}/satyr/__init__.py[co]
174 %attr(755,root,root) %{py_sitedir}/satyr/_satyr.so
175 %{_mandir}/man3/satyr-python.3*
176
177 %if %{with python3}
178 %files -n python3-satyr
179 %defattr(644,root,root,755)
180 %dir %{py3_sitedir}/satyr
181 %{py3_sitedir}/satyr/__init__.py
182 %attr(755,root,root) %{py3_sitedir}/satyr/_satyr3.so
183 %{py3_sitedir}/satyr/__pycache__
184 %{_mandir}/man3/satyr-python.3*
185 %endif
This page took 0.053505 seconds and 4 git commands to generate.