]> git.pld-linux.org Git - packages/satyr.git/blob - satyr.spec
- updated to 0.24
[packages/satyr.git] / satyr.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # Doxygen API documentation
4 %bcond_without  python3 # CPython 3.x binding
5 #
6 Summary:        Tools to create anonymous, machine-friendly problem reports
7 Summary(pl.UTF-8):      Analizator śladów wywołań tworzonych przez GDB
8 Name:           satyr
9 Version:        0.24
10 Release:        1
11 License:        GPL v2+
12 Group:          Development/Tools
13 #Source0Download: https://github.com/abrt/satyr/releases
14 Source0:        https://github.com/abrt/satyr/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  a93ce43a212713bd6a9e0872779acf5d
16 Patch0:         %{name}-rpm5.patch
17 Patch1:         %{name}-rpm45.patch
18 URL:            https://github.com/abrt/satyr
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  binutils-devel
22 %{?with_apidocs:BuildRequires:  doxygen}
23 BuildRequires:  elfutils-devel
24 BuildRequires:  libstdc++-devel
25 BuildRequires:  libtool
26 BuildRequires:  pkgconfig
27 BuildRequires:  python-devel >= 1:2.6
28 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
29 BuildRequires:  rpm-devel >= 4.5
30 BuildRequires:  rpm-pythonprov
31 BuildRequires:  rpmbuild(macros) >= 1.219
32 BuildRequires:  sphinx-pdg
33 BuildRequires:  tar >= 1:1.22
34 BuildRequires:  xz
35 Requires:       %{name}-libs = %{version}-%{release}
36 Obsoletes:      btparser
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 # satyr-python(3) man page exists in both python packages
40 %define         _duplicate_files_terminate_build        0
41
42 %description
43 Satyr is a library that can be used to create and process
44 microreports. Microreports consist of structured data suitable to be
45 analyzed in a fully automated manner, though they do not necessarily
46 contain sufficient information to fix the underlying problem. The
47 reports are designed not to contain any potentially sensitive data to
48 eliminate the need for review before submission. Included is a tool
49 that can create microreports and perform some basic operations on
50 them.
51
52 %description -l pl.UTF-8
53 Satyr to biblioteka do tworzenia i przetwarzania mikroraportów.
54 Mikroraporty składają się ze strukturalnych danych nadających się do
55 analizy w sposób całkowicie automatyczny, ale niekoniecznie
56 zawierających pełne informacje do naprawienia problemu. Raporty są
57 zaprojektowane tak, żeby nie zawierały żadnych potencjalnie wrażliwych
58 danych, aby nie było potrzeby przeglądania ich przed wysłaniem. Do
59 pakietu jest dołączone narzędzie potrafiące tworzyć mikroraporty i
60 wykonywać na nich podstawowe operacje.
61
62 %package libs
63 Summary:        Satyr library - automatic problem management with anonymous reports
64 Summary(pl.UTF-8):      Biblioteka Satyr do automatycznego zarządzania problemami z anonimowymi zgłoszeniami
65 Group:          Libraries
66 Obsoletes:      btparser-libs
67
68 %description libs
69 Satyr library - automatic problem management with anonymous reports.
70
71 %description libs -l pl.UTF-8
72 Biblioteka Satyr do automatycznego zarządzania problemami z
73 anonimowymi złoszeniami.
74
75 %package devel
76 Summary:        Header files for Satyr library
77 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Satyr
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{version}-%{release}
80 Obsoletes:      btparser-devel
81
82 %description devel
83 Header files for Satyr library.
84
85 %description devel -l pl.UTF-8
86 Pliki nagłówkowe biblioteki Satyr.
87
88 %package apidocs
89 Summary:        API documentation for Satyr library
90 Summary(pl.UTF-8):      Dokumentacja API biblioteki Satyr
91 Group:          Documentation
92
93 %description apidocs
94 API documentation for Satyr library.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API biblioteki Satyr.
98
99 %package -n python-satyr
100 Summary:        Python 2 bindings for Satyr library
101 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki Satyr
102 Group:          Libraries/Python
103 Requires:       %{name}-libs = %{version}-%{release}
104 Requires:       python-modules
105 Obsoletes:      python-btparser
106
107 %description -n python-satyr
108 Python 2 bindings for Satyr library.
109
110 %description -n python-satyr -l pl.UTF-8
111 Wiązania Pythona 2 do biblioteki Satyr.
112
113 %package -n python3-satyr
114 Summary:        Python 3 bindings for Satyr library
115 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki Satyr
116 Group:          Libraries/Python
117 Requires:       %{name}-libs = %{version}-%{release}
118 Requires:       python3-modules
119
120 %description -n python3-satyr
121 Python 3 bindings for Satyr library.
122
123 %description -n python3-satyr -l pl.UTF-8
124 Wiązania Pythona 3 do biblioteki Satyr.
125
126 %prep
127 %setup -q
128 %if "%{_rpmversion}" >= "5.0"
129 %patch0 -p1
130 %else
131 %patch1 -p1
132 %endif
133
134 printf '%s' '%{version}' > satyr-version
135
136 %build
137 %{__libtoolize}
138 %{__aclocal}
139 %{__autoconf}
140 %{__autoheader}
141 %{__automake}
142 %configure \
143         %{?with_apidocs:--enable-doxygen-docs} \
144         --disable-silent-rules \
145         %{!?with_python3:--without-python3}
146
147 %{__make}
148
149 %install
150 rm -rf $RPM_BUILD_ROOT
151
152 %{__make} install \
153         DESTDIR=$RPM_BUILD_ROOT
154
155 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
156         $RPM_BUILD_ROOT%{py_sitedir}/satyr/*.la
157
158
159 %py_postclean
160
161 %if %{with python3}
162 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
163 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
164 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/satyr/*.la
165 %endif
166
167 %clean
168 rm -rf $RPM_BUILD_ROOT
169
170 %post   libs -p /sbin/ldconfig
171 %postun libs -p /sbin/ldconfig
172
173 %files
174 %defattr(644,root,root,755)
175 %doc NEWS README
176 %attr(755,root,root) %{_bindir}/satyr
177 %{_mandir}/man1/satyr.1*
178
179 %files libs
180 %defattr(644,root,root,755)
181 %attr(755,root,root) %{_libdir}/libsatyr.so.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libsatyr.so.3
183
184 %files devel
185 %defattr(644,root,root,755)
186 %attr(755,root,root) %{_libdir}/libsatyr.so
187 %{_includedir}/satyr
188 %{_pkgconfigdir}/satyr.pc
189
190 %if %{with apidocs}
191 %files apidocs
192 %defattr(644,root,root,755)
193 %doc apidoc/html/{search,*.css,*.html,*.js,*.png}
194 %endif
195
196 %files -n python-satyr
197 %defattr(644,root,root,755)
198 %dir %{py_sitedir}/satyr
199 %{py_sitedir}/satyr/__init__.py[co]
200 %attr(755,root,root) %{py_sitedir}/satyr/_satyr.so
201 %{_mandir}/man3/satyr-python.3*
202
203 %if %{with python3}
204 %files -n python3-satyr
205 %defattr(644,root,root,755)
206 %dir %{py3_sitedir}/satyr
207 %{py3_sitedir}/satyr/__init__.py
208 %attr(755,root,root) %{py3_sitedir}/satyr/_satyr3.so
209 %{py3_sitedir}/satyr/__pycache__
210 %{_mandir}/man3/satyr-python.3*
211 %endif
This page took 0.07844 seconds and 4 git commands to generate.