]> git.pld-linux.org Git - packages/satyr.git/blob - satyr.spec
Release 3 (by relup.sh)
[packages/satyr.git] / satyr.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # Doxygen API documentation
4 %bcond_with     rpm5    # build with rpm5
5 #
6 Summary:        Tools to create anonymous, machine-friendly problem reports
7 Summary(pl.UTF-8):      Analizator śladów wywołań tworzonych przez GDB
8 Name:           satyr
9 Version:        0.39
10 Release:        3
11 License:        GPL v2+
12 Group:          Development/Tools
13 #Source0Download: https://github.com/abrt/satyr/releases
14 Source0:        https://github.com/abrt/satyr/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  6acc5098620fba5da8a3f8b13b6331e1
16 Patch0:         %{name}-rpm5.patch
17 URL:            https://github.com/abrt/satyr
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  binutils-devel
21 %{?with_apidocs:BuildRequires:  doxygen}
22 BuildRequires:  elfutils-devel
23 BuildRequires:  glib2-devel >= 2.0
24 BuildRequires:  json-c-devel
25 BuildRequires:  libgomp-devel
26 BuildRequires:  libstdc++-devel
27 BuildRequires:  libtool
28 BuildRequires:  nettle-devel
29 BuildRequires:  pkgconfig
30 BuildRequires:  python3-devel >= 1:3.6
31 BuildRequires:  rpm-devel >= 4.5
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.507
34 BuildRequires:  sphinx-pdg
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  xz
37 Requires:       %{name}-libs = %{version}-%{release}
38 Obsoletes:      btparser < 0.27
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 Satyr is a library that can be used to create and process
43 microreports. Microreports consist of structured data suitable to be
44 analyzed in a fully automated manner, though they do not necessarily
45 contain sufficient information to fix the underlying problem. The
46 reports are designed not to contain any potentially sensitive data to
47 eliminate the need for review before submission. Included is a tool
48 that can create microreports and perform some basic operations on
49 them.
50
51 %description -l pl.UTF-8
52 Satyr to biblioteka do tworzenia i przetwarzania mikroraportów.
53 Mikroraporty składają się ze strukturalnych danych nadających się do
54 analizy w sposób całkowicie automatyczny, ale niekoniecznie
55 zawierających pełne informacje do naprawienia problemu. Raporty są
56 zaprojektowane tak, żeby nie zawierały żadnych potencjalnie wrażliwych
57 danych, aby nie było potrzeby przeglądania ich przed wysłaniem. Do
58 pakietu jest dołączone narzędzie potrafiące tworzyć mikroraporty i
59 wykonywać na nich podstawowe operacje.
60
61 %package libs
62 Summary:        Satyr library - automatic problem management with anonymous reports
63 Summary(pl.UTF-8):      Biblioteka Satyr do automatycznego zarządzania problemami z anonimowymi zgłoszeniami
64 Group:          Libraries
65 Requires:       json-c-devel
66 Obsoletes:      btparser-libs < 0.27
67
68 %description libs
69 Satyr library - automatic problem management with anonymous reports.
70
71 %description libs -l pl.UTF-8
72 Biblioteka Satyr do automatycznego zarządzania problemami z
73 anonimowymi złoszeniami.
74
75 %package devel
76 Summary:        Header files for Satyr library
77 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Satyr
78 Group:          Development/Libraries
79 Requires:       %{name}-libs = %{version}-%{release}
80 Requires:       json-c-devel
81 Obsoletes:      btparser-devel < 0.27
82
83 %description devel
84 Header files for Satyr library.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki Satyr.
88
89 %package apidocs
90 Summary:        API documentation for Satyr library
91 Summary(pl.UTF-8):      Dokumentacja API biblioteki Satyr
92 Group:          Documentation
93
94 %description apidocs
95 API documentation for Satyr library.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API biblioteki Satyr.
99
100 %package -n python3-satyr
101 Summary:        Python 3 bindings for Satyr library
102 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki Satyr
103 Group:          Libraries/Python
104 Requires:       %{name}-libs = %{version}-%{release}
105 Requires:       python3-modules >= 1:3.6
106 Obsoletes:      python-btparser < 0.27
107 Obsoletes:      python-satyr < 0.30
108
109 %description -n python3-satyr
110 Python 3 bindings for Satyr library.
111
112 %description -n python3-satyr -l pl.UTF-8
113 Wiązania Pythona 3 do biblioteki Satyr.
114
115 %prep
116 %setup -q
117 %{?with_rpm5:%patch0 -p1}
118
119 printf '%s' '%{version}' > satyr-version
120
121 %build
122 %{__libtoolize}
123 %{__aclocal}
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         %{?with_apidocs:--enable-doxygen-docs} \
129         --disable-silent-rules
130
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135
136 %{__make} install \
137         DESTDIR=$RPM_BUILD_ROOT
138
139 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
140         $RPM_BUILD_ROOT%{py3_sitedir}/satyr/*.la
141
142 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
143 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %post   libs -p /sbin/ldconfig
149 %postun libs -p /sbin/ldconfig
150
151 %files
152 %defattr(644,root,root,755)
153 %doc NEWS README.md
154 %attr(755,root,root) %{_bindir}/satyr
155 %{_mandir}/man1/satyr.1*
156
157 %files libs
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_libdir}/libsatyr.so.*.*
160 %attr(755,root,root) %ghost %{_libdir}/libsatyr.so.4
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_libdir}/libsatyr.so
165 %{_includedir}/satyr
166 %{_pkgconfigdir}/satyr.pc
167
168 %if %{with apidocs}
169 %files apidocs
170 %defattr(644,root,root,755)
171 %doc apidoc/html/{search,*.css,*.html,*.js,*.png}
172 %endif
173
174 %files -n python3-satyr
175 %defattr(644,root,root,755)
176 %dir %{py3_sitedir}/satyr
177 %{py3_sitedir}/satyr/__init__.py
178 %attr(755,root,root) %{py3_sitedir}/satyr/_satyr3.so
179 %{py3_sitedir}/satyr/__pycache__
This page took 0.066702 seconds and 3 git commands to generate.