]> git.pld-linux.org Git - packages/satyr.git/blob - satyr.spec
25e6e25fe67d5077b390902d0ebf08058f294369
[packages/satyr.git] / satyr.spec
1 #
2 # Conditional build:
3 %bcond_without  python3 # CPython 3.x binding
4 #
5 Summary:        Tools to create anonymous, machine-friendly problem reports
6 Summary(pl.UTF-8):      Analizator śladów wywołań tworzonych przez GDB
7 Name:           satyr
8 Version:        0.23
9 Release:        1
10 License:        GPL v2+
11 Group:          Development/Tools
12 Source0:        https://github.com/abrt/satyr/archive/%{version}/%{name}-%{version}.tar.gz
13 # Source0-md5:  23607da2080c798307eb8ce6f69f337f
14 Patch0:         %{name}-rpm5.patch
15 Patch1:         %{name}-rpm45.patch
16 URL:            https://github.com/abrt/satyr
17 BuildRequires:  autoconf >= 2.50
18 BuildRequires:  automake
19 BuildRequires:  binutils-devel
20 BuildRequires:  elfutils-devel
21 BuildRequires:  libstdc++-devel
22 BuildRequires:  libtool
23 BuildRequires:  pkgconfig
24 BuildRequires:  python-devel >= 1:2.6
25 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
26 BuildRequires:  rpm-devel >= 4.5
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  rpmbuild(macros) >= 1.219
29 BuildRequires:  sphinx-pdg
30 BuildRequires:  tar >= 1:1.22
31 BuildRequires:  xz
32 Requires:       %{name}-libs = %{version}-%{release}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 # satyr-python(3) man page exists in both python packages
36 %define         _duplicate_files_terminate_build        0
37
38 %description
39 Satyr is a library that can be used to create and process
40 microreports. Microreports consist of structured data suitable to be
41 analyzed in a fully automated manner, though they do not necessarily
42 contain sufficient information to fix the underlying problem. The
43 reports are designed not to contain any potentially sensitive data to
44 eliminate the need for review before submission. Included is a tool
45 that can create microreports and perform some basic operations on
46 them.
47
48 %description -l pl.UTF-8
49 Satyr to biblioteka do tworzenia i przetwarzania mikroraportów.
50 Mikroraporty składają się ze strukturalnych danych nadających się do
51 analizy w sposób całkowicie automatyczny, ale niekoniecznie
52 zawierających pełne informacje do naprawienia problemu. Raporty są
53 zaprojektowane tak, żeby nie zawierały żadnych potencjalnie wrażliwych
54 danych, aby nie było potrzeby przeglądania ich przed wysłaniem. Do
55 pakietu jest dołączone narzędzie potrafiące tworzyć mikroraporty i
56 wykonywać na nich podstawowe operacje.
57
58 %package libs
59 Summary:        Satyr library - automatic problem management with anonymous reports
60 Summary(pl.UTF-8):      Biblioteka Satyr do automatycznego zarządzania problemami z anonimowymi zgłoszeniami
61 Group:          Libraries
62
63 %description libs
64 Satyr library - automatic problem management with anonymous reports.
65
66 %description libs -l pl.UTF-8
67 Biblioteka Satyr do automatycznego zarządzania problemami z
68 anonimowymi złoszeniami.
69
70 %package devel
71 Summary:        Header files for Satyr library
72 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Satyr
73 Group:          Development/Libraries
74 Requires:       %{name}-libs = %{version}-%{release}
75
76 %description devel
77 Header files for Satyr library.
78
79 %description devel -l pl.UTF-8
80 Pliki nagłówkowe biblioteki Satyr.
81
82 %package -n python-satyr
83 Summary:        Python 2 bindings for Satyr library
84 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki Satyr
85 Group:          Libraries/Python
86 Requires:       %{name}-libs = %{version}-%{release}
87 Requires:       python-modules
88
89 %description -n python-satyr
90 Python 2 bindings for Satyr library.
91
92 %description -n python-satyr -l pl.UTF-8
93 Wiązania Pythona 2 do biblioteki Satyr.
94
95 %package -n python3-satyr
96 Summary:        Python 3 bindings for Satyr library
97 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki Satyr
98 Group:          Libraries/Python
99 Requires:       %{name}-libs = %{version}-%{release}
100 Requires:       python3-modules
101
102 %description -n python3-satyr
103 Python 3 bindings for Satyr library.
104
105 %description -n python3-satyr -l pl.UTF-8
106 Wiązania Pythona 3 do biblioteki Satyr.
107
108 %prep
109 %setup -q
110 %if "%{_rpmversion}" >= "5.0"
111 %patch0 -p1
112 %else
113 %patch1 -p1
114 %endif
115
116 printf '%s' '%{version}' > satyr-version
117
118 %build
119 %{__libtoolize}
120 %{__aclocal}
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         --disable-silent-rules \
126         %{!?with_python3:--without-python3}
127
128 %{__make}
129
130 %install
131 rm -rf $RPM_BUILD_ROOT
132
133 %{__make} install \
134         DESTDIR=$RPM_BUILD_ROOT
135
136 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
137         $RPM_BUILD_ROOT%{py_sitedir}/satyr/*.la
138
139
140 %py_postclean
141
142 %if %{with python3}
143 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
144 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
145 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/satyr/*.la
146 %endif
147
148 %clean
149 rm -rf $RPM_BUILD_ROOT
150
151 %post   libs -p /sbin/ldconfig
152 %postun libs -p /sbin/ldconfig
153
154 %files
155 %defattr(644,root,root,755)
156 %doc NEWS README
157 %attr(755,root,root) %{_bindir}/satyr
158 %{_mandir}/man1/satyr.1*
159
160 %files libs
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libsatyr.so.*.*
163 %attr(755,root,root) %ghost %{_libdir}/libsatyr.so.3
164
165 %files devel
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_libdir}/libsatyr.so
168 %{_includedir}/satyr
169 %{_pkgconfigdir}/satyr.pc
170
171 %files -n python-satyr
172 %defattr(644,root,root,755)
173 %dir %{py_sitedir}/satyr
174 %{py_sitedir}/satyr/__init__.py[co]
175 %attr(755,root,root) %{py_sitedir}/satyr/_satyr.so
176 %{_mandir}/man3/satyr-python.3*
177
178 %if %{with python3}
179 %files -n python3-satyr
180 %defattr(644,root,root,755)
181 %dir %{py3_sitedir}/satyr
182 %{py3_sitedir}/satyr/__init__.py
183 %attr(755,root,root) %{py3_sitedir}/satyr/_satyr3.so
184 %{py3_sitedir}/satyr/__pycache__
185 %{_mandir}/man3/satyr-python.3*
186 %endif
This page took 0.056504 seconds and 2 git commands to generate.