]> git.pld-linux.org Git - packages/satyr.git/blob - satyr.spec
- updated to 0.31
[packages/satyr.git] / satyr.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # Doxygen API documentation
4 #
5 Summary:        Tools to create anonymous, machine-friendly problem reports
6 Summary(pl.UTF-8):      Analizator śladów wywołań tworzonych przez GDB
7 Name:           satyr
8 Version:        0.31
9 Release:        1
10 License:        GPL v2+
11 Group:          Development/Tools
12 #Source0Download: https://github.com/abrt/satyr/releases
13 Source0:        https://github.com/abrt/satyr/archive/%{version}/%{name}-%{version}.tar.gz
14 # Source0-md5:  b8d144be731da681b6ff2701422a2f96
15 Patch0:         %{name}-rpm5.patch
16 Patch1:         %{name}-rpm45.patch
17 URL:            https://github.com/abrt/satyr
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  binutils-devel
21 %{?with_apidocs:BuildRequires:  doxygen}
22 BuildRequires:  elfutils-devel
23 BuildRequires:  json-c-devel
24 BuildRequires:  libgomp-devel
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool
27 BuildRequires:  nettle-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  python3-devel >= 1:3.6
30 BuildRequires:  rpm-devel >= 4.5
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  rpmbuild(macros) >= 1.219
33 BuildRequires:  sphinx-pdg
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xz
36 Requires:       %{name}-libs = %{version}-%{release}
37 Obsoletes:      btparser
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Satyr is a library that can be used to create and process
42 microreports. Microreports consist of structured data suitable to be
43 analyzed in a fully automated manner, though they do not necessarily
44 contain sufficient information to fix the underlying problem. The
45 reports are designed not to contain any potentially sensitive data to
46 eliminate the need for review before submission. Included is a tool
47 that can create microreports and perform some basic operations on
48 them.
49
50 %description -l pl.UTF-8
51 Satyr to biblioteka do tworzenia i przetwarzania mikroraportów.
52 Mikroraporty składają się ze strukturalnych danych nadających się do
53 analizy w sposób całkowicie automatyczny, ale niekoniecznie
54 zawierających pełne informacje do naprawienia problemu. Raporty są
55 zaprojektowane tak, żeby nie zawierały żadnych potencjalnie wrażliwych
56 danych, aby nie było potrzeby przeglądania ich przed wysłaniem. Do
57 pakietu jest dołączone narzędzie potrafiące tworzyć mikroraporty i
58 wykonywać na nich podstawowe operacje.
59
60 %package libs
61 Summary:        Satyr library - automatic problem management with anonymous reports
62 Summary(pl.UTF-8):      Biblioteka Satyr do automatycznego zarządzania problemami z anonimowymi zgłoszeniami
63 Group:          Libraries
64 Requires:       json-c-devel
65 Obsoletes:      btparser-libs
66
67 %description libs
68 Satyr library - automatic problem management with anonymous reports.
69
70 %description libs -l pl.UTF-8
71 Biblioteka Satyr do automatycznego zarządzania problemami z
72 anonimowymi złoszeniami.
73
74 %package devel
75 Summary:        Header files for Satyr library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Satyr
77 Group:          Development/Libraries
78 Requires:       %{name}-libs = %{version}-%{release}
79 Obsoletes:      btparser-devel
80
81 %description devel
82 Header files for Satyr library.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe biblioteki Satyr.
86
87 %package apidocs
88 Summary:        API documentation for Satyr library
89 Summary(pl.UTF-8):      Dokumentacja API biblioteki Satyr
90 Group:          Documentation
91
92 %description apidocs
93 API documentation for Satyr library.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API biblioteki Satyr.
97
98 %package -n python3-satyr
99 Summary:        Python 3 bindings for Satyr library
100 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki Satyr
101 Group:          Libraries/Python
102 Requires:       %{name}-libs = %{version}-%{release}
103 Requires:       python3-modules >= 1:3.6
104 Obsoletes:      python-btparser
105 Obsoletes:      python-satyr
106
107 %description -n python3-satyr
108 Python 3 bindings for Satyr library.
109
110 %description -n python3-satyr -l pl.UTF-8
111 Wiązania Pythona 3 do biblioteki Satyr.
112
113 %prep
114 %setup -q
115 %if "%{_rpmversion}" >= "5.0"
116 %patch0 -p1
117 %else
118 %if "%{_rpmversion}" >= "4.5" && "%{_rpmversion}" < "4.6"
119 %patch1 -p1
120 %endif
121 %endif
122
123 printf '%s' '%{version}' > satyr-version
124
125 %build
126 %{__libtoolize}
127 %{__aclocal}
128 %{__autoconf}
129 %{__autoheader}
130 %{__automake}
131 %configure \
132         %{?with_apidocs:--enable-doxygen-docs} \
133         --disable-silent-rules
134
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
144         $RPM_BUILD_ROOT%{py3_sitedir}/satyr/*.la
145
146 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
147 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
148
149 %clean
150 rm -rf $RPM_BUILD_ROOT
151
152 %post   libs -p /sbin/ldconfig
153 %postun libs -p /sbin/ldconfig
154
155 %files
156 %defattr(644,root,root,755)
157 %doc NEWS README
158 %attr(755,root,root) %{_bindir}/satyr
159 %{_mandir}/man1/satyr.1*
160
161 %files libs
162 %defattr(644,root,root,755)
163 %attr(755,root,root) %{_libdir}/libsatyr.so.*.*
164 %attr(755,root,root) %ghost %{_libdir}/libsatyr.so.4
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libsatyr.so
169 %{_includedir}/satyr
170 %{_pkgconfigdir}/satyr.pc
171
172 %if %{with apidocs}
173 %files apidocs
174 %defattr(644,root,root,755)
175 %doc apidoc/html/{search,*.css,*.html,*.js,*.png}
176 %endif
177
178 %files -n python3-satyr
179 %defattr(644,root,root,755)
180 %dir %{py3_sitedir}/satyr
181 %{py3_sitedir}/satyr/__init__.py
182 %attr(755,root,root) %{py3_sitedir}/satyr/_satyr3.so
183 %{py3_sitedir}/satyr/__pycache__
This page took 0.057006 seconds and 3 git commands to generate.