]> git.pld-linux.org Git - packages/satyr.git/blob - satyr.spec
2127e54cc7e924fd28e3a9633127e80c82a2624f
[packages/satyr.git] / satyr.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # Doxygen API documentation
4 %bcond_without  python3 # CPython 3.x binding
5 #
6 Summary:        Tools to create anonymous, machine-friendly problem reports
7 Summary(pl.UTF-8):      Analizator śladów wywołań tworzonych przez GDB
8 Name:           satyr
9 Version:        0.27
10 Release:        1
11 License:        GPL v2+
12 Group:          Development/Tools
13 #Source0Download: https://github.com/abrt/satyr/releases
14 Source0:        https://github.com/abrt/satyr/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  8c3b82597b69831634ab69f105c168c0
16 Patch0:         %{name}-rpm5.patch
17 Patch1:         %{name}-rpm45.patch
18 URL:            https://github.com/abrt/satyr
19 BuildRequires:  autoconf >= 2.50
20 BuildRequires:  automake
21 BuildRequires:  binutils-devel
22 %{?with_apidocs:BuildRequires:  doxygen}
23 BuildRequires:  elfutils-devel
24 BuildRequires:  libgomp-devel
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool
27 BuildRequires:  pkgconfig
28 BuildRequires:  python-devel >= 1:2.6
29 %{?with_python3:BuildRequires:  python3-devel >= 1:3.2}
30 BuildRequires:  rpm-devel >= 4.5
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  rpmbuild(macros) >= 1.219
33 BuildRequires:  sphinx-pdg
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xz
36 Requires:       %{name}-libs = %{version}-%{release}
37 Obsoletes:      btparser
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 # satyr-python(3) man page exists in both python packages
41 %define         _duplicate_files_terminate_build        0
42
43 %description
44 Satyr is a library that can be used to create and process
45 microreports. Microreports consist of structured data suitable to be
46 analyzed in a fully automated manner, though they do not necessarily
47 contain sufficient information to fix the underlying problem. The
48 reports are designed not to contain any potentially sensitive data to
49 eliminate the need for review before submission. Included is a tool
50 that can create microreports and perform some basic operations on
51 them.
52
53 %description -l pl.UTF-8
54 Satyr to biblioteka do tworzenia i przetwarzania mikroraportów.
55 Mikroraporty składają się ze strukturalnych danych nadających się do
56 analizy w sposób całkowicie automatyczny, ale niekoniecznie
57 zawierających pełne informacje do naprawienia problemu. Raporty są
58 zaprojektowane tak, żeby nie zawierały żadnych potencjalnie wrażliwych
59 danych, aby nie było potrzeby przeglądania ich przed wysłaniem. Do
60 pakietu jest dołączone narzędzie potrafiące tworzyć mikroraporty i
61 wykonywać na nich podstawowe operacje.
62
63 %package libs
64 Summary:        Satyr library - automatic problem management with anonymous reports
65 Summary(pl.UTF-8):      Biblioteka Satyr do automatycznego zarządzania problemami z anonimowymi zgłoszeniami
66 Group:          Libraries
67 Obsoletes:      btparser-libs
68
69 %description libs
70 Satyr library - automatic problem management with anonymous reports.
71
72 %description libs -l pl.UTF-8
73 Biblioteka Satyr do automatycznego zarządzania problemami z
74 anonimowymi złoszeniami.
75
76 %package devel
77 Summary:        Header files for Satyr library
78 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Satyr
79 Group:          Development/Libraries
80 Requires:       %{name}-libs = %{version}-%{release}
81 Obsoletes:      btparser-devel
82
83 %description devel
84 Header files for Satyr library.
85
86 %description devel -l pl.UTF-8
87 Pliki nagłówkowe biblioteki Satyr.
88
89 %package apidocs
90 Summary:        API documentation for Satyr library
91 Summary(pl.UTF-8):      Dokumentacja API biblioteki Satyr
92 Group:          Documentation
93
94 %description apidocs
95 API documentation for Satyr library.
96
97 %description apidocs -l pl.UTF-8
98 Dokumentacja API biblioteki Satyr.
99
100 %package -n python-satyr
101 Summary:        Python 2 bindings for Satyr library
102 Summary(pl.UTF-8):      Wiązania Pythona 2 do biblioteki Satyr
103 Group:          Libraries/Python
104 Requires:       %{name}-libs = %{version}-%{release}
105 Requires:       python-modules
106 Obsoletes:      python-btparser
107
108 %description -n python-satyr
109 Python 2 bindings for Satyr library.
110
111 %description -n python-satyr -l pl.UTF-8
112 Wiązania Pythona 2 do biblioteki Satyr.
113
114 %package -n python3-satyr
115 Summary:        Python 3 bindings for Satyr library
116 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki Satyr
117 Group:          Libraries/Python
118 Requires:       %{name}-libs = %{version}-%{release}
119 Requires:       python3-modules
120
121 %description -n python3-satyr
122 Python 3 bindings for Satyr library.
123
124 %description -n python3-satyr -l pl.UTF-8
125 Wiązania Pythona 3 do biblioteki Satyr.
126
127 %prep
128 %setup -q
129 %if "%{_rpmversion}" >= "5.0"
130 %patch0 -p1
131 %else
132 %patch1 -p1
133 %endif
134
135 printf '%s' '%{version}' > satyr-version
136
137 %build
138 %{__libtoolize}
139 %{__aclocal}
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143 %configure \
144         %{?with_apidocs:--enable-doxygen-docs} \
145         --disable-silent-rules \
146         %{!?with_python3:--without-python3}
147
148 %{__make}
149
150 %install
151 rm -rf $RPM_BUILD_ROOT
152
153 %{__make} install \
154         DESTDIR=$RPM_BUILD_ROOT
155
156 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
157         $RPM_BUILD_ROOT%{py_sitedir}/satyr/*.la
158
159
160 %py_postclean
161
162 %if %{with python3}
163 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
164 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
165 %{__rm} $RPM_BUILD_ROOT%{py3_sitedir}/satyr/*.la
166 %endif
167
168 %clean
169 rm -rf $RPM_BUILD_ROOT
170
171 %post   libs -p /sbin/ldconfig
172 %postun libs -p /sbin/ldconfig
173
174 %files
175 %defattr(644,root,root,755)
176 %doc NEWS README
177 %attr(755,root,root) %{_bindir}/satyr
178 %{_mandir}/man1/satyr.1*
179
180 %files libs
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_libdir}/libsatyr.so.*.*
183 %attr(755,root,root) %ghost %{_libdir}/libsatyr.so.3
184
185 %files devel
186 %defattr(644,root,root,755)
187 %attr(755,root,root) %{_libdir}/libsatyr.so
188 %{_includedir}/satyr
189 %{_pkgconfigdir}/satyr.pc
190
191 %if %{with apidocs}
192 %files apidocs
193 %defattr(644,root,root,755)
194 %doc apidoc/html/{search,*.css,*.html,*.js,*.png}
195 %endif
196
197 %files -n python-satyr
198 %defattr(644,root,root,755)
199 %dir %{py_sitedir}/satyr
200 %{py_sitedir}/satyr/__init__.py[co]
201 %attr(755,root,root) %{py_sitedir}/satyr/_satyr.so
202 %{_mandir}/man3/satyr-python.3*
203
204 %if %{with python3}
205 %files -n python3-satyr
206 %defattr(644,root,root,755)
207 %dir %{py3_sitedir}/satyr
208 %{py3_sitedir}/satyr/__init__.py
209 %attr(755,root,root) %{py3_sitedir}/satyr/_satyr3.so
210 %{py3_sitedir}/satyr/__pycache__
211 %{_mandir}/man3/satyr-python.3*
212 %endif
This page took 0.109045 seconds and 2 git commands to generate.