]> git.pld-linux.org Git - packages/satyr.git/blob - satyr.spec
0eb46938eba8b793e15d9def7fb84dfd8ad4ad4b
[packages/satyr.git] / satyr.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # Doxygen API documentation
4 %bcond_with     rpm5    # build with rpm5
5 #
6 Summary:        Tools to create anonymous, machine-friendly problem reports
7 Summary(pl.UTF-8):      Analizator śladów wywołań tworzonych przez GDB
8 Name:           satyr
9 Version:        0.31
10 Release:        8
11 License:        GPL v2+
12 Group:          Development/Tools
13 #Source0Download: https://github.com/abrt/satyr/releases
14 Source0:        https://github.com/abrt/satyr/archive/%{version}/%{name}-%{version}.tar.gz
15 # Source0-md5:  b8d144be731da681b6ff2701422a2f96
16 Patch0:         %{name}-rpm5.patch
17 URL:            https://github.com/abrt/satyr
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  automake
20 BuildRequires:  binutils-devel
21 %{?with_apidocs:BuildRequires:  doxygen}
22 BuildRequires:  elfutils-devel
23 BuildRequires:  json-c-devel
24 BuildRequires:  libgomp-devel
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool
27 BuildRequires:  nettle-devel
28 BuildRequires:  pkgconfig
29 BuildRequires:  python3-devel >= 1:3.6
30 BuildRequires:  rpm-devel >= 4.5
31 BuildRequires:  rpm-pythonprov
32 BuildRequires:  rpmbuild(macros) >= 1.219
33 BuildRequires:  sphinx-pdg
34 BuildRequires:  tar >= 1:1.22
35 BuildRequires:  xz
36 Requires:       %{name}-libs = %{version}-%{release}
37 Obsoletes:      btparser
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Satyr is a library that can be used to create and process
42 microreports. Microreports consist of structured data suitable to be
43 analyzed in a fully automated manner, though they do not necessarily
44 contain sufficient information to fix the underlying problem. The
45 reports are designed not to contain any potentially sensitive data to
46 eliminate the need for review before submission. Included is a tool
47 that can create microreports and perform some basic operations on
48 them.
49
50 %description -l pl.UTF-8
51 Satyr to biblioteka do tworzenia i przetwarzania mikroraportów.
52 Mikroraporty składają się ze strukturalnych danych nadających się do
53 analizy w sposób całkowicie automatyczny, ale niekoniecznie
54 zawierających pełne informacje do naprawienia problemu. Raporty są
55 zaprojektowane tak, żeby nie zawierały żadnych potencjalnie wrażliwych
56 danych, aby nie było potrzeby przeglądania ich przed wysłaniem. Do
57 pakietu jest dołączone narzędzie potrafiące tworzyć mikroraporty i
58 wykonywać na nich podstawowe operacje.
59
60 %package libs
61 Summary:        Satyr library - automatic problem management with anonymous reports
62 Summary(pl.UTF-8):      Biblioteka Satyr do automatycznego zarządzania problemami z anonimowymi zgłoszeniami
63 Group:          Libraries
64 Requires:       json-c-devel
65 Obsoletes:      btparser-libs
66
67 %description libs
68 Satyr library - automatic problem management with anonymous reports.
69
70 %description libs -l pl.UTF-8
71 Biblioteka Satyr do automatycznego zarządzania problemami z
72 anonimowymi złoszeniami.
73
74 %package devel
75 Summary:        Header files for Satyr library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Satyr
77 Group:          Development/Libraries
78 Requires:       %{name}-libs = %{version}-%{release}
79 Obsoletes:      btparser-devel
80
81 %description devel
82 Header files for Satyr library.
83
84 %description devel -l pl.UTF-8
85 Pliki nagłówkowe biblioteki Satyr.
86
87 %package apidocs
88 Summary:        API documentation for Satyr library
89 Summary(pl.UTF-8):      Dokumentacja API biblioteki Satyr
90 Group:          Documentation
91
92 %description apidocs
93 API documentation for Satyr library.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API biblioteki Satyr.
97
98 %package -n python3-satyr
99 Summary:        Python 3 bindings for Satyr library
100 Summary(pl.UTF-8):      Wiązania Pythona 3 do biblioteki Satyr
101 Group:          Libraries/Python
102 Requires:       %{name}-libs = %{version}-%{release}
103 Requires:       python3-modules >= 1:3.6
104 Obsoletes:      python-btparser
105 Obsoletes:      python-satyr
106
107 %description -n python3-satyr
108 Python 3 bindings for Satyr library.
109
110 %description -n python3-satyr -l pl.UTF-8
111 Wiązania Pythona 3 do biblioteki Satyr.
112
113 %prep
114 %setup -q
115 %{?with_rpm5:%patch0 -p1}
116
117 printf '%s' '%{version}' > satyr-version
118
119 %build
120 %{__libtoolize}
121 %{__aclocal}
122 %{__autoconf}
123 %{__autoheader}
124 %{__automake}
125 %configure \
126         %{?with_apidocs:--enable-doxygen-docs} \
127         --disable-silent-rules
128
129 %{__make}
130
131 %install
132 rm -rf $RPM_BUILD_ROOT
133
134 %{__make} install \
135         DESTDIR=$RPM_BUILD_ROOT
136
137 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la \
138         $RPM_BUILD_ROOT%{py3_sitedir}/satyr/*.la
139
140 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
141 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
142
143 %clean
144 rm -rf $RPM_BUILD_ROOT
145
146 %post   libs -p /sbin/ldconfig
147 %postun libs -p /sbin/ldconfig
148
149 %files
150 %defattr(644,root,root,755)
151 %doc NEWS README
152 %attr(755,root,root) %{_bindir}/satyr
153 %{_mandir}/man1/satyr.1*
154
155 %files libs
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_libdir}/libsatyr.so.*.*
158 %attr(755,root,root) %ghost %{_libdir}/libsatyr.so.4
159
160 %files devel
161 %defattr(644,root,root,755)
162 %attr(755,root,root) %{_libdir}/libsatyr.so
163 %{_includedir}/satyr
164 %{_pkgconfigdir}/satyr.pc
165
166 %if %{with apidocs}
167 %files apidocs
168 %defattr(644,root,root,755)
169 %doc apidoc/html/{search,*.css,*.html,*.js,*.png}
170 %endif
171
172 %files -n python3-satyr
173 %defattr(644,root,root,755)
174 %dir %{py3_sitedir}/satyr
175 %{py3_sitedir}/satyr/__init__.py
176 %attr(755,root,root) %{py3_sitedir}/satyr/_satyr3.so
177 %{py3_sitedir}/satyr/__pycache__
This page took 0.056128 seconds and 2 git commands to generate.