]> git.pld-linux.org Git - packages/sary.git/blob - sary.spec
- pl, cleanup
[packages/sary.git] / sary.spec
1 #
2 # Conditional build:
3 %bcond_without  static_libs     # don't build static libraries
4 #
5 Summary:        Suffix array library
6 Summary(pl.UTF-8):      Biblioteka tablic sufiksowych
7 Name:           sary
8 Version:        1.2.0
9 Release:        1
10 License:        LGPL v2+
11 Group:          Libraries
12 Source0:        http://sary.sourceforge.net/%{name}-%{version}.tar.gz
13 # Source0-md5:  10b9a803025c5f428014a7f1ff849ecc
14 Patch0:         %{name}-link.patch
15 URL:            http://sary.sourceforge.net/
16 BuildRequires:  autoconf >= 2.52
17 BuildRequires:  automake >= 1.4
18 BuildRequires:  glib2-devel >= 2.0.0
19 BuildRequires:  libtool
20 BuildRequires:  pkgconfig
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 sary is a suffix array library and tools.
25
26 It provides fast full-text search facilities for text files
27 on the order of 10 to 100 MB using a data structure called
28 a suffix array. It can also search specific fields in a text
29 file by assigning index points to those fields. 
30
31 %description -l pl.UTF-8
32 sary to biblioteka oraz narzędzia do tablic sufiksowych.
33
34 Zapewnia szybkie funkcje do przeszukiwania pełnotekstowego dla
35 plików tekstowych rzędu wielkości od 10 do 100 MB przy użyciu
36 struktury danych zwanej tablicą sufiksową. Potrafi także
37 wyszukiwać konkretnych pól w pliku tekstowym przypisując punkty
38 indeksu do tych pól.
39
40 %package devel
41 Summary:        Header files for sary library
42 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki sary
43 Group:          Development/Libraries
44 Requires:       %{name} = %{version}-%{release}
45 Requires:       glib2-devel >= 2.0.0
46
47 %description devel
48 Header files for sary library.
49
50 %description devel -l pl.UTF-8
51 Pliki nagłówkowe biblioteki sary.
52
53 %package static
54 Summary:        Static sary library
55 Summary(pl.UTF-8):      Statyczna biblioteka sary
56 Group:          Development/Libraries
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description static
60 Static sary library.
61
62 %description static -l pl.UTF-8
63 Statyczna biblioteka sary.
64
65 %prep
66 %setup -q
67 %patch0 -p1
68
69 %build
70 %{__libtoolize}
71 %{__aclocal}
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 %configure \
76         %{!?with_static_libs:--disable-static}
77 %{__make}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %{__rm} -rf devel-doc
86 mv $RPM_BUILD_ROOT%{_datadir}/%{name}/docs devel-doc
87
88 # obsoleted by pkg-config
89 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libsary.la
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %post   -p /sbin/ldconfig
95 %postun -p /sbin/ldconfig
96
97 %files
98 %defattr(644,root,root,755)
99 %doc AUTHORS ChangeLog NEWS README TODO
100 %attr(755,root,root) %{_bindir}/mksary
101 %attr(755,root,root) %{_bindir}/sary
102 %attr(755,root,root) %{_libdir}/libsary.so.*.*.*
103 %attr(755,root,root) %ghost %{_libdir}/libsary.so.10
104 %{_mandir}/man1/mksary.1*
105 %{_mandir}/man1/sary.1*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %doc devel-doc/*
110 %attr(755,root,root) %{_libdir}/libsary.so
111 %{_includedir}/sary
112 %{_includedir}/sary.h
113 %{_pkgconfigdir}/sary.pc
114
115 %if %{with static_libs}
116 %files static
117 %defattr(644,root,root,755)
118 %{_libdir}/libsary.a
119 %endif
This page took 0.15142 seconds and 3 git commands to generate.