]> git.pld-linux.org Git - packages/s3ql.git/blob - s3ql.spec
- python 3.5 rebuild
[packages/s3ql.git] / s3ql.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 Summary:        Filesystem that stores data in Google Storage, Amazon S3 etc
6 Name:           s3ql
7 Version:        2.11.1
8 Release:        4
9 License:        GPL v3
10 Group:          Applications/System
11 Source0:        https://bitbucket.org/nikratio/s3ql/downloads/%{name}-%{version}.tar.bz2
12 # Source0-md5:  f2af113cf1ee7cad98829cf0a972c8e4
13 URL:            https://bitbucket.org/nikratio/s3ql/
14 BuildRequires:  python3-Crypto
15 BuildRequires:  python3-apsw >= 3.7.0
16 BuildRequires:  python3-defusedxml
17 BuildRequires:  python3-devel
18 BuildRequires:  python3-distribute
19 BuildRequires:  python3-dugong >= 3.2
20 BuildRequires:  python3-llfuse >= 0.39
21 BuildRequires:  python3-modules >= 3.3
22 BuildRequires:  rpm-pythonprov
23 %{?with_tests:BuildRequires:    python3-requests}
24 Requires:       python3-Crypto
25 Requires:       python3-apsw >= 3.7.0
26 Requires:       python3-defusedxml
27 Requires:       python3-dugong >= 3.2
28 Requires:       python3-llfuse >= 0.39
29 Requires:       python3-modules >= 3.3
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 S3QL is a file system that stores all its data online using storage
34 services like Google Storage, Amazon S3, or OpenStack. S3QL
35 effectively provides a hard disk of dynamic, infinite capacity that
36 can be accessed from any computer with internet access running Linux,
37 FreeBSD or OS-X.
38
39 %prep
40 %setup -q
41
42 %build
43 CC="%{__cc}" \
44 CFLAGS="%{rpmcflags}" \
45 %{__python3} setup.py build --build-base build-3 %{?with_tests:test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__python3} setup.py \
51         build --build-base build-3 \
52         install --skip-build \
53         --optimize=2 \
54         --root=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes.txt README.rst
62 %attr(755,root,root) %{_bindir}/fsck.s3ql
63 %attr(755,root,root) %{_bindir}/mkfs.s3ql
64 %attr(755,root,root) %{_bindir}/mount.s3ql
65 %attr(755,root,root) %{_bindir}/s3ql*
66 %attr(755,root,root) %{_bindir}/umount.s3ql
67 %{py3_sitedir}/s3ql
68 %{py3_sitedir}/s3ql-%{version}-py*.egg-info
69 %{_mandir}/man1/*.1*
This page took 0.076189 seconds and 3 git commands to generate.