]> git.pld-linux.org Git - packages/rubymine.git/blob - rubymine.spec
fix broken config/cache paths
[packages/rubymine.git] / rubymine.spec
1 %include        /usr/lib/rpm/macros.java
2 Summary:        The Most Intelligent Ruby and Rails IDE
3 Name:           rubymine
4 Version:        6.0.3
5 Release:        0.4
6 # TODO: figure out what's the licensing and redistribution
7 License:        ?
8 Group:          Development/Tools
9 Source0:        http://download.jetbrains.com/ruby/RubyMine-%{version}.tar.gz
10 # NoSource0-md5:        271068d44ad9249e4b3be3533232d336
11 NoSource:       0
12 Source1:        %{name}.desktop
13 Patch0:         pld.patch
14 URL:            http://www.jetbrains.com/ruby/
15 BuildRequires:  jpackage-utils
16 BuildRequires:  rpm-javaprov
17 BuildRequires:  rpmbuild(macros) >= 1.300
18 Requires:       desktop-file-utils
19 Requires:       jre >= 1.6
20 Requires:       which
21 Suggests:       cvs
22 Suggests:       git-core
23 Suggests:       subversion
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 # use /usr/lib, 64bit files do not conflict with 32bit files (64 suffix)
27 # this allows to install both arch files and to use 32bit jdk on 64bit os
28 %define         _appdir         %{_prefix}/lib/%{name}
29
30 %description
31
32 %prep
33 %setup -qn RubyMine-%{version}
34
35 # keep only single arch files (don't want to pull 32bit deps by default),
36 # if you want to mix, install rpm from both arch
37 %ifarch %{ix86}
38 rm bin/fsnotifier64
39 rm bin/libyjpagent-linux64.so
40 rm bin/rubymine64.vmoptions
41 rm bin/libbreakgen64.so
42 %endif
43 %ifarch %{x8664}
44 rm bin/fsnotifier
45 rm bin/libyjpagent-linux.so
46 rm bin/rubymine.vmoptions
47 rm bin/libbreakgen.so
48 %endif
49 %patch0 -p1
50 chmod a+rx bin/*.so bin/fsnotifier*
51 mv bin/rubymine.png .
52 mv bin/RMlogo.svg .
53
54 # cleanup backups after patching
55 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{%{_appdir},%{_bindir},%{_pixmapsdir},%{_desktopdir}}
60 cp -l build.txt $RPM_BUILD_ROOT/cp-test && l=l && rm -f $RPM_BUILD_ROOT/cp-test
61 cp -p rubymine.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
62 cp -p RMlogo.svg $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.svg
63 cp -a$l bin help lib license plugins rb rubystubs* $RPM_BUILD_ROOT%{_appdir}
64 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
65 ln -s %{_appdir}/bin/rubymine.sh $RPM_BUILD_ROOT%{_bindir}/rubymine
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %post
71 %update_desktop_database
72
73 %postun
74 %update_desktop_database
75
76 %files
77 %defattr(644,root,root,755)
78 %attr(755,root,root) %{_bindir}/%{name}
79 %dir %{_appdir}
80 %{_appdir}/help
81 %{_appdir}/lib
82 %{_appdir}/license
83 %{_appdir}/plugins
84 %{_appdir}/rb
85 %{_appdir}/rubystubs*
86 %dir %{_appdir}/bin
87 %{_appdir}/bin/rubymine*.vmoptions
88 %{_appdir}/bin/idea.properties
89 %{_appdir}/bin/log.xml
90 %attr(755,root,root) %{_appdir}/bin/rubymine.sh
91 %attr(755,root,root) %{_appdir}/bin/rinspect.sh
92 %attr(755,root,root) %{_appdir}/bin/fsnotifier*
93 %attr(755,root,root) %{_appdir}/bin/libyjpagent-linux*.so
94 %attr(755,root,root) %{_appdir}/bin/libbreakgen*.so
95 %{_desktopdir}/%{name}.desktop
96 %{_pixmapsdir}/%{name}.png
97 %{_pixmapsdir}/%{name}.svg
This page took 0.046951 seconds and 3 git commands to generate.