]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
rpm fixed, ruby abi is provided versioned now
[packages/ruby.git] / ruby.spec
1 #
2 # TODO:
3 #       - include ext/ in docs
4 #       - replace ri with fastri
5 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
6 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
7 #   - custom-rubygems-location.patch
8 #
9 # Conditional build:
10 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
11 %bcond_without  tk              # skip building package with Tk bindings
12 %bcond_without  batteries       # Don't include rubygems, json or rake
13 %bcond_with     bootstrap       # build bootstrap version
14
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      392
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 %define         rubygems_ver    1.8.11
22 %define         minitest_ver    2.5.1
23 %define         rdoc_ver        3.9.5
24 Summary:        Ruby - interpreted scripting language
25 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
26 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
27 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
28 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
29 Name:           ruby
30 Version:        %{basever}.%{patchlevel}
31 # NOTE: do not decrease Release, when updating Version,
32 # unless rdoc_ver, rubygems_ver *both* are increased as well
33 Release:        7
34 Epoch:          1
35 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
36 License:        (Ruby or BSD) and Public Domain
37 Group:          Development/Languages
38 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/%{ruby_version}/%{name}-%{basever}-p%{patchlevel}.tar.bz2
39 # Source0-md5:  a810d64e2255179d2f334eb61fb8519c
40 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
41 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
42 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
43 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
44 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
45 # Source3-md5:  1892aadde51d36106c513bced2193dff
46 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
47 # Source100-md5:        50a49edb787211598d08e756e733e42e
48 Source4:        rdoc.1
49 Source5:        testrb.1
50 Patch0:         %{name}-lib64.patch
51 Patch1:         %{name}-ffs.patch
52 Patch2:         fix-bison-invocation.patch
53 # http://redmine.ruby-lang.org/issues/5231
54 Patch3:         disable-versioned-paths.patch
55 # TODO: Should be submitted upstream?
56 Patch4:         arch-specific-dir.patch
57 # http://redmine.ruby-lang.org/issues/5281
58 Patch5:         site-and-vendor-arch-flags.patch
59 # Make mkmf verbose by default
60 Patch6:         mkmf-verbose.patch
61 URL:            http://www.ruby-lang.org/
62 BuildRequires:  autoconf >= 2.60
63 BuildRequires:  automake
64 BuildRequires:  bison
65 BuildRequires:  db-devel
66 BuildRequires:  gdbm-devel >= 1.8.3
67 BuildRequires:  libffi-devel
68 BuildRequires:  ncurses-devel
69 BuildRequires:  openssl-devel
70 BuildRequires:  pkgconfig
71 BuildRequires:  readline-devel >= 4.2
72 BuildRequires:  rpm-build >= 5.4.10-49
73 # boostrap needs ruby binary, erb module
74 %{!?with_bootstrap:BuildRequires:       ruby-modules}
75 %{!?with_bootstrap:BuildRequires:       ruby}
76 BuildRequires:  sed >= 4.0
77 BuildRequires:  yaml-devel
78 %if %{with tk}
79 BuildRequires:  tk-devel
80 %endif
81 Requires(post,postun):  /sbin/ldconfig
82 Provides:       ruby(ver) = %{ruby_version}
83 Obsoletes:      rdoc
84 Obsoletes:      ruby-REXML
85 Obsoletes:      ruby-doc < 1.8.4
86 Obsoletes:      ruby-fastthread
87 %if %{with batteries}
88 Provides:       json = %{json_ver}
89 Provides:       rake = %{rake_ver}
90 Provides:       ruby-json = %{json_ver}
91 Provides:       ruby-rake = %{rake_ver}
92 Obsoletes:      ruby-json
93 Obsoletes:      ruby-rake
94 %endif
95 Conflicts:      ruby-activesupport < 2.3.11-2
96 Conflicts:      ruby-activesupport2 < 2.3.11-2
97 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
98
99 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
100 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
101
102 # The RubyGems library has to stay out of Ruby directory three, since the
103 # RubyGems should be share by all Ruby implementations.
104 %define rubygems_dir            %{_datadir}/rubygems
105
106 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
107 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
108
109 # This is the local lib/arch and should not be used for packaging.
110 %define sitedir                 site_ruby
111 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
112 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
113 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
114
115 # This is the general location for libs/archs compatible with all
116 # or most of the Ruby versions available in the PLD repositories.
117 %define vendordir               vendor_ruby
118 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
119 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
120 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
121
122 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
123 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
124 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_target_cpu}-linux
125 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
126 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
127 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
128 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
129 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
130 %define legacy_vendorarchdir    %{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
131
132 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
133 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
134 %define legacy_loadpath         %{legacy_archdir}
135 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
136
137 # bleh, some nasty (gcc or ruby) bug still not fixed
138 # (SEGV or "unexpected break" on miniruby run during build)
139 %define         specflags_ia64  -O0
140
141 # ruby needs frame pointers for correct exception handling
142 %define         specflags_ia32  -fno-omit-frame-pointer
143
144 %description
145 Ruby is the interpreted scripting language for quick and easy
146 object-oriented programming. It has many features to process text
147 files and to do system management tasks (as in Perl). It is simple,
148 straight-forward, extensible, and portable.
149
150 This package contains only shared library and ruby interpreter. To get
151 full-functional ruby environment install ruby-modules package.
152
153 %description -l ja.UTF-8
154 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
155 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
156 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
157
158 %description -l pl.UTF-8
159 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
160 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
161 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
162 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
163 rozszerzalny i przenośny.
164
165 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
166 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
167 funkcjonalnego środowiska ruby.
168
169 %description -l pt_BR.UTF-8
170 Ruby é uma linguagem de script interpretada de programação orientada a
171 objeto. Possui diversas características para processamento de texto. É
172 simples, extensível e direta.
173
174 %package modules
175 Summary:        Ruby standard modules and utilities
176 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
177 Group:          Development/Languages
178 Requires:       %{name} = %{epoch}:%{version}-%{release}
179 Suggests:       ruby-rubygems
180 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
181 Provides:       ruby-modules(ver) = %{ruby_version}
182 Obsoletes:      ruby-minitest
183
184 %description modules
185 Ruby standard modules and utilities:
186 - erb - Tiny eRuby
187 - irb - interactive Ruby
188 - testrb - automatic runner for Test::Unit of Ruby
189
190 %description modules -l pl.UTF-8
191 Standardowe moduły i narzędzia Ruby:
192 - erb - mały eRuby
193 - irb - interaktywny Ruby
194 - testrb - automatyczny runner dla Ruby Test::Unit
195
196 %package tk
197 Summary:        Ruby/Tk bindings
198 Summary(pl.UTF-8):      Wiązania Ruby/Tk
199 Group:          Development/Languages
200 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
201
202 %description tk
203 This pachage contains Ruby/Tk bindings.
204
205 %description tk -l pl.UTF-8
206 Ten pakiet zawiera wiązania Ruby/Tk.
207
208 %package devel
209 Summary:        Ruby development libraries
210 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
211 Group:          Development/Languages
212 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
213 Requires:       pkgconfig
214
215 %description devel
216 Ruby development libraries.
217
218 %description devel -l pl.UTF-8
219 Biblioteki programistyczne interpretera języka Ruby.
220
221 %package static
222 Summary:        Ruby static libraries
223 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
224 Group:          Development/Languages
225 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
226
227 %description static
228 Ruby static libraries.
229
230 %description static -l pl.UTF-8
231 Biblioteki statyczne Ruby.
232
233 %package doc
234 Summary:        Ruby HTML documentation
235 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
236 Group:          Documentation
237
238 %description doc
239 Ruby HTML documentation: FAQ, guide, core and standard library.
240
241 %description doc -l pl.UTF-8
242 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
243 stdlib.
244
245 %package doc-ri
246 Summary:        Ruby ri documentation
247 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
248 Group:          Documentation
249 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
250
251 %description doc-ri
252 Ruby ri documentation.
253
254 %description doc-ri -l pl.UTF-8
255 Dokumentacja Ruby w formacie ri.
256
257 %package examples
258 Summary:        Ruby examples
259 Summary(pl.UTF-8):      Przykłady dla języka Ruby
260 Group:          Development/Languages
261
262 %description examples
263 Ruby examples.
264
265 %description examples -l pl.UTF-8
266 Przykłady programów w języku Ruby.
267
268 # IMPORTANT: keep this as last package, as we reset Epoch
269 %package rdoc
270 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
271 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
272 Version:        %{rdoc_ver}
273 Epoch:          0
274 License:        GPL v2 and Ruby and MIT
275 Group:          Development/Libraries
276 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
277
278 %description rdoc
279 RDoc produces HTML and command-line documentation for Ruby projects.
280 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
281 online documentation.
282
283 %description rdoc -l pl.UTF-8
284 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
285 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
286 wyświetlania dokumentacji online.
287
288 %package rubygems
289 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
290 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
291 Version:        %{rubygems_ver}
292 Epoch:          0
293 License:        Ruby or MIT
294 Group:          Development/Libraries
295 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
296 Requires:       %{name}-rdoc >= %{rdoc_ver}
297 Provides:       rubygems = %{rubygems_ver}
298 %if "%{_rpmversion}" >= "5"
299 BuildArch:      noarch
300 %endif
301
302 %description rubygems
303 RubyGems is the Ruby standard for publishing and managing third party
304 libraries.
305
306 %description rubygems -l pl.UTF-8
307 RubyGems to standardowe narzędzie języka Ruby do publikowania i
308 zarządzania zewnętrznymi bibliotekami.
309
310 %prep
311 %if %{with bootstrap}
312 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
313 %else
314 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
315 %endif
316 %patch0 -p1
317 %patch1 -p1
318 %patch2 -p1
319 %patch3 -p1
320 %patch4 -p1
321 %patch5 -p1
322
323 # must be regenerated with new bison
324 %{__rm} parse.{c,h}
325
326 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
327
328 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
329         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
330         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
331
332 %build
333 cp -f /usr/share/automake/config.sub .
334
335 # build ruby-1.8.7 first
336 %if %{with bootstrap}
337 cd %{name}-1.8.7-p330
338 %configure
339 %{__make}
340 cd ..
341 %endif
342
343 %{__autoconf}
344 %configure \
345         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
346         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
347         --with-archdir=%{ruby_archdir} \
348         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
349         --with-sitearchdir=%{ruby_sitearchdir} \
350         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
351         --with-vendorarchdir=%{ruby_vendorarchdir} \
352         --with-rubygemsdir=%{rubygems_dir} \
353         --with-search-path="%{legacy_loadpaths}" \
354         --enable-shared \
355         --enable-pthread \
356         --disable-rubygems \
357         --disable-install-doc \
358         --with-ruby-version=minor
359
360 %{__make} -j1 main \
361         COPY="cp -p" Q= \
362         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
363
364 %if %{with doc}
365 %{__make} -j1 rdoc
366 %endif
367
368 %install
369 rm -rf $RPM_BUILD_ROOT
370 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
371         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
372         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
373         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
374
375 %{__make} install %{?with_doc:install-doc} \
376         DESTDIR=$RPM_BUILD_ROOT
377
378 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
379 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
380 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
381
382 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
383
384 %if %{without batteries}
385 # packaged separately
386 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json}
387 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
388 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
389 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
390 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
391 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON
392 %endif
393
394 %if %{with doc}
395 # too much .ri
396 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
397 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
398 %endif
399
400 %clean
401 rm -rf $RPM_BUILD_ROOT
402
403 %post   -p /sbin/ldconfig
404 %postun -p /sbin/ldconfig
405
406 %files
407 %defattr(644,root,root,755)
408 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
409 %attr(755,root,root) %{_bindir}/ruby
410 %if %{with batteries}
411 %attr(755,root,root) %{_bindir}/rake
412 %endif
413 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
414 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
415 %{_mandir}/man1/ruby.1*
416 %if %{with batteries}
417 %{_mandir}/man1/rake.1*
418 %endif
419
420 %dir %{_libdir}/%{name}
421 %dir %{_libdir}/%{name}/%{vendordir}
422 %dir %{_datadir}/%{name}
423 %dir %{_datadir}/%{name}/%{vendordir}
424
425 %dir %{ruby_libdir}
426 %dir %{ruby_archdir}
427 %dir %{ruby_vendorlibdir}
428 %dir %{ruby_vendorarchdir}
429
430 %dir %{_datadir}/ri
431 %dir %{_datadir}/ri/%{ruby_version}
432 %dir %{ruby_ridir}
433
434 %dir %{ruby_rdocdir}
435
436 # common dirs for ruby vendor modules
437 %dir %{ruby_vendorlibdir}/net
438
439 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
440 %dir %{legacy_archdir}
441 %dir %{legacy_sitedir}
442 %dir %{legacy_sitelibdir}
443 %dir %{legacy_sitearchdir}
444 %dir %{legacy_vendorarchdir}
445 %dir %{legacy_libdir}/tasks
446 %dir %{legacy_archdir}/racc
447
448 %files devel
449 %defattr(644,root,root,755)
450 %attr(755,root,root) %{_libdir}/libruby.so
451 %{_includedir}/%{name}-%{ruby_version}
452 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
453 %{ruby_libdir}/mkmf.rb
454
455 %files static
456 %defattr(644,root,root,755)
457 %{_libdir}/libruby-static.a
458
459 %if %{with tk}
460 %files tk
461 %defattr(644,root,root,755)
462 %{ruby_libdir}/tcltk.rb
463 %{ruby_libdir}/tk*.rb
464 %{ruby_libdir}/tk
465 %{ruby_libdir}/tkextlib
466 %attr(755,root,root) %{ruby_archdir}/t*.so
467 %endif
468
469 %files rdoc
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_bindir}/rdoc
472 %attr(755,root,root) %{_bindir}/ri
473 %{_mandir}/man1/rdoc.1*
474 %{ruby_libdir}/rdoc
475 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
476 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
477 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
478 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
479 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
480
481 %if %{with batteries}
482 %files rubygems
483 %defattr(644,root,root,755)
484 %attr(755,root,root) %{_bindir}/gem
485 %{ruby_libdir}/rubygems
486 %{ruby_libdir}/rubygems.rb
487 %{ruby_libdir}/ubygems.rb
488
489 %{gem_dir}/specifications/io-console-*.gemspec
490 %{gem_dir}/specifications/bigdecimal-*.gemspec
491 %if %{with batteries}
492 %dir %{gem_dir}/gems/rake-%{rake_ver}
493 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
494 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
495 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
496 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
497 %{gem_dir}/specifications/json-%{json_ver}.gemspec
498 %endif
499 %endif
500
501 %files modules
502 %defattr(644,root,root,755)
503 %attr(755,root,root) %{_bindir}/erb
504 %attr(755,root,root) %{_bindir}/irb
505 %attr(755,root,root) %{_bindir}/testrb
506 %{ruby_libdir}/bigdecimal
507 %{ruby_libdir}/cgi
508 %{ruby_libdir}/date
509 %{ruby_libdir}/digest
510 %{ruby_libdir}/dl
511 %{ruby_libdir}/drb
512 %{ruby_libdir}/fiddle
513 %{ruby_libdir}/io
514 %{ruby_libdir}/irb
515 %{ruby_libdir}/matrix
516 %{ruby_libdir}/minitest
517 %{ruby_libdir}/net
518 %{ruby_libdir}/openssl
519 %{ruby_libdir}/optparse
520 %if %{with batteries}
521 %{ruby_libdir}/json
522 %{ruby_libdir}/rake
523 %endif
524 %{ruby_libdir}/psych
525 %{ruby_libdir}/racc
526 %{ruby_libdir}/rbconfig
527 %{ruby_libdir}/rexml
528 %{ruby_libdir}/rinda
529 %{ruby_libdir}/ripper
530 %{ruby_libdir}/rss
531 %{ruby_libdir}/shell
532 %{ruby_libdir}/syck
533 %{ruby_libdir}/test
534 %{ruby_libdir}/uri
535 %{ruby_libdir}/webrick
536 %{ruby_libdir}/xmlrpc
537 %{ruby_libdir}/yaml
538 %{ruby_libdir}/[A-Za-s]*.rb
539 %{ruby_libdir}/tempfile.rb
540 %{ruby_libdir}/thread.rb
541 %{ruby_libdir}/thwait.rb
542 %{ruby_libdir}/time.rb
543 %{ruby_libdir}/timeout.rb
544 %{ruby_libdir}/tmpdir.rb
545 %{ruby_libdir}/tracer.rb
546 %{ruby_libdir}/tsort.rb
547 %{ruby_libdir}/[u-z]*.rb
548 %exclude %{ruby_libdir}/rubygems.rb
549 %exclude %{ruby_libdir}/ubygems.rb
550 %exclude %{ruby_libdir}/mkmf.rb
551 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
552 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
553 %dir %{ruby_archdir}/digest
554 %attr(755,root,root) %{ruby_archdir}/digest/*.so
555 %dir %{ruby_archdir}/dl
556 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
557 %dir %{ruby_archdir}/enc
558 %attr(755,root,root) %{ruby_archdir}/enc/*.so
559 %dir %{ruby_archdir}/enc/trans
560 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
561 %dir %{ruby_archdir}/io
562 %attr(755,root,root) %{ruby_archdir}/io/*.so
563 %if %{with batteries}
564 %dir %{ruby_archdir}/json
565 %dir %{ruby_archdir}/json/ext
566 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
567 %endif
568 %dir %{ruby_archdir}/mathn
569 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
570 %dir %{ruby_archdir}/racc
571 %attr(755,root,root) %{ruby_archdir}/racc/*.so
572 %{ruby_archdir}/rbconfig.rb
573
574 # parents of gem_dir
575 %dir %{_datadir}/%{name}/gems
576 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
577 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
578
579 %dir %{gem_dir}
580 %dir %{gem_dir}/specifications
581 %{_mandir}/man1/erb.1*
582 %{_mandir}/man1/irb.1*
583 %{_mandir}/man1/ri.1*
584 %{_mandir}/man1/testrb.1*
585
586 %files doc
587 %defattr(644,root,root,755)
588 %doc ruby-doc-bundle/*
589 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
590 %{?with_doc:%doc ruby_%{doc_version}_core}
591
592 %if %{with doc}
593 %files doc-ri
594 %defattr(644,root,root,755)
595 %{ruby_ridir}/*
596 %endif
597
598 %files examples
599 %defattr(644,root,root,755)
600 %{_examplesdir}/%{name}-%{version}
This page took 0.074493 seconds and 4 git commands to generate.