]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
ease building gems from source
[packages/ruby.git] / ruby.spec
1 #
2 # TODO:
3 #       - include ext/ in docs
4 #       - replace ri with fastri
5 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
6 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
7 #   - custom-rubygems-location.patch
8 #
9 # Conditional build:
10 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
11 %bcond_without  tk              # skip building package with Tk bindings
12 %bcond_without  batteries       # Don't include rubygems, json, rake, minitest
13 %bcond_with     bootstrap       # build bootstrap version
14
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      426
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 %define         rubygems_ver    1.8.11
22 %define         minitest_ver    2.5.1
23 %define         rdoc_ver        3.9.5
24 %define         bigdecimal_ver  1.1.0
25 %define         io_console_ver  0.3
26 Summary:        Ruby - interpreted scripting language
27 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
28 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
29 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
30 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
31 Name:           ruby
32 Version:        %{basever}.%{patchlevel}
33 # NOTE: do not decrease Release, when updating Version,
34 # unless rdoc_ver, rubygems_ver *both* are increased as well
35 Release:        11
36 Epoch:          1
37 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
38 License:        (Ruby or BSD) and Public Domain
39 Group:          Development/Languages
40 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/1.9/%{name}-%{basever}-p%{patchlevel}.tar.bz2
41 # Source0-md5:  c211205e65d7253fc2a4620a34bc9245
42 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
43 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
44 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
45 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
46 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
47 # Source3-md5:  1892aadde51d36106c513bced2193dff
48 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
49 # Source100-md5:        50a49edb787211598d08e756e733e42e
50 Source4:        rdoc.1
51 Source5:        testrb.1
52 Patch0:         %{name}-lib64.patch
53 Patch1:         %{name}-ffs.patch
54 Patch2:         fix-bison-invocation.patch
55 # http://redmine.ruby-lang.org/issues/5231
56 Patch3:         disable-versioned-paths.patch
57 # TODO: Should be submitted upstream?
58 Patch4:         arch-specific-dir.patch
59 # http://redmine.ruby-lang.org/issues/5281
60 Patch5:         site-and-vendor-arch-flags.patch
61 # Make mkmf verbose by default
62 Patch6:         mkmf-verbose.patch
63 URL:            http://www.ruby-lang.org/
64 BuildRequires:  autoconf >= 2.60
65 BuildRequires:  automake
66 BuildRequires:  bison
67 BuildRequires:  db-devel
68 BuildRequires:  gdbm-devel >= 1.8.3
69 BuildRequires:  libffi-devel
70 BuildRequires:  ncurses-devel
71 BuildRequires:  openssl-devel
72 BuildRequires:  pkgconfig
73 BuildRequires:  readline-devel >= 4.2
74 BuildRequires:  rpm-build >= 5.4.10-49
75 # boostrap needs ruby binary, erb module
76 %{!?with_bootstrap:BuildRequires:       ruby-modules}
77 %{!?with_bootstrap:BuildRequires:       ruby}
78 BuildRequires:  sed >= 4.0
79 BuildRequires:  yaml-devel
80 %if %{with tk}
81 BuildRequires:  tk-devel
82 %endif
83 Requires(post,postun):  /sbin/ldconfig
84 Provides:       ruby(ver) = %{ruby_version}
85 Obsoletes:      ruby-REXML <= 2.4.0-2
86 Obsoletes:      ruby-doc < 1.8.4
87 Obsoletes:      ruby-fastthread <= 0.6.3
88 Conflicts:      ruby-activesupport < 2.3.11-2
89 Conflicts:      ruby-activesupport2 < 2.3.11-2
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
93 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
94
95 # The RubyGems library has to stay out of Ruby directory three, since the
96 # RubyGems should be share by all Ruby implementations.
97 %define rubygems_dir            %{_datadir}/rubygems
98
99 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
100 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
101
102 # This is the local lib/arch and should not be used for packaging.
103 %define sitedir                 site_ruby
104 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
105 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
106 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
107
108 # This is the general location for libs/archs compatible with all
109 # or most of the Ruby versions available in the PLD repositories.
110 %define vendordir               vendor_ruby
111 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
112 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
113 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
114
115 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
116 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
117 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_target_cpu}-linux
118 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
119 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
120 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_target_cpu}-linux
121 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
122 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
123 %define legacy_vendorarchdir    %{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_target_cpu}-linux
124
125 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
126 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
127 %define legacy_loadpath         %{legacy_archdir}
128 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
129
130 # bleh, some nasty (gcc or ruby) bug still not fixed
131 # (SEGV or "unexpected break" on miniruby run during build)
132 %define         specflags_ia64  -O0
133
134 # ruby needs frame pointers for correct exception handling
135 %define         specflags_ia32  -fno-omit-frame-pointer
136
137 %description
138 Ruby is the interpreted scripting language for quick and easy
139 object-oriented programming. It has many features to process text
140 files and to do system management tasks (as in Perl). It is simple,
141 straight-forward, extensible, and portable.
142
143 This package contains only shared library and ruby interpreter. To get
144 full-functional ruby environment install ruby-modules package.
145
146 %description -l ja.UTF-8
147 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
148 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
149 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
150
151 %description -l pl.UTF-8
152 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
153 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
154 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
155 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
156 rozszerzalny i przenośny.
157
158 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
159 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
160 funkcjonalnego środowiska ruby.
161
162 %description -l pt_BR.UTF-8
163 Ruby é uma linguagem de script interpretada de programação orientada a
164 objeto. Possui diversas características para processamento de texto. É
165 simples, extensível e direta.
166
167 %package modules
168 Summary:        Ruby standard modules and utilities
169 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
170 Group:          Development/Languages
171 Requires:       %{name} = %{epoch}:%{version}-%{release}
172 Suggests:       ruby-rubygems
173 Provides:       ruby-bigdecimal = %{bigdecimal_ver}
174 Provides:       ruby-io-console = %{io_console_ver}
175 # ruby-modules deprecated, rpm5 generates ruby(abi) itself
176 Provides:       ruby-modules(ver) = %{ruby_version}
177 %if %{with batteries}
178 Provides:       rake = %{rake_ver}
179 Provides:       ruby-json = %{json_ver}
180 Provides:       ruby-minitest = %{minitest_ver}
181 Provides:       ruby-rake = %{rake_ver}
182 Obsoletes:      ruby-json <= 1.5.4
183 Obsoletes:      ruby-minitest <= 1.5.0
184 Obsoletes:      ruby-rake < 0.9.2.2
185 %endif
186
187 %description modules
188 Ruby standard modules and utilities:
189 - erb - Tiny eRuby
190 - irb - interactive Ruby
191 - testrb - automatic runner for Test::Unit of Ruby
192
193 %description modules -l pl.UTF-8
194 Standardowe moduły i narzędzia Ruby:
195 - erb - mały eRuby
196 - irb - interaktywny Ruby
197 - testrb - automatyczny runner dla Ruby Test::Unit
198
199 %package tk
200 Summary:        Ruby/Tk bindings
201 Summary(pl.UTF-8):      Wiązania Ruby/Tk
202 Group:          Development/Languages
203 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
204
205 %description tk
206 This pachage contains Ruby/Tk bindings.
207
208 %description tk -l pl.UTF-8
209 Ten pakiet zawiera wiązania Ruby/Tk.
210
211 %package devel
212 Summary:        Ruby development libraries
213 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
214 Group:          Development/Languages
215 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
216 Requires:       gcc
217 Requires:       glibc-devel
218 Requires:       pkgconfig
219
220 %description devel
221 Ruby development libraries.
222
223 %description devel -l pl.UTF-8
224 Biblioteki programistyczne interpretera języka Ruby.
225
226 %package static
227 Summary:        Ruby static libraries
228 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
229 Group:          Development/Languages
230 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
231
232 %description static
233 Ruby static libraries.
234
235 %description static -l pl.UTF-8
236 Biblioteki statyczne Ruby.
237
238 %package doc
239 Summary:        Ruby HTML documentation
240 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
241 Group:          Documentation
242 %if "%{_rpmversion}" >= "5"
243 BuildArch:      noarch
244 %endif
245
246 %description doc
247 Ruby HTML documentation: FAQ, guide, core and standard library.
248
249 %description doc -l pl.UTF-8
250 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
251 stdlib.
252
253 %package doc-ri
254 Summary:        Ruby ri documentation
255 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
256 Group:          Documentation
257 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
258 %if "%{_rpmversion}" >= "5"
259 BuildArch:      noarch
260 %endif
261
262 %description doc-ri
263 Ruby ri documentation.
264
265 %description doc-ri -l pl.UTF-8
266 Dokumentacja Ruby w formacie ri.
267
268 %package examples
269 Summary:        Ruby examples
270 Summary(pl.UTF-8):      Przykłady dla języka Ruby
271 Group:          Development/Languages
272 %if "%{_rpmversion}" >= "5"
273 BuildArch:      noarch
274 %endif
275
276 %description examples
277 Ruby examples.
278
279 %description examples -l pl.UTF-8
280 Przykłady programów w języku Ruby.
281
282 # IMPORTANT: keep this as last package, as we reset Epoch
283 %package rdoc
284 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
285 Summary(pl.UTF-8):      Narzędzie do generowania dokumentacji HTML i linii poleceń dla projektów w Rubym
286 Version:        %{rdoc_ver}
287 Epoch:          0
288 License:        GPL v2 and Ruby and MIT
289 Group:          Development/Libraries
290 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
291 Obsoletes:      rdoc <= 0.9.0
292 %if "%{_rpmversion}" >= "5"
293 BuildArch:      noarch
294 %endif
295
296 %description rdoc
297 RDoc produces HTML and command-line documentation for Ruby projects.
298 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
299 online documentation.
300
301 %description rdoc -l pl.UTF-8
302 RDoc tworzy dokumentację HTML i linii poleceń dla projektów w języku
303 Ruby. RDoc zawiera narzędzia 'rdoc' i 'ri' do generowania i
304 wyświetlania dokumentacji online.
305
306 %package rubygems
307 Summary:        RubyGems - the Ruby standard for packaging Ruby libraries
308 Summary(pl.UTF-8):      RubyGems - standard Ruby'ego pakietowania bibliotek
309 Version:        %{rubygems_ver}
310 Epoch:          0
311 License:        Ruby or MIT
312 Group:          Development/Libraries
313 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
314 Requires:       %{name}-rdoc >= %{rdoc_ver}
315 Suggests:       %{name}-devel
316 Provides:       rubygems = %{rubygems_ver}
317 %if "%{_rpmversion}" >= "5"
318 BuildArch:      noarch
319 %endif
320
321 %description rubygems
322 RubyGems is the Ruby standard for publishing and managing third party
323 libraries.
324
325 %description rubygems -l pl.UTF-8
326 RubyGems to standardowe narzędzie języka Ruby do publikowania i
327 zarządzania zewnętrznymi bibliotekami.
328
329 %prep
330 %if %{with bootstrap}
331 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
332 %else
333 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
334 %endif
335 %patch0 -p1
336 %patch1 -p1
337 %patch2 -p1
338 %patch3 -p1
339 %patch4 -p1
340 %patch5 -p1
341
342 # must be regenerated with new bison
343 %{__rm} parse.{c,h}
344
345 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
346
347 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
348         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
349         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
350
351 %build
352 cp -f /usr/share/automake/config.sub .
353
354 # build ruby-1.8.7 first
355 %if %{with bootstrap}
356 cd %{name}-1.8.7-p330
357 %configure
358 %{__make}
359 cd ..
360 %endif
361
362 %{__autoconf}
363 %configure \
364         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
365         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
366         --with-archdir=%{ruby_archdir} \
367         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
368         --with-sitearchdir=%{ruby_sitearchdir} \
369         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
370         --with-vendorarchdir=%{ruby_vendorarchdir} \
371         --with-rubygemsdir=%{rubygems_dir} \
372         --with-search-path="%{legacy_loadpaths}" \
373         --enable-shared \
374         --enable-pthread \
375         --disable-rubygems \
376         --disable-install-doc \
377         --with-ruby-version=minor
378
379 %{__make} -j1 main \
380         COPY="cp -p" Q= \
381         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
382
383 %if %{with doc}
384 %{__make} -j1 rdoc
385 %endif
386
387 %install
388 rm -rf $RPM_BUILD_ROOT
389 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
390         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
391         $RPM_BUILD_ROOT%{ruby_vendorlibdir}/net \
392         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
393
394 %{__make} install %{?with_doc:install-doc} \
395         DESTDIR=$RPM_BUILD_ROOT
396
397 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
398 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
399 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
400
401 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
402
403 %if %{without batteries}
404 # packaged separately
405 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,minitest}
406 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
407 %{__rm} -r $RPM_BUILD_ROOT%{gem_dir}/gems/rake-*
408 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
409 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
410 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
411 %{__rm} $RPM_BUILD_ROOT%{gem_dir}/specifications/{json,minitest,rake}-*.gemspec
412 %{?with_doc:%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON}
413 %endif
414
415 %if %{with doc}
416 # too much .ri
417 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
418 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
419 %endif
420
421 %clean
422 rm -rf $RPM_BUILD_ROOT
423
424 %post   -p /sbin/ldconfig
425 %postun -p /sbin/ldconfig
426
427 %files
428 %defattr(644,root,root,755)
429 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
430 %attr(755,root,root) %{_bindir}/ruby
431 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
432 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
433 %{_mandir}/man1/ruby.1*
434
435 %if %{with batteries}
436 # rake
437 %attr(755,root,root) %{_bindir}/rake
438 %{_mandir}/man1/rake.1*
439 %endif
440
441 %dir %{_libdir}/%{name}
442 %dir %{_libdir}/%{name}/%{vendordir}
443 %dir %{_datadir}/%{name}
444 %dir %{_datadir}/%{name}/%{vendordir}
445
446 %dir %{ruby_libdir}
447 %dir %{ruby_archdir}
448 %dir %{ruby_vendorlibdir}
449 %dir %{ruby_vendorarchdir}
450
451 %dir %{_datadir}/ri
452 %dir %{_datadir}/ri/%{ruby_version}
453 %dir %{ruby_ridir}
454
455 %dir %{ruby_rdocdir}
456
457 # common dirs for ruby vendor modules
458 %dir %{ruby_vendorlibdir}/net
459
460 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
461 %dir %{legacy_archdir}
462 %dir %{legacy_sitedir}
463 %dir %{legacy_sitelibdir}
464 %dir %{legacy_sitearchdir}
465 %dir %{legacy_vendorarchdir}
466 %dir %{legacy_libdir}/tasks
467 %dir %{legacy_archdir}/racc
468
469 %files devel
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_libdir}/libruby.so
472 %{_includedir}/%{name}-%{ruby_version}
473 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
474 %{ruby_libdir}/mkmf.rb
475
476 %files static
477 %defattr(644,root,root,755)
478 %{_libdir}/libruby-static.a
479
480 %if %{with tk}
481 %files tk
482 %defattr(644,root,root,755)
483 %{ruby_libdir}/tcltk.rb
484 %{ruby_libdir}/tk*.rb
485 %{ruby_libdir}/tk
486 %{ruby_libdir}/tkextlib
487 %attr(755,root,root) %{ruby_archdir}/t*.so
488 %endif
489
490 %files rdoc
491 %defattr(644,root,root,755)
492 %attr(755,root,root) %{_bindir}/rdoc
493 %attr(755,root,root) %{_bindir}/ri
494 %{_mandir}/man1/rdoc.1*
495 %{ruby_libdir}/rdoc
496 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
497 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
498 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
499 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
500 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
501
502 %if %{with batteries}
503 %files rubygems
504 %defattr(644,root,root,755)
505 %attr(755,root,root) %{_bindir}/gem
506 %{ruby_libdir}/rubygems
507 %{ruby_libdir}/rubygems.rb
508 %{ruby_libdir}/ubygems.rb
509 %endif
510
511 %files modules
512 %defattr(644,root,root,755)
513 %attr(755,root,root) %{_bindir}/erb
514 %attr(755,root,root) %{_bindir}/irb
515 %attr(755,root,root) %{_bindir}/testrb
516 %{ruby_libdir}/bigdecimal
517 %{ruby_libdir}/cgi
518 %{ruby_libdir}/date
519 %{ruby_libdir}/digest
520 %{ruby_libdir}/dl
521 %{ruby_libdir}/drb
522 %{ruby_libdir}/fiddle
523 %{ruby_libdir}/io
524 %{ruby_libdir}/irb
525 %{ruby_libdir}/matrix
526 %{ruby_libdir}/net
527 %{ruby_libdir}/openssl
528 %{ruby_libdir}/optparse
529 %{ruby_libdir}/psych
530 %{ruby_libdir}/racc
531 %{ruby_libdir}/rbconfig
532 %{ruby_libdir}/rexml
533 %{ruby_libdir}/rinda
534 %{ruby_libdir}/ripper
535 %{ruby_libdir}/rss
536 %{ruby_libdir}/shell
537 %{ruby_libdir}/syck
538 %{ruby_libdir}/test
539 %{ruby_libdir}/uri
540 %{ruby_libdir}/webrick
541 %{ruby_libdir}/xmlrpc
542 %{ruby_libdir}/yaml
543 %{ruby_libdir}/[A-Za-s]*.rb
544 %{ruby_libdir}/tempfile.rb
545 %{ruby_libdir}/thread.rb
546 %{ruby_libdir}/thwait.rb
547 %{ruby_libdir}/time.rb
548 %{ruby_libdir}/timeout.rb
549 %{ruby_libdir}/tmpdir.rb
550 %{ruby_libdir}/tracer.rb
551 %{ruby_libdir}/tsort.rb
552 %{ruby_libdir}/[u-z]*.rb
553 %if %{with batteries}
554 %exclude %{ruby_libdir}/rubygems.rb
555 %exclude %{ruby_libdir}/ubygems.rb
556 %endif
557 %exclude %{ruby_libdir}/mkmf.rb
558 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
559 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
560 %dir %{ruby_archdir}/digest
561 %attr(755,root,root) %{ruby_archdir}/digest/*.so
562 %dir %{ruby_archdir}/dl
563 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
564 %dir %{ruby_archdir}/enc
565 %attr(755,root,root) %{ruby_archdir}/enc/*.so
566 %dir %{ruby_archdir}/enc/trans
567 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
568 %dir %{ruby_archdir}/io
569 %attr(755,root,root) %{ruby_archdir}/io/*.so
570 %dir %{ruby_archdir}/mathn
571 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
572 %dir %{ruby_archdir}/racc
573 %attr(755,root,root) %{ruby_archdir}/racc/*.so
574 %{ruby_archdir}/rbconfig.rb
575
576 %{gem_dir}/specifications/bigdecimal-%{bigdecimal_ver}.gemspec
577 %{gem_dir}/specifications/io-console-%{io_console_ver}.gemspec
578
579 %if %{with batteries}
580 # json
581 %{ruby_libdir}/json
582 %dir %{ruby_archdir}/json
583 %dir %{ruby_archdir}/json/ext
584 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
585 %{gem_dir}/specifications/json-%{json_ver}.gemspec
586
587 # minitest
588 %{ruby_libdir}/minitest
589 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
590
591 # rake
592 %{ruby_libdir}/rake
593 %dir %{gem_dir}/gems/rake-%{rake_ver}
594 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
595 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
596 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
597 %endif
598
599 # parents of gem_dir
600 %dir %{_datadir}/%{name}/gems
601 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
602 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
603
604 %dir %{gem_dir}
605 %dir %{gem_dir}/specifications
606 %{_mandir}/man1/erb.1*
607 %{_mandir}/man1/irb.1*
608 %{_mandir}/man1/ri.1*
609 %{_mandir}/man1/testrb.1*
610
611 %files doc
612 %defattr(644,root,root,755)
613 %doc ruby-doc-bundle/*
614 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
615 %{?with_doc:%doc ruby_%{doc_version}_core}
616
617 %if %{with doc}
618 %files doc-ri
619 %defattr(644,root,root,755)
620 %{ruby_ridir}/*
621 %endif
622
623 %files examples
624 %defattr(644,root,root,755)
625 %{_examplesdir}/%{name}-%{version}
This page took 0.093029 seconds and 4 git commands to generate.