]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
drop verpath bcond, unsupported at this point
[packages/ruby.git] / ruby.spec
1 #
2 # TODO:
3 #       - include ext/ in docs
4 #       - replace ri with fastri
5 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
6 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
7 #   - custom-rubygems-location.patch
8 #
9 # Conditional build:
10 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
11 %bcond_without  tk              # skip building package with Tk bindings
12 %bcond_without  batteries       # Don't include rubygems, json or rake
13 %bcond_with     bootstrap       # build bootstrap version
14
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      392
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 %define         rubygems_ver    1.8.11
22 %define         minitest_ver    2.5.1
23 %define         rdoc_ver        3.9.5
24 Summary:        Ruby - interpreted scripting language
25 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
26 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
27 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
28 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
29 Name:           ruby
30 Version:        %{basever}.%{patchlevel}
31 # NOTE: do not decrease Release, when updating Version,
32 # unless rdoc_ver, rubygems_ver *both* are increased as well
33 Release:        0.24
34 Epoch:          1
35 License:        The Ruby License
36 Group:          Development/Languages
37 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/%{ruby_version}/%{name}-%{basever}-p%{patchlevel}.tar.bz2
38 # Source0-md5:  a810d64e2255179d2f334eb61fb8519c
39 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
40 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
41 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
42 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
43 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
44 # Source3-md5:  1892aadde51d36106c513bced2193dff
45 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
46 # Source100-md5:        50a49edb787211598d08e756e733e42e
47 Source4:        rdoc.1
48 Source5:        testrb.1
49 Source6:        %{name}-mode-init.el
50 Patch0:         %{name}-lib64.patch
51 Patch1:         %{name}-ffs.patch
52 Patch2:         fix-bison-invocation.patch
53 # http://redmine.ruby-lang.org/issues/5231
54 Patch3:         disable-versioned-paths.patch
55 # TODO: Should be submitted upstream?
56 Patch4:         arch-specific-dir.patch
57 # http://redmine.ruby-lang.org/issues/5281
58 Patch5:         site-and-vendor-arch-flags.patch
59 URL:            http://www.ruby-lang.org/
60 BuildRequires:  autoconf >= 2.60
61 BuildRequires:  automake
62 BuildRequires:  bison
63 BuildRequires:  db-devel
64 BuildRequires:  gdbm-devel >= 1.8.3
65 BuildRequires:  libffi-devel
66 BuildRequires:  ncurses-devel
67 BuildRequires:  openssl-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  readline-devel >= 4.2
70 %{!?with_bootstrap:BuildRequires:       ruby-modules}
71 BuildRequires:  sed >= 4.0
72 BuildRequires:  yaml-devel
73 %if %{with tk}
74 BuildRequires:  tk-devel
75 %endif
76 Requires(post,postun):  /sbin/ldconfig
77 Provides:       ruby(ver) = %{ruby_version}
78 Obsoletes:      rdoc
79 Obsoletes:      ruby-REXML
80 Obsoletes:      ruby-doc < 1.8.4
81 Obsoletes:      ruby-fastthread
82 %if %{with batteries}
83 Provides:       json = %{json_ver}
84 Provides:       rake = %{rake_ver}
85 Provides:       ruby-json = %{json_ver}
86 Provides:       ruby-rake = %{rake_ver}
87 Obsoletes:      ruby-json
88 Obsoletes:      ruby-rake
89 %endif
90 Conflicts:      ruby-activesupport < 2.3.11-2
91 Conflicts:      ruby-activesupport2 < 2.3.11-2
92 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
93
94 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
95 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
96
97 # The RubyGems library has to stay out of Ruby directory three, since the
98 # RubyGems should be share by all Ruby implementations.
99 %define rubygems_dir            %{_datadir}/rubygems
100
101 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
102 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
103
104 # This is the local lib/arch and should not be used for packaging.
105 %define sitedir                 site_ruby
106 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
107 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
108 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
109
110 # This is the general location for libs/archs compatible with all
111 # or most of the Ruby versions available in the PLD repositories.
112 %define vendordir               vendor_ruby
113 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
114 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
115 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
116
117 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
118 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
119 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_arch}-linux
120 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
121 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
122 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_arch}-linux
123 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
124 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
125 %define legacy_vendorarchdir%{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_arch}-linux
126
127 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
128 %define legacy_vendorloadpath   %{legacy_vendorlibdir}\\0%{legacy_vendorarchdir}
129 %define legacy_loadpath         %{legacy_archdir}
130 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
131
132 # bleh, some nasty (gcc or ruby) bug still not fixed
133 # (SEGV or "unexpected break" on miniruby run during build)
134 %define         specflags_ia64  -O0
135
136 # ruby needs frame pointers for correct exception handling
137 %define         specflags_ia32  -fno-omit-frame-pointer
138
139 %description
140 Ruby is the interpreted scripting language for quick and easy
141 object-oriented programming. It has many features to process text
142 files and to do system management tasks (as in Perl). It is simple,
143 straight-forward, extensible, and portable.
144
145 This package contains only shared library and ruby interpreter. To get
146 full-functional ruby environment install ruby-modules package.
147
148 %description -l ja.UTF-8
149 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
150 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
151 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
152
153 %description -l pl.UTF-8
154 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
155 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
156 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
157 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
158 rozszerzalny i przenośny.
159
160 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
161 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
162 funkcjonalnego środowiska ruby.
163
164 %description -l pt_BR.UTF-8
165 Ruby é uma linguagem de script interpretada de programação orientada a
166 objeto. Possui diversas características para processamento de texto. É
167 simples, extensível e direta.
168
169 %package modules
170 Summary:        Ruby standard modules and utilities
171 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
172 Group:          Development/Languages
173 Requires:       %{name} = %{epoch}:%{version}-%{release}
174 # workaround for autodep generator not getting version properly
175 Provides:       ruby(abi) = %{ruby_version}
176 Provides:       ruby-modules(ver) = %{ruby_version}
177 Obsoletes:      ruby-minitest
178
179 %description modules
180 Ruby standard modules and utilities:
181 - erb - Tiny eRuby
182 - irb - interactive Ruby
183 - testrb - automatic runner for Test::Unit of Ruby
184
185 %description modules -l pl.UTF-8
186 Standardowe moduły i narzędzia Ruby:
187 - erb - mały eRuby
188 - irb - interaktywny Ruby
189 - testrb - automatyczny runner dla Ruby Test::Unit
190
191 %package tk
192 Summary:        Ruby/Tk bindings
193 Summary(pl.UTF-8):      Wiązania Ruby/Tk
194 Group:          Development/Languages
195 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
196
197 %description tk
198 This pachage contains Ruby/Tk bindings.
199
200 %description tk -l pl.UTF-8
201 Ten pakiet zawiera wiązania Ruby/Tk.
202
203 %package devel
204 Summary:        Ruby development libraries
205 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
206 Group:          Development/Languages
207 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
208
209 %description devel
210 Ruby development libraries.
211
212 %description devel -l pl.UTF-8
213 Biblioteki programistyczne interpretera języka Ruby.
214
215 %package static
216 Summary:        Ruby static libraries
217 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
218 Group:          Development/Languages
219 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
220
221 %description static
222 Ruby static libraries.
223
224 %description static -l pl.UTF-8
225 Biblioteki statyczne Ruby.
226
227 %package doc
228 Summary:        Ruby HTML documentation
229 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
230 Group:          Documentation
231
232 %description doc
233 Ruby HTML documentation: FAQ, guide, core and standard library.
234
235 %description doc -l pl.UTF-8
236 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
237 stdlib.
238
239 %package doc-ri
240 Summary:        Ruby ri documentation
241 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
242 Group:          Documentation
243 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
244
245 %description doc-ri
246 Ruby ri documentation.
247
248 %description doc-ri -l pl.UTF-8
249 Dokumentacja Ruby w formacie ri.
250
251 %package examples
252 Summary:        Ruby examples
253 Summary(pl.UTF-8):      Przykłady dla języka Ruby
254 Group:          Development/Languages
255
256 %description examples
257 Ruby examples.
258
259 %description examples -l pl.UTF-8
260 Przykłady programów w języku Ruby.
261
262 # IMPORTANT: keep this as last package, as we reset Epoch
263 %package rdoc
264 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
265 Version:        %{rdoc_ver}
266 Epoch:          0
267 License:        GPL v2 and Ruby and MIT
268 Group:          Development/Libraries
269 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
270
271 %description rdoc
272 RDoc produces HTML and command-line documentation for Ruby projects.
273 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
274 online documentation.
275
276 %package rubygems
277 Summary:    The Ruby standard for packaging ruby libraries
278 Version:    %{rubygems_ver}
279 Group:      Development/Libraries
280 License:    Ruby or MIT
281 Requires:   %{name}-rdoc >= %{rdoc_ver}
282 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
283 Provides:       rubygems = %{rubygems_ver}
284 %if "%{_rpmversion}" >= "5"
285 BuildArch:      noarch
286 %endif
287
288 %description rubygems
289 RubyGems is the Ruby standard for publishing and managing third party
290 libraries.
291
292 %prep
293 %if %{with bootstrap}
294 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
295 %else
296 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
297 %endif
298 %patch0 -p1
299 %patch1 -p1
300 %patch2 -p1
301 %patch3 -p1
302 %patch4 -p1
303 %patch5 -p1
304
305 # must be regenerated with new bison
306 %{__rm} parse.{c,h}
307
308 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
309
310 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
311         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
312         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
313
314 %build
315 cp -f /usr/share/automake/config.sub .
316
317 # build ruby-1.8.7 first
318 %if %{with bootstrap}
319 cd %{name}-1.8.7-p330
320 %configure
321 %{__make}
322 cd ..
323 %endif
324
325 %{__autoconf}
326 %configure \
327         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
328         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
329         --with-archdir=%{ruby_archdir} \
330         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
331         --with-sitearchdir=%{ruby_sitearchdir} \
332         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
333         --with-vendorarchdir=%{ruby_vendorarchdir} \
334         --with-rubygemsdir=%{rubygems_dir} \
335         --with-search-path="%{legacy_loadpaths}" \
336         --enable-shared \
337         --enable-pthread \
338         --disable-install-doc \
339         --with-ruby-version=minor
340
341 %{__make} -j1 main \
342         COPY="cp -p" Q= \
343         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
344
345 %if %{with doc}
346 %{__make} -j1 docs
347 %endif
348
349 %install
350 rm -rf $RPM_BUILD_ROOT
351 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
352         $RPM_BUILD_ROOT%{ruby_libdir}/tasks \
353         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
354         $RPM_BUILD_ROOT{%{legacy_archdir},%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir}} \
355
356 %{__make} install %{?with_doc:install-doc} \
357         DESTDIR=$RPM_BUILD_ROOT
358
359 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
360 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
361 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
362
363 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
364
365 %if %{without batteries}
366 # packaged separately
367 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,tasks}
368 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
369 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
370 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
371 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
372 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON
373 %endif
374
375 %if %{with doc}
376 # too much .ri
377 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
378 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
379 %endif
380
381 %clean
382 rm -rf $RPM_BUILD_ROOT
383
384 %post   -p /sbin/ldconfig
385 %postun -p /sbin/ldconfig
386
387 %files
388 %defattr(644,root,root,755)
389 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
390 %attr(755,root,root) %{_bindir}/ruby
391 %if %{with batteries}
392 %attr(755,root,root) %{_bindir}/rake
393 %endif
394 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
395 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
396 %{_mandir}/man1/ruby.1*
397 %if %{with batteries}
398 %{_mandir}/man1/rake.1*
399 %endif
400
401 %dir %{_libdir}/%{name}
402 %dir %{_libdir}/%{name}/%{vendordir}
403 %dir %{_datadir}/%{name}
404 %dir %{_datadir}/%{name}/%{vendordir}
405
406 %dir %{ruby_libdir}
407 %dir %{ruby_archdir}
408 %dir %{ruby_vendorlibdir}
409 %dir %{ruby_vendorarchdir}
410
411 %dir %{_datadir}/ri
412 %dir %{_datadir}/ri/%{ruby_version}
413 %dir %{ruby_ridir}
414
415 %dir %{ruby_rdocdir}
416
417 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
418 %dir %{legacy_archdir}
419 %dir %{legacy_sitedir}
420 %dir %{legacy_sitelibdir}
421 %dir %{legacy_sitearchdir}
422 %dir %{legacy_vendorarchdir}
423
424 %files devel
425 %defattr(644,root,root,755)
426 %attr(755,root,root) %{_libdir}/libruby.so
427 %{_includedir}/%{name}-%{ruby_version}
428 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
429
430 %files static
431 %defattr(644,root,root,755)
432 %{_libdir}/libruby-static.a
433
434 %if %{with tk}
435 %files tk
436 %defattr(644,root,root,755)
437 %{ruby_libdir}/tcltk.rb
438 %{ruby_libdir}/tk*.rb
439 %{ruby_libdir}/tk
440 %{ruby_libdir}/tkextlib
441 %attr(755,root,root) %{ruby_archdir}/t*.so
442 %endif
443
444 %files rdoc
445 %defattr(644,root,root,755)
446 %attr(755,root,root) %{_bindir}/rdoc
447 %attr(755,root,root) %{_bindir}/ri
448 %{_mandir}/man1/rdoc.1*
449 %{ruby_libdir}/rdoc
450 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
451 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
452 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
453 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
454 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
455
456 %if %{with batteries}
457 %files rubygems
458 %attr(755,root,root) %{_bindir}/gem
459 %{ruby_libdir}/rubygems
460 %{ruby_libdir}/rubygems.rb
461 %{ruby_libdir}/ubygems.rb
462
463 %{gem_dir}/specifications/io-console-*.gemspec
464 %{gem_dir}/specifications/bigdecimal-*.gemspec
465 %if %{with batteries}
466 %dir %{gem_dir}/gems/rake-%{rake_ver}
467 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
468 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
469 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
470 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
471 %{gem_dir}/specifications/json-%{json_ver}.gemspec
472 %endif
473 %endif
474
475 %files modules
476 %defattr(644,root,root,755)
477 %attr(755,root,root) %{_bindir}/erb
478 %attr(755,root,root) %{_bindir}/irb
479 %attr(755,root,root) %{_bindir}/testrb
480 %{ruby_libdir}/bigdecimal
481 %{ruby_libdir}/cgi
482 %{ruby_libdir}/date
483 %{ruby_libdir}/digest
484 %{ruby_libdir}/dl
485 %{ruby_libdir}/drb
486 %{ruby_libdir}/fiddle
487 %{ruby_libdir}/io
488 %{ruby_libdir}/irb
489 %{ruby_libdir}/matrix
490 %{ruby_libdir}/minitest
491 %{ruby_libdir}/net
492 %{ruby_libdir}/openssl
493 %{ruby_libdir}/optparse
494 %if %{with batteries}
495 %{ruby_libdir}/json
496 %{ruby_libdir}/rake
497 %dir %{ruby_libdir}/tasks
498 %endif
499 %{ruby_libdir}/psych
500 %{ruby_libdir}/racc
501 %{ruby_libdir}/rbconfig
502 %{ruby_libdir}/rexml
503 %{ruby_libdir}/rinda
504 %{ruby_libdir}/ripper
505 %{ruby_libdir}/rss
506 %{ruby_libdir}/shell
507 %{ruby_libdir}/syck
508 %{ruby_libdir}/test
509 %{ruby_libdir}/uri
510 %{ruby_libdir}/webrick
511 %{ruby_libdir}/xmlrpc
512 %{ruby_libdir}/yaml
513 %{ruby_libdir}/[A-Za-s]*.rb
514 %{ruby_libdir}/tempfile.rb
515 %{ruby_libdir}/thread.rb
516 %{ruby_libdir}/thwait.rb
517 %{ruby_libdir}/time.rb
518 %{ruby_libdir}/timeout.rb
519 %{ruby_libdir}/tmpdir.rb
520 %{ruby_libdir}/tracer.rb
521 %{ruby_libdir}/tsort.rb
522 %{ruby_libdir}/[u-z]*.rb
523 %exclude %{ruby_libdir}/rubygems.rb
524 %exclude %{ruby_libdir}/ubygems.rb
525 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
526 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
527 %dir %{ruby_archdir}/digest
528 %attr(755,root,root) %{ruby_archdir}/digest/*.so
529 %dir %{ruby_archdir}/dl
530 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
531 %dir %{ruby_archdir}/enc
532 %attr(755,root,root) %{ruby_archdir}/enc/*.so
533 %dir %{ruby_archdir}/enc/trans
534 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
535 %dir %{ruby_archdir}/io
536 %attr(755,root,root) %{ruby_archdir}/io/*.so
537 %if %{with batteries}
538 %dir %{ruby_archdir}/json
539 %dir %{ruby_archdir}/json/ext
540 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
541 %endif
542 %dir %{ruby_archdir}/mathn
543 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
544 %dir %{ruby_archdir}/racc
545 %attr(755,root,root) %{ruby_archdir}/racc/*.so
546 %{ruby_archdir}/rbconfig.rb
547
548 # parents of gem_dir
549 %dir %{_datadir}/%{name}/gems
550 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
551 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
552
553 %dir %{gem_dir}
554 %dir %{gem_dir}/specifications
555 %{_mandir}/man1/erb.1*
556 %{_mandir}/man1/irb.1*
557 %{_mandir}/man1/ri.1*
558 %{_mandir}/man1/testrb.1*
559
560 %files doc
561 %defattr(644,root,root,755)
562 %doc ruby-doc-bundle/*
563 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
564 %{?with_doc:%doc ruby_%{doc_version}_core}
565
566 %if %{with doc}
567 %files doc-ri
568 %defattr(644,root,root,755)
569 %{ruby_ridir}/*
570 %endif
571
572 %files examples
573 %defattr(644,root,root,755)
574 %{_examplesdir}/%{name}-%{version}
This page took 0.073315 seconds and 4 git commands to generate.