]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
update macros to match exactly here and outside (need to hack with versioned subdirs)
[packages/ruby.git] / ruby.spec
1 #
2 # TODO:
3 #       - include ext/ in docs
4 #       - replace ri with fastri
5 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
6 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
7 #
8 # Conditional build:
9 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
10 %bcond_without  tk              # skip building package with Tk bindings
11 %bcond_without  batteries       # Don't include rubygems, json or rake
12 %bcond_without  verpath # LOAD_PATH with version number
13 %bcond_with     bootstrap       # build bootstrap version
14
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      392
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 %define         rubygems_ver    1.8.11
22 %define         minitest_ver    2.5.1
23 %define         rdoc_ver        3.9.5
24 Summary:        Ruby - interpreted scripting language
25 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
26 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
27 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
28 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
29 Name:           ruby
30 Version:        %{basever}.%{patchlevel}
31 Release:        0.13
32 Epoch:          1
33 License:        The Ruby License
34 Group:          Development/Languages
35 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/%{ruby_version}/%{name}-%{basever}-p%{patchlevel}.tar.bz2
36 # Source0-md5:  a810d64e2255179d2f334eb61fb8519c
37 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
38 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
39 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
40 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
41 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
42 # Source3-md5:  1892aadde51d36106c513bced2193dff
43 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
44 # Source100-md5:        50a49edb787211598d08e756e733e42e
45 Source4:        rdoc.1
46 Source5:        testrb.1
47 Source6:        %{name}-mode-init.el
48 Patch0:         %{name}-lib64.patch
49 Patch1:         %{name}-ffs.patch
50 Patch2:         fix-bison-invocation.patch
51 # http://redmine.ruby-lang.org/issues/5231
52 Patch3:         disable-versioned-paths.patch
53 # TODO: Should be submitted upstream?
54 Patch4:         arch-specific-dir.patch
55 # http://redmine.ruby-lang.org/issues/5281
56 Patch5:         site-and-vendor-arch-flags.patch
57 URL:            http://www.ruby-lang.org/
58 BuildRequires:  autoconf >= 2.60
59 BuildRequires:  automake
60 BuildRequires:  bison
61 BuildRequires:  db-devel
62 BuildRequires:  gdbm-devel >= 1.8.3
63 BuildRequires:  libffi-devel
64 BuildRequires:  ncurses-devel
65 BuildRequires:  openssl-devel
66 BuildRequires:  pkgconfig
67 BuildRequires:  readline-devel >= 4.2
68 %{!?with_bootstrap:BuildRequires:       ruby-modules}
69 BuildRequires:  sed >= 4.0
70 BuildRequires:  yaml-devel
71 %if %{with tk}
72 BuildRequires:  tk-devel
73 %endif
74 Requires(post,postun):  /sbin/ldconfig
75 Provides:       ruby(ver) = %{ruby_version}
76 Obsoletes:      rdoc
77 Obsoletes:      ruby-REXML
78 Obsoletes:      ruby-doc < 1.8.4
79 Obsoletes:      ruby-fastthread
80 %if %{with batteries}
81 Provides:       json = %{json_ver}
82 Provides:       rake = %{rake_ver}
83 Provides:       ruby-json = %{json_ver}
84 Provides:       ruby-rake = %{rake_ver}
85 Provides:       ruby-rubygems = %{rubygems_ver}
86 Provides:       rubygems = %{rubygems_ver}
87 Obsoletes:      ruby-json
88 Obsoletes:      ruby-rake
89 Obsoletes:      ruby-rubygems
90 %endif
91 Conflicts:      ruby-activesupport < 2.3.11-2
92 Conflicts:      ruby-activesupport2 < 2.3.11-2
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
96
97 # The RubyGems library has to stay out of Ruby directory three, since the
98 # RubyGems should be share by all Ruby implementations.
99 %define rubygems_dir            %{_datadir}/rubygems
100
101 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
102 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
103
104 # This is the local lib/arch and should not be used for packaging.
105 %define sitedir                 site_ruby
106 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
107 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}
108 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
109
110 # This is the general location for libs/archs compatible with all
111 # or most of the Ruby versions available in the PLD repositories.
112 %define vendordir               vendor_ruby
113 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
114 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}
115 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
116
117 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
118 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
119 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_arch}-linux
120 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
121 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
122 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_arch}-linux
123 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
124 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
125 %define legacy_vendorarchdir%{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_arch}-linux
126
127 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
128 %define legacy_vendorloadpath   %{legacy_vendorlibdir}\\0%{legacy_vendorarchdir}
129 %define legacy_loadpath         %{legacy_archdir}
130 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
131
132 # bleh, some nasty (gcc or ruby) bug still not fixed
133 # (SEGV or "unexpected break" on miniruby run during build)
134 %define         specflags_ia64  -O0
135
136 # ruby needs frame pointers for correct exception handling
137 %define         specflags_ia32  -fno-omit-frame-pointer
138
139 %description
140 Ruby is the interpreted scripting language for quick and easy
141 object-oriented programming. It has many features to process text
142 files and to do system management tasks (as in Perl). It is simple,
143 straight-forward, extensible, and portable.
144
145 This package contains only shared library and ruby interpreter. To get
146 full-functional ruby environment install ruby-modules package.
147
148 %description -l ja.UTF-8
149 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
150 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
151 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
152
153 %description -l pl.UTF-8
154 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
155 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
156 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
157 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
158 rozszerzalny i przenośny.
159
160 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
161 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
162 funkcjonalnego środowiska ruby.
163
164 %description -l pt_BR.UTF-8
165 Ruby é uma linguagem de script interpretada de programação orientada a
166 objeto. Possui diversas características para processamento de texto. É
167 simples, extensível e direta.
168
169 %package modules
170 Summary:        Ruby standard modules and utilities
171 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
172 Group:          Development/Languages
173 Requires:       %{name} = %{epoch}:%{version}-%{release}
174 # workaround for autodep generator net getting version properly
175 Provides:       ruby(abi) = %{ruby_version}
176 Provides:       ruby-modules(ver) = %{ruby_version}
177 Obsoletes:      ruby-minitest
178
179 %description modules
180 Ruby standard modules and utilities:
181 - erb - Tiny eRuby
182 - rdoc - documentation tool for source code
183 - irb - interactive Ruby
184 - ri - Ruby interactive reference
185 - testrb - automatic runner for Test::Unit of Ruby
186
187 %description modules -l pl.UTF-8
188 Standardowe moduły i narzędzia Ruby:
189 - erb - mały eRuby
190 - rdoc - narzędzie do dokumentowania kodu źródłowego
191 - irb - interaktywny Ruby
192 - ri - interaktywna dokumentacja Ruby
193 - testrb - automatyczny runner dla Ruby Test::Unit
194
195 %package tk
196 Summary:        Ruby/Tk bindings
197 Summary(pl.UTF-8):      Wiązania Ruby/Tk
198 Group:          Development/Languages
199 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
200
201 %description tk
202 This pachage contains Ruby/Tk bindings.
203
204 %description tk -l pl.UTF-8
205 Ten pakiet zawiera wiązania Ruby/Tk.
206
207 %package devel
208 Summary:        Ruby development libraries
209 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
210 Group:          Development/Languages
211 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
212
213 %description devel
214 Ruby development libraries.
215
216 %description devel -l pl.UTF-8
217 Biblioteki programistyczne interpretera języka Ruby.
218
219 %package static
220 Summary:        Ruby static libraries
221 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
222 Group:          Development/Languages
223 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
224
225 %description static
226 Ruby static libraries.
227
228 %description static -l pl.UTF-8
229 Biblioteki statyczne Ruby.
230
231 %package doc
232 Summary:        Ruby HTML documentation
233 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
234 Group:          Documentation
235
236 %description doc
237 Ruby HTML documentation: FAQ, guide, core and standard library.
238
239 %description doc -l pl.UTF-8
240 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
241 stdlib.
242
243 %package doc-ri
244 Summary:        Ruby ri documentation
245 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
246 Group:          Documentation
247 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
248
249 %description doc-ri
250 Ruby ri documentation.
251
252 %description doc-ri -l pl.UTF-8
253 Dokumentacja Ruby w formacie ri.
254
255 %package examples
256 Summary:        Ruby examples
257 Summary(pl.UTF-8):      Przykłady dla języka Ruby
258 Group:          Development/Languages
259
260 %description examples
261 Ruby examples.
262
263 %description examples -l pl.UTF-8
264 Przykłady programów w języku Ruby.
265
266 %prep
267 %if %{with bootstrap}
268 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
269 %else
270 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
271 %endif
272 %patch0 -p1
273 %patch1 -p1
274 %patch2 -p1
275 %patch3 -p1
276 %patch4 -p1
277 %patch5 -p1
278
279 # must be regenerated with new bison
280 %{__rm} parse.{c,h}
281
282 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
283
284 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
285         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
286         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
287
288 %build
289 cp -f /usr/share/automake/config.sub .
290
291 # build ruby-1.8.7 first
292 %if %{with bootstrap}
293 cd %{name}-1.8.7-p330
294 %configure
295 %{__make}
296 cd ..
297 %endif
298
299 %{__autoconf}
300 %configure \
301         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
302         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
303         --with-archdir=%{ruby_archdir} \
304         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
305         --with-sitearchdir=%{ruby_sitearchdir} \
306         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
307         --with-vendorarchdir=%{ruby_vendorarchdir} \
308         --with-rubygemsdir=%{rubygems_dir} \
309         --with-search-path="%{legacy_loadpaths}" \
310         --enable-shared \
311         --enable-pthread \
312         --disable-install-doc \
313         %{!?with_verpath:--disable-versioned-paths} \
314         --with-ruby-version=minor
315
316 %{__make} -j1 main \
317         COPY="cp -p" Q= \
318         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
319
320 %if %{with doc}
321 %{__make} -j1 docs
322 %endif
323
324 %install
325 rm -rf $RPM_BUILD_ROOT
326 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
327         $RPM_BUILD_ROOT%{ruby_libdir}/tasks \
328         $RPM_BUILD_ROOT%{ruby_vendorarchdir}/%{ruby_version} \
329         $RPM_BUILD_ROOT{%{legacy_archdir},%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir}} \
330
331 %{__make} install %{?with_doc:install-doc} \
332         DESTDIR=$RPM_BUILD_ROOT
333
334 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
335 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
336 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
337
338 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
339
340 %if %{without batteries}
341 # packaged separately
342 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json,tasks}
343 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
344 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
345 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
346 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
347 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON
348 %endif
349
350 # too much .ri
351 rm -rf $RPM_BUILD_ROOT%{_datadir}/ri
352
353 %clean
354 rm -rf $RPM_BUILD_ROOT
355
356 %post   -p /sbin/ldconfig
357 %postun -p /sbin/ldconfig
358
359 %files
360 %defattr(644,root,root,755)
361 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
362 %attr(755,root,root) %{_bindir}/ruby
363 %if %{with batteries}
364 %attr(755,root,root) %{_bindir}/gem
365 %attr(755,root,root) %{_bindir}/rake
366 %endif
367 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
368 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
369 %{_mandir}/man1/ruby.1*
370 %if %{with batteries}
371 %{_mandir}/man1/rake.1*
372 %endif
373
374 %dir %{_libdir}/%{name}
375 %dir %{_datadir}/%{name}
376 %dir %{_datadir}/%{name}/%{vendordir}
377
378 %dir %{ruby_libdir}
379 %dir %{ruby_archdir}
380 %dir %{ruby_vendorlibdir}
381 %dir %{ruby_vendorarchdir}
382 %dir %{ruby_vendorarchdir}/%{ruby_version}
383
384 #%dir %{_datadir}/ri
385 #%dir %{_datadir}/ri/%{ruby_version}
386 #%dir %{_datadir}/ri/%{ruby_version}/system
387 %dir %{ruby_rdocdir}
388
389 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
390 %dir %{legacy_archdir}
391 %dir %{legacy_sitedir}
392 %dir %{legacy_sitelibdir}
393 %dir %{legacy_sitearchdir}
394 %dir %{legacy_vendorarchdir}
395
396 %files devel
397 %defattr(644,root,root,755)
398 %attr(755,root,root) %{_libdir}/libruby.so
399 %{_includedir}/%{name}-%{ruby_version}
400 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
401
402 %files static
403 %defattr(644,root,root,755)
404 %{_libdir}/libruby-static.a
405
406 %if %{with tk}
407 %files tk
408 %defattr(644,root,root,755)
409 %{ruby_libdir}/tcltk.rb
410 %{ruby_libdir}/tk*.rb
411 %{ruby_libdir}/tk
412 %{ruby_libdir}/tkextlib
413 %attr(755,root,root) %{ruby_archdir}/t*.so
414 %endif
415
416 %files modules
417 %defattr(644,root,root,755)
418 %attr(755,root,root) %{_bindir}/erb
419 %attr(755,root,root) %{_bindir}/irb
420 %attr(755,root,root) %{_bindir}/rdoc
421 %attr(755,root,root) %{_bindir}/ri
422 %attr(755,root,root) %{_bindir}/testrb
423 %{ruby_libdir}/bigdecimal
424 %{ruby_libdir}/cgi
425 %{ruby_libdir}/date
426 %{ruby_libdir}/digest
427 %{ruby_libdir}/dl
428 %{ruby_libdir}/drb
429 %{ruby_libdir}/fiddle
430 %{ruby_libdir}/io
431 %{ruby_libdir}/irb
432 %{ruby_libdir}/matrix
433 %{ruby_libdir}/minitest
434 %{ruby_libdir}/net
435 %{ruby_libdir}/openssl
436 %{ruby_libdir}/optparse
437 %if %{with batteries}
438 %{ruby_libdir}/json
439 %{ruby_libdir}/rake
440 %{ruby_libdir}/rubygems
441 %dir %{ruby_libdir}/tasks
442 %endif
443 %{ruby_libdir}/psych
444 %{ruby_libdir}/racc
445 %{ruby_libdir}/rbconfig
446 %{ruby_libdir}/rdoc
447 %{ruby_libdir}/rexml
448 %{ruby_libdir}/rinda
449 %{ruby_libdir}/ripper
450 %{ruby_libdir}/rss
451 %{ruby_libdir}/shell
452 %{ruby_libdir}/syck
453 %{ruby_libdir}/test
454 %{ruby_libdir}/uri
455 %{ruby_libdir}/webrick
456 %{ruby_libdir}/xmlrpc
457 %{ruby_libdir}/yaml
458 %{ruby_libdir}/[A-Za-s]*.rb
459 %{ruby_libdir}/tempfile.rb
460 %{ruby_libdir}/thread.rb
461 %{ruby_libdir}/thwait.rb
462 %{ruby_libdir}/time.rb
463 %{ruby_libdir}/timeout.rb
464 %{ruby_libdir}/tmpdir.rb
465 %{ruby_libdir}/tracer.rb
466 %{ruby_libdir}/tsort.rb
467 %{ruby_libdir}/[u-z]*.rb
468 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
469 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
470 %dir %{ruby_archdir}/digest
471 %attr(755,root,root) %{ruby_archdir}/digest/*.so
472 %dir %{ruby_archdir}/dl
473 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
474 %dir %{ruby_archdir}/enc
475 %attr(755,root,root) %{ruby_archdir}/enc/*.so
476 %dir %{ruby_archdir}/enc/trans
477 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
478 %dir %{ruby_archdir}/io
479 %attr(755,root,root) %{ruby_archdir}/io/*.so
480 %if %{with batteries}
481 %dir %{ruby_archdir}/json
482 %dir %{ruby_archdir}/json/ext
483 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
484 %endif
485 %dir %{ruby_archdir}/mathn
486 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
487 %dir %{ruby_archdir}/racc
488 %attr(755,root,root) %{ruby_archdir}/racc/*.so
489 %{ruby_archdir}/rbconfig.rb
490
491 # parents of gem_dir
492 %dir %{_datadir}/%{name}/gems
493 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
494 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
495
496 %dir %{gem_dir}
497 %dir %{gem_dir}/specifications
498 %{gem_dir}/specifications/io-console-*.gemspec
499 %{gem_dir}/specifications/bigdecimal-*.gemspec
500 %if %{with batteries}
501 %dir %{gem_dir}/gems/rake-%{rake_ver}
502 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
503 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
504 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
505 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
506 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
507 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
508 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
509 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
510 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
511 %{gem_dir}/specifications/json-%{json_ver}.gemspec
512 %endif
513 %{_mandir}/man1/erb.1*
514 %{_mandir}/man1/irb.1*
515 %{_mandir}/man1/rdoc.1*
516 %{_mandir}/man1/ri.1*
517 %{_mandir}/man1/testrb.1*
518
519 %files doc
520 %defattr(644,root,root,755)
521 %doc ruby-doc-bundle/*
522 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
523 %{?with_doc:%doc ruby_%{doc_version}_core}
524
525 %if %{with doc}
526 %files doc-ri
527 %defattr(644,root,root,755)
528 %{_datadir}/ri/%{ruby_version}/system/*
529 %endif
530
531 %files examples
532 %defattr(644,root,root,755)
533 %{_examplesdir}/%{name}-%{version}
This page took 0.114334 seconds and 4 git commands to generate.