]> git.pld-linux.org Git - packages/ruby.git/blob - ruby.spec
bootstrap needs ruby binary, erb module...
[packages/ruby.git] / ruby.spec
1 #
2 # TODO:
3 #       - include ext/ in docs
4 #       - replace ri with fastri
5 #       - patch ri to search multiple indexes (one per package), so RPMs can install ri docs
6 #   - fix inconsistencies with versioned vs not-versioned dirs (see dirname hacks in configure)
7 #   - custom-rubygems-location.patch
8 #
9 # Conditional build:
10 %bcond_without  doc             # skip (time-consuming) docs generating; intended for speed up test builds
11 %bcond_without  tk              # skip building package with Tk bindings
12 %bcond_without  batteries       # Don't include rubygems, json or rake
13 %bcond_with     bootstrap       # build bootstrap version
14
15 %define         ruby_version    1.9
16 %define         basever         1.9.3
17 %define         patchlevel      392
18 %define         doc_version     1_9_3
19 %define         json_ver        1.5.5
20 %define         rake_ver        0.9.2.2
21 %define         rubygems_ver    1.8.11
22 %define         minitest_ver    2.5.1
23 %define         rdoc_ver        3.9.5
24 Summary:        Ruby - interpreted scripting language
25 Summary(ja.UTF-8):      オブジェクト指向言語Rubyインタプリタ
26 Summary(pl.UTF-8):      Ruby - interpretowany język skryptowy
27 Summary(pt_BR.UTF-8):   Linguagem de script orientada a objeto
28 Summary(zh_CN.UTF-8):   ruby - 一种快速高效的面向对象脚本编程语言
29 Name:           ruby
30 Version:        %{basever}.%{patchlevel}
31 # NOTE: do not decrease Release, when updating Version,
32 # unless rdoc_ver, rubygems_ver *both* are increased as well
33 Release:        4
34 Epoch:          1
35 # Public Domain for example for: include/ruby/st.h, strftime.c, ...
36 License:        (Ruby or BSD) and Public Domain
37 Group:          Development/Languages
38 Source0:        ftp://ftp.ruby-lang.org/pub/ruby/%{ruby_version}/%{name}-%{basever}-p%{patchlevel}.tar.bz2
39 # Source0-md5:  a810d64e2255179d2f334eb61fb8519c
40 Source1:        http://www.ruby-doc.org/download/%{name}-doc-bundle.tar.gz
41 # Source1-md5:  ad1af0043be98ba1a4f6d0185df63876
42 Source2:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_stdlib_rdocs.tgz
43 # Source2-md5:  ec622612428672c432b6f65dd31a84b5
44 Source3:        http://www.ruby-doc.org/downloads/%{name}_%{doc_version}_core_rdocs.tgz
45 # Source3-md5:  1892aadde51d36106c513bced2193dff
46 Source100:      ftp://ftp.ruby-lang.org/pub/ruby/1.8/%{name}-1.8.7-p330.tar.gz
47 # Source100-md5:        50a49edb787211598d08e756e733e42e
48 Source4:        rdoc.1
49 Source5:        testrb.1
50 Patch0:         %{name}-lib64.patch
51 Patch1:         %{name}-ffs.patch
52 Patch2:         fix-bison-invocation.patch
53 # http://redmine.ruby-lang.org/issues/5231
54 Patch3:         disable-versioned-paths.patch
55 # TODO: Should be submitted upstream?
56 Patch4:         arch-specific-dir.patch
57 # http://redmine.ruby-lang.org/issues/5281
58 Patch5:         site-and-vendor-arch-flags.patch
59 URL:            http://www.ruby-lang.org/
60 BuildRequires:  autoconf >= 2.60
61 BuildRequires:  automake
62 BuildRequires:  bison
63 BuildRequires:  db-devel
64 BuildRequires:  gdbm-devel >= 1.8.3
65 BuildRequires:  libffi-devel
66 BuildRequires:  ncurses-devel
67 BuildRequires:  openssl-devel
68 BuildRequires:  pkgconfig
69 BuildRequires:  readline-devel >= 4.2
70 # boostrap needs ruby binary, erb module
71 %{!?with_bootstrap:BuildRequires:       ruby-modules}
72 %{!?with_bootstrap:BuildRequires:       ruby}
73 BuildRequires:  sed >= 4.0
74 BuildRequires:  yaml-devel
75 %if %{with tk}
76 BuildRequires:  tk-devel
77 %endif
78 Requires(post,postun):  /sbin/ldconfig
79 Provides:       ruby(ver) = %{ruby_version}
80 Obsoletes:      rdoc
81 Obsoletes:      ruby-REXML
82 Obsoletes:      ruby-doc < 1.8.4
83 Obsoletes:      ruby-fastthread
84 %if %{with batteries}
85 Provides:       json = %{json_ver}
86 Provides:       rake = %{rake_ver}
87 Provides:       ruby-json = %{json_ver}
88 Provides:       ruby-rake = %{rake_ver}
89 Obsoletes:      ruby-json
90 Obsoletes:      ruby-rake
91 %endif
92 Conflicts:      ruby-activesupport < 2.3.11-2
93 Conflicts:      ruby-activesupport2 < 2.3.11-2
94 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
95
96 %define ruby_ridir              %{_datadir}/ri/%{ruby_version}/system
97 %define gem_dir                 %{_datadir}/%{name}/gems/%{ruby_version}
98
99 # The RubyGems library has to stay out of Ruby directory three, since the
100 # RubyGems should be share by all Ruby implementations.
101 %define rubygems_dir            %{_datadir}/rubygems
102
103 %define ruby_archdir            %{_libdir}/%{name}/%{ruby_version}
104 %define ruby_libdir             %{_datadir}/%{name}/%{ruby_version}
105
106 # This is the local lib/arch and should not be used for packaging.
107 %define sitedir                 site_ruby
108 %define ruby_sitedir            %{_prefix}/local/share/%{name}/%{sitedir}
109 %define ruby_sitearchdir        %{_prefix}/local/%{_lib}/%{name}/%{sitedir}/%{ruby_version}
110 %define ruby_sitelibdir         %{_prefix}/local/share/%{name}/%{sitedir}/%{ruby_version}
111
112 # This is the general location for libs/archs compatible with all
113 # or most of the Ruby versions available in the PLD repositories.
114 %define vendordir               vendor_ruby
115 %define ruby_vendordir          %{_datadir}/%{name}/%{vendordir}
116 %define ruby_vendorarchdir      %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
117 %define ruby_vendorlibdir       %{_datadir}/%{name}/%{vendordir}/%{ruby_version}
118
119 # TODO: drop legacy loadpaths after all ruby modules rebuilt in Th
120 %define legacy_libdir           %{_libdir}/%{name}/%{ruby_version}
121 %define legacy_archdir          %{_libdir}/%{name}/%{ruby_version}/%{_arch}-linux
122 %define legacy_sitedir          %{_libdir}/%{name}/%{sitedir}
123 %define legacy_sitelibdir       %{_libdir}/%{name}/%{sitedir}/%{ruby_version}
124 %define legacy_sitearchdir      %{_libdir}/%{name}/%{sitedir}/%{ruby_version}/%{_arch}-linux
125 %define legacy_vendordir        %{_libdir}/%{name}/%{vendordir}
126 %define legacy_vendorlibdir     %{_libdir}/%{name}/%{vendordir}/%{ruby_version}
127 %define legacy_vendorarchdir%{_libdir}/%{name}/%{vendordir}/%{ruby_version}/%{_arch}-linux
128
129 %define legacy_siteloadpath     %{legacy_sitelibdir}\\0%{legacy_sitearchdir}\\0%{legacy_sitedir}
130 %define legacy_vendorloadpath   %{legacy_vendorarchdir}
131 %define legacy_loadpath         %{legacy_archdir}
132 %define legacy_loadpaths        %{legacy_siteloadpath}\\0%{legacy_vendorloadpath}\\0%{legacy_loadpath}
133
134 # bleh, some nasty (gcc or ruby) bug still not fixed
135 # (SEGV or "unexpected break" on miniruby run during build)
136 %define         specflags_ia64  -O0
137
138 # ruby needs frame pointers for correct exception handling
139 %define         specflags_ia32  -fno-omit-frame-pointer
140
141 %description
142 Ruby is the interpreted scripting language for quick and easy
143 object-oriented programming. It has many features to process text
144 files and to do system management tasks (as in Perl). It is simple,
145 straight-forward, extensible, and portable.
146
147 This package contains only shared library and ruby interpreter. To get
148 full-functional ruby environment install ruby-modules package.
149
150 %description -l ja.UTF-8
151 Rubyはシンプルかつ強力なオブジェクト指向スクリプト言語です.Rubyは最初
152 から純粋なオブジェクト指向言語として設計されていますから,オブジェクト
153 指向プログラミングを手軽に行う事が出来ます.もちろん通常の手続き型のプ ログラミングも可能です.
154
155 %description -l pl.UTF-8
156 Ruby to interpretowany język skryptowy, w sam raz dla łatwego i
157 szybkiego pisania zorientowanych obiektowo programów. Ma wiele funkcji
158 ułatwiających przetwarzanie plików tekstowych i wykonywanie prac
159 związanych z zarządzaniem systemu (podobnie jak Perl). Jest prosty,
160 rozszerzalny i przenośny.
161
162 Ten pakiet zawiera tylko bibliotekę dzieloną i interpreter ruby.
163 Zainstaluj pakiet ruby-modules, jeżeli potrzebujesz w pełni
164 funkcjonalnego środowiska ruby.
165
166 %description -l pt_BR.UTF-8
167 Ruby é uma linguagem de script interpretada de programação orientada a
168 objeto. Possui diversas características para processamento de texto. É
169 simples, extensível e direta.
170
171 %package modules
172 Summary:        Ruby standard modules and utilities
173 Summary(pl.UTF-8):      Standardowe moduły i narzędzia dla języka Ruby
174 Group:          Development/Languages
175 Requires:       %{name} = %{epoch}:%{version}-%{release}
176 Suggests:       ruby-rubygems
177 # workaround for autodep generator not getting version properly
178 Provides:       ruby(abi) = %{ruby_version}
179 Provides:       ruby-modules(ver) = %{ruby_version}
180 Obsoletes:      ruby-minitest
181
182 %description modules
183 Ruby standard modules and utilities:
184 - erb - Tiny eRuby
185 - irb - interactive Ruby
186 - testrb - automatic runner for Test::Unit of Ruby
187
188 %description modules -l pl.UTF-8
189 Standardowe moduły i narzędzia Ruby:
190 - erb - mały eRuby
191 - irb - interaktywny Ruby
192 - testrb - automatyczny runner dla Ruby Test::Unit
193
194 %package tk
195 Summary:        Ruby/Tk bindings
196 Summary(pl.UTF-8):      Wiązania Ruby/Tk
197 Group:          Development/Languages
198 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
199
200 %description tk
201 This pachage contains Ruby/Tk bindings.
202
203 %description tk -l pl.UTF-8
204 Ten pakiet zawiera wiązania Ruby/Tk.
205
206 %package devel
207 Summary:        Ruby development libraries
208 Summary(pl.UTF-8):      Biblioteki programistyczne interpretera języka Ruby
209 Group:          Development/Languages
210 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
211
212 %description devel
213 Ruby development libraries.
214
215 %description devel -l pl.UTF-8
216 Biblioteki programistyczne interpretera języka Ruby.
217
218 %package static
219 Summary:        Ruby static libraries
220 Summary(pl.UTF-8):      Biblioteki statyczne Ruby
221 Group:          Development/Languages
222 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
223
224 %description static
225 Ruby static libraries.
226
227 %description static -l pl.UTF-8
228 Biblioteki statyczne Ruby.
229
230 %package doc
231 Summary:        Ruby HTML documentation
232 Summary(pl.UTF-8):      Dokumentacja HTML do Ruby
233 Group:          Documentation
234
235 %description doc
236 Ruby HTML documentation: FAQ, guide, core and standard library.
237
238 %description doc -l pl.UTF-8
239 Dokumentacja HTML do Ruby: FAQ, przewodnik, dokumentacja dla core i
240 stdlib.
241
242 %package doc-ri
243 Summary:        Ruby ri documentation
244 Summary(pl.UTF-8):      Dokumentacja Ruby w formacie ri
245 Group:          Documentation
246 Requires:       %{name}-modules = %{epoch}:%{version}-%{release}
247
248 %description doc-ri
249 Ruby ri documentation.
250
251 %description doc-ri -l pl.UTF-8
252 Dokumentacja Ruby w formacie ri.
253
254 %package examples
255 Summary:        Ruby examples
256 Summary(pl.UTF-8):      Przykłady dla języka Ruby
257 Group:          Development/Languages
258
259 %description examples
260 Ruby examples.
261
262 %description examples -l pl.UTF-8
263 Przykłady programów w języku Ruby.
264
265 # IMPORTANT: keep this as last package, as we reset Epoch
266 %package rdoc
267 Summary:        A tool to generate HTML and command-line documentation for Ruby projects
268 Version:        %{rdoc_ver}
269 Epoch:          0
270 License:        GPL v2 and Ruby and MIT
271 Group:          Development/Libraries
272 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
273
274 %description rdoc
275 RDoc produces HTML and command-line documentation for Ruby projects.
276 RDoc includes the 'rdoc' and 'ri' tools for generating and displaying
277 online documentation.
278
279 %package rubygems
280 Summary:        The Ruby standard for packaging ruby libraries
281 Version:        %{rubygems_ver}
282 License:        Ruby or MIT
283 Group:          Development/Libraries
284 Requires:       %{name}-modules = 1:%{basever}.%{patchlevel}-%{release}
285 Requires:       %{name}-rdoc >= %{rdoc_ver}
286 Provides:       rubygems = %{rubygems_ver}
287 %if "%{_rpmversion}" >= "5"
288 BuildArch:      noarch
289 %endif
290
291 %description rubygems
292 RubyGems is the Ruby standard for publishing and managing third party
293 libraries.
294
295 %prep
296 %if %{with bootstrap}
297 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3 -a100
298 %else
299 %setup -q -n %{name}-%{basever}-p%{patchlevel} -a1 -a2 -a3
300 %endif
301 %patch0 -p1
302 %patch1 -p1
303 %patch2 -p1
304 %patch3 -p1
305 %patch4 -p1
306 %patch5 -p1
307
308 # must be regenerated with new bison
309 %{__rm} parse.{c,h}
310
311 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
312
313 find -type f '(' -name '*.rb' -o -name '*.cgi' -o -name '*.test' \
314         -o -name 'ruby.1' -o -name '*.html' -o -name '*.tcl' ')' \
315         | xargs %{__sed} -i 's,/usr/local/bin/,%{_bindir}/,'
316
317 %build
318 cp -f /usr/share/automake/config.sub .
319
320 # build ruby-1.8.7 first
321 %if %{with bootstrap}
322 cd %{name}-1.8.7-p330
323 %configure
324 %{__make}
325 cd ..
326 %endif
327
328 %{__autoconf}
329 %configure \
330         %{?with_bootstrap:--with-baseruby=%{name}-1.8.7-p330/miniruby} \
331         --with-rubylibprefix=%(dirname %{ruby_libdir}) \
332         --with-archdir=%{ruby_archdir} \
333         --with-sitedir=%(dirname %{ruby_sitelibdir}) \
334         --with-sitearchdir=%{ruby_sitearchdir} \
335         --with-vendordir=%(dirname %{ruby_vendorlibdir}) \
336         --with-vendorarchdir=%{ruby_vendorarchdir} \
337         --with-rubygemsdir=%{rubygems_dir} \
338         --with-search-path="%{legacy_loadpaths}" \
339         --enable-shared \
340         --enable-pthread \
341         --disable-rubygems \
342         --disable-install-doc \
343         --with-ruby-version=minor
344
345 %{__make} -j1 main \
346         COPY="cp -p" Q= \
347         %{?with_bootstrap:BASERUBY="ruby-1.8.7-p330/miniruby -I./ruby-1.8.7-p330/lib"}
348
349 %if %{with doc}
350 %{__make} -j1 rdoc
351 %endif
352
353 %install
354 rm -rf $RPM_BUILD_ROOT
355 install -d $RPM_BUILD_ROOT{%{ruby_rdocdir},%{_examplesdir}/%{name}-%{version}} \
356         $RPM_BUILD_ROOT{%{ruby_vendorarchdir},%{ruby_ridir}} \
357         $RPM_BUILD_ROOT{%{legacy_archdir}/racc,%{legacy_sitelibdir},%{legacy_sitearchdir},%{legacy_vendorarchdir},%{legacy_libdir}/tasks} \
358
359 %{__make} install %{?with_doc:install-doc} \
360         DESTDIR=$RPM_BUILD_ROOT
361
362 cp -Rf sample/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
363 cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/man1
364 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_mandir}/man1
365
366 %{__rm} -rf $RPM_BUILD_ROOT%{_docdir}/%{name}/html
367
368 %if %{without batteries}
369 # packaged separately
370 %{__rm} -r $RPM_BUILD_ROOT%{ruby_libdir}/{rubygems,rake,json}
371 %{__rm} -r $RPM_BUILD_ROOT%{ruby_archdir}/json
372 %{__rm} $RPM_BUILD_ROOT%{ruby_libdir}/{rake,rubygems,json}.rb
373 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{gem,rake}
374 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/rake*
375 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/ri/%{ruby_version}/system/JSON
376 %endif
377
378 %if %{with doc}
379 # too much .ri
380 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/cache.ri
381 %{__rm} $RPM_BUILD_ROOT%{ruby_ridir}/created.rid
382 %endif
383
384 %clean
385 rm -rf $RPM_BUILD_ROOT
386
387 %post   -p /sbin/ldconfig
388 %postun -p /sbin/ldconfig
389
390 %files
391 %defattr(644,root,root,755)
392 %doc NEWS LEGAL README README.EXT ChangeLog ToDo
393 %attr(755,root,root) %{_bindir}/ruby
394 %if %{with batteries}
395 %attr(755,root,root) %{_bindir}/rake
396 %endif
397 %attr(755,root,root) %{_libdir}/libruby.so.*.*.*
398 %attr(755,root,root) %ghost %{_libdir}/libruby.so.1.9
399 %{_mandir}/man1/ruby.1*
400 %if %{with batteries}
401 %{_mandir}/man1/rake.1*
402 %endif
403
404 %dir %{_libdir}/%{name}
405 %dir %{_libdir}/%{name}/%{vendordir}
406 %dir %{_datadir}/%{name}
407 %dir %{_datadir}/%{name}/%{vendordir}
408
409 %dir %{ruby_libdir}
410 %dir %{ruby_archdir}
411 %dir %{ruby_vendorlibdir}
412 %dir %{ruby_vendorarchdir}
413
414 %dir %{_datadir}/ri
415 %dir %{_datadir}/ri/%{ruby_version}
416 %dir %{ruby_ridir}
417
418 %dir %{ruby_rdocdir}
419
420 # legacy dirs. when everything rebuilt in Th not using these dirs. drop them
421 %dir %{legacy_archdir}
422 %dir %{legacy_sitedir}
423 %dir %{legacy_sitelibdir}
424 %dir %{legacy_sitearchdir}
425 %dir %{legacy_vendorarchdir}
426 %dir %{legacy_libdir}/tasks
427 %dir %{legacy_archdir}/racc
428
429 %files devel
430 %defattr(644,root,root,755)
431 %attr(755,root,root) %{_libdir}/libruby.so
432 %{_includedir}/%{name}-%{ruby_version}
433 %{_pkgconfigdir}/ruby-%{ruby_version}.pc
434
435 %files static
436 %defattr(644,root,root,755)
437 %{_libdir}/libruby-static.a
438
439 %if %{with tk}
440 %files tk
441 %defattr(644,root,root,755)
442 %{ruby_libdir}/tcltk.rb
443 %{ruby_libdir}/tk*.rb
444 %{ruby_libdir}/tk
445 %{ruby_libdir}/tkextlib
446 %attr(755,root,root) %{ruby_archdir}/t*.so
447 %endif
448
449 %files rdoc
450 %defattr(644,root,root,755)
451 %attr(755,root,root) %{_bindir}/rdoc
452 %attr(755,root,root) %{_bindir}/ri
453 %{_mandir}/man1/rdoc.1*
454 %{ruby_libdir}/rdoc
455 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}
456 %dir %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin
457 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/rdoc
458 %{gem_dir}/specifications/rdoc-%{rdoc_ver}.gemspec
459 %attr(755,root,root) %{gem_dir}/gems/rdoc-%{rdoc_ver}/bin/ri
460
461 %if %{with batteries}
462 %files rubygems
463 %defattr(644,root,root,755)
464 %attr(755,root,root) %{_bindir}/gem
465 %{ruby_libdir}/rubygems
466 %{ruby_libdir}/rubygems.rb
467 %{ruby_libdir}/ubygems.rb
468
469 %{gem_dir}/specifications/io-console-*.gemspec
470 %{gem_dir}/specifications/bigdecimal-*.gemspec
471 %if %{with batteries}
472 %dir %{gem_dir}/gems/rake-%{rake_ver}
473 %dir %{gem_dir}/gems/rake-%{rake_ver}/bin
474 %attr(755,root,root) %{gem_dir}/gems/rake-%{rake_ver}/bin/rake
475 %{gem_dir}/specifications/minitest-%{minitest_ver}.gemspec
476 %{gem_dir}/specifications/rake-%{rake_ver}.gemspec
477 %{gem_dir}/specifications/json-%{json_ver}.gemspec
478 %endif
479 %endif
480
481 %files modules
482 %defattr(644,root,root,755)
483 %attr(755,root,root) %{_bindir}/erb
484 %attr(755,root,root) %{_bindir}/irb
485 %attr(755,root,root) %{_bindir}/testrb
486 %{ruby_libdir}/bigdecimal
487 %{ruby_libdir}/cgi
488 %{ruby_libdir}/date
489 %{ruby_libdir}/digest
490 %{ruby_libdir}/dl
491 %{ruby_libdir}/drb
492 %{ruby_libdir}/fiddle
493 %{ruby_libdir}/io
494 %{ruby_libdir}/irb
495 %{ruby_libdir}/matrix
496 %{ruby_libdir}/minitest
497 %{ruby_libdir}/net
498 %{ruby_libdir}/openssl
499 %{ruby_libdir}/optparse
500 %if %{with batteries}
501 %{ruby_libdir}/json
502 %{ruby_libdir}/rake
503 %endif
504 %{ruby_libdir}/psych
505 %{ruby_libdir}/racc
506 %{ruby_libdir}/rbconfig
507 %{ruby_libdir}/rexml
508 %{ruby_libdir}/rinda
509 %{ruby_libdir}/ripper
510 %{ruby_libdir}/rss
511 %{ruby_libdir}/shell
512 %{ruby_libdir}/syck
513 %{ruby_libdir}/test
514 %{ruby_libdir}/uri
515 %{ruby_libdir}/webrick
516 %{ruby_libdir}/xmlrpc
517 %{ruby_libdir}/yaml
518 %{ruby_libdir}/[A-Za-s]*.rb
519 %{ruby_libdir}/tempfile.rb
520 %{ruby_libdir}/thread.rb
521 %{ruby_libdir}/thwait.rb
522 %{ruby_libdir}/time.rb
523 %{ruby_libdir}/timeout.rb
524 %{ruby_libdir}/tmpdir.rb
525 %{ruby_libdir}/tracer.rb
526 %{ruby_libdir}/tsort.rb
527 %{ruby_libdir}/[u-z]*.rb
528 %exclude %{ruby_libdir}/rubygems.rb
529 %exclude %{ruby_libdir}/ubygems.rb
530 %attr(755,root,root) %{ruby_archdir}/[a-s]*.so
531 %attr(755,root,root) %{ruby_archdir}/[u-z]*.so
532 %dir %{ruby_archdir}/digest
533 %attr(755,root,root) %{ruby_archdir}/digest/*.so
534 %dir %{ruby_archdir}/dl
535 %attr(755,root,root) %{ruby_archdir}/dl/callback.so
536 %dir %{ruby_archdir}/enc
537 %attr(755,root,root) %{ruby_archdir}/enc/*.so
538 %dir %{ruby_archdir}/enc/trans
539 %attr(755,root,root) %{ruby_archdir}/enc/trans/*.so
540 %dir %{ruby_archdir}/io
541 %attr(755,root,root) %{ruby_archdir}/io/*.so
542 %if %{with batteries}
543 %dir %{ruby_archdir}/json
544 %dir %{ruby_archdir}/json/ext
545 %attr(755,root,root) %{ruby_archdir}/json/ext/*.so
546 %endif
547 %dir %{ruby_archdir}/mathn
548 %attr(755,root,root) %{ruby_archdir}/mathn/*.so
549 %dir %{ruby_archdir}/racc
550 %attr(755,root,root) %{ruby_archdir}/racc/*.so
551 %{ruby_archdir}/rbconfig.rb
552
553 # parents of gem_dir
554 %dir %{_datadir}/%{name}/gems
555 #%dir %{_datadir}/%{name}/gems/%{ruby_version}
556 %dir %{_datadir}/%{name}/gems/%{ruby_version}/gems
557
558 %dir %{gem_dir}
559 %dir %{gem_dir}/specifications
560 %{_mandir}/man1/erb.1*
561 %{_mandir}/man1/irb.1*
562 %{_mandir}/man1/ri.1*
563 %{_mandir}/man1/testrb.1*
564
565 %files doc
566 %defattr(644,root,root,755)
567 %doc ruby-doc-bundle/*
568 %{?with_doc:%doc ruby_%{doc_version}_stdlib}
569 %{?with_doc:%doc ruby_%{doc_version}_core}
570
571 %if %{with doc}
572 %files doc-ri
573 %defattr(644,root,root,755)
574 %{ruby_ridir}/*
575 %endif
576
577 %files examples
578 %defattr(644,root,root,755)
579 %{_examplesdir}/%{name}-%{version}
This page took 0.074915 seconds and 3 git commands to generate.