]> git.pld-linux.org Git - packages/ruby-safe_yaml.git/blob - ruby-safe_yaml.spec
cc7238945df38b08b4f04d0717da3c3a5aef4f47
[packages/ruby-safe_yaml.git] / ruby-safe_yaml.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname safe_yaml
6 Summary:        Parse YAML safely
7 Name:           ruby-%{pkgname}
8 Version:        0.9.4
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  9788eb941a0935853679ee186a3d481b
14 URL:            http://dtao.github.com/safe_yaml/
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-hashie
19 BuildRequires:  ruby-heredoc_unindent
20 BuildRequires:  ruby-ostruct
21 BuildRequires:  ruby-rspec
22 BuildRequires:  ruby-yaml
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Parse YAML safely, without that pesky arbitrary object deserialization
29 vulnerability
30
31 %prep
32 %setup -q -n %{pkgname}-%{version}
33
34 %build
35 %if %{with tests}
36 rspec -Ilib spec
37 %endif
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 install -d $RPM_BUILD_ROOT%{ruby_vendorlibdir}
42 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %doc README.md CHANGES.md LICENSE.txt
50 %{ruby_vendorlibdir}/safe_yaml.rb
51 %{ruby_vendorlibdir}/safe_yaml
This page took 0.048302 seconds and 2 git commands to generate.