]> git.pld-linux.org Git - packages/ruby-rubytree.git/blob - ruby-rubytree.spec
b1604b2b1e2ce65e1fd584db21f32fc94caa2d06
[packages/ruby-rubytree.git] / ruby-rubytree.spec
1 %define pkgname rubytree
2 Summary:        Ruby implementation of the generic tree data structure
3 Name:           ruby-%{pkgname}
4 Version:        0.6.2
5 Release:        2
6 License:        MIT/Ruby License
7 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
8 # Source0-md5:  04acabb6a1da7271a1505cecbea507cf
9 Group:          Development/Languages
10 URL:            http://rubytree.rubyforge.org/
11 BuildRequires:  rpmbuild(macros) >= 1.484
12 BuildRequires:  ruby >= 1:1.8.6
13 BuildRequires:  ruby-modules
14 %{?ruby_mod_ver_requires_eq}
15 #BuildArch:     noarch
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 # nothing to be placed there. we're not noarch only because of ruby packaging
19 %define         _enable_debug_packages  0
20
21 %description
22 RubyTree is a Ruby implementation of the generic tree data structure.
23 It provides a node-based model to store keyed node-elements in the
24 tree and simple APIs to access, modify and traverse the structure.
25 RubyTree is node-centric, where individual nodes on the tree are the
26 primary compositional and structural elements. This implementation
27 also mixes in the Enumerable module to allow standard access to the
28 tree as a collection.
29
30 %package rdoc
31 Summary:        HTML documentation for %{pkgname}
32 Summary(pl.UTF-8):      Dokumentacja w formacie HTML dla %{pkgname}
33 Group:          Documentation
34 Requires:       ruby >= 1:1.8.7-4
35
36 %description rdoc
37 HTML documentation for %{pkgname}.
38
39 %description rdoc -l pl.UTF-8
40 Dokumentacja w formacie HTML dla %{pkgname}.
41
42 %package ri
43 Summary:        ri documentation for %{pkgname}
44 Summary(pl.UTF-8):      Dokumentacja w formacie ri dla %{pkgname}
45 Group:          Documentation
46 Requires:       ruby
47
48 %description ri
49 ri documentation for %{pkgname}.
50
51 %description ri -l pl.UTF-8
52 Dokumentacji w formacie ri dla %{pkgname}.
53
54 %prep
55 %setup -q -c
56 %{__tar} xf %{SOURCE0} -O data.tar.gz | %{__tar} xz
57 find -newer README -o -print | xargs touch --reference %{SOURCE0}
58
59 %build
60 rdoc --ri --op ri lib
61 rdoc --op rdoc lib
62 # rm -r ri/NOT_THIS_MODULE_RELATED_DIRS
63 rm ri/created.rid
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 install -d $RPM_BUILD_ROOT{%{ruby_rubylibdir},%{ruby_ridir},%{ruby_rdocdir}}
68
69 cp -a lib/* $RPM_BUILD_ROOT%{ruby_rubylibdir}
70 cp -a ri/* $RPM_BUILD_ROOT%{ruby_ridir}
71 cp -a rdoc $RPM_BUILD_ROOT%{ruby_rdocdir}/%{name}-%{version}
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %files
77 %defattr(644,root,root,755)
78 %doc ChangeLog History.txt README TODO
79 %{ruby_rubylibdir}/tree.rb
80 %{ruby_rubylibdir}/tree
81
82 %files rdoc
83 %defattr(644,root,root,755)
84 %{ruby_rdocdir}/%{name}-%{version}
85
86 %files ri
87 %defattr(644,root,root,755)
88 %{ruby_ridir}/Tree
This page took 0.077199 seconds and 2 git commands to generate.