]> git.pld-linux.org Git - packages/ruby-rspec-expectations.git/blob - ruby-rspec-expectations.spec
new, version 2.13.0
[packages/ruby-rspec-expectations.git] / ruby-rspec-expectations.spec
1 #
2 # Conditional build:
3 %bcond_with     bootstrap               # build with boostrap
4 %bcond_without  tests           # build without tests
5
6 %if %{with boostrap}
7 %undefine       with_tests
8 %endif
9
10 # bootstrap: test needs rspec-core, however rspec-core depends on rspec-mocks
11 # runtime part of rspec-mocks does not depend on rspec-core
12
13 %define gem_name        rspec-expectations
14 Summary:        Rspec-2 expectations (should and matchers)
15 Name:           ruby-%{gem_name}
16 Version:        2.13.0
17 Release:        0.1
18 License:        MIT
19 Group:          Development/Languages
20 Source0:        http://rubygems.org/gems/%{gem_name}-%{version}.gem
21 # Source0-md5:  2873d31ef1f8f65d3a04ac40e27825a1
22 URL:            http://github.com/rspec/rspec-expectations
23 BuildRequires:  rpm-rubyprov
24 BuildRequires:  rpmbuild(macros) >= 1.656
25 %if %{without bootstrap}
26 BuildRequires:  ruby-minitest
27 BuildRequires:  ruby-rspec
28 %endif
29 Requires:       ruby-diff-lcs
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 rspec-expectations adds `should` and `should_not` to every object and
35 includes RSpec::Matchers, a library of standard matchers.
36
37 %package        doc
38 Summary:        Documentation for %{name}
39 Group:          Documentation
40 Requires:       %{name} = %{version}-%{release}
41
42 %description    doc
43 This package contains documentation for %{name}.
44
45
46 %prep
47 %setup -q -n %{gem_name}-%{version}
48
49
50 %build
51 %if %{with tests}
52 ruby -rubygems -Ilib/ -S rspec spec/
53 %endif
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
58 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
59
60 # cleanups
61 rm -f $RPM_BUILD_ROOT%{gem_instdir}/{.document,.gitignore,.travis.yml,.yardopts}
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc README.md Changelog.md License.txt
69 %{ruby_vendorlibdir}/rspec-expectations.rb
70 %{ruby_vendorlibdir}/rspec/matchers.rb
71 %{ruby_vendorlibdir}/rspec/matchers
72 %{ruby_vendorlibdir}/rspec/expectations.rb
73 %{ruby_vendorlibdir}/rspec/expectations
74
75 %if 0
76 %files  doc
77 %defattr(644,root,root,755)
78 %endif
This page took 0.080711 seconds and 4 git commands to generate.