]> git.pld-linux.org Git - packages/ruby-rspec-expectations.git/blob - ruby-rspec-expectations.spec
- up to 3.7.0
[packages/ruby-rspec-expectations.git] / ruby-rspec-expectations.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4 # test needs rspec-core, however rspec-core depends on rspec-mocks
5 # runtime part of rspec-mocks does not depend on rspec-core
6
7 %define pkgname rspec-expectations
8 Summary:        Rspec-2 expectations (should and matchers)
9 Summary(pl.UTF-8):      Oczekiwania Rspec-2 (should oraz matchers)
10 Name:           ruby-%{pkgname}
11 Version:        3.7.0
12 Release:        1
13 License:        MIT
14 Group:          Development/Languages
15 Source0:        http://rubygems.org/gems/%{pkgname}-%{version}.gem
16 # Source0-md5:  23a198e5227cb308417efef6d136c41e
17 URL:            http://github.com/rspec/rspec-expectations
18 BuildRequires:  rpm-rubyprov
19 BuildRequires:  rpmbuild(macros) >= 1.656
20 %if %{with tests}
21 BuildRequires:  ruby-minitest
22 BuildRequires:  ruby-rspec
23 %endif
24 Requires:       ruby-diff-lcs >= 1.1.3
25 Requires:       ruby-diff-lcs < 2.0
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 rspec-expectations adds `should` and `should_not` to every object and
31 includes RSpec::Matchers, a library of standard matchers.
32
33 %description -l pl.UTF-8
34 rspec-expectations dodaje `should` oraz `should_not` do każdego
35 obiektu oraz zawiera RSpec::Matchers - bibliotekę standardowych
36 funkcji dopasowujących.
37
38 %prep
39 %setup -q -n %{pkgname}-%{version}
40
41 %build
42 # write .gemspec
43 %__gem_helper spec
44
45 %if %{with tests}
46 ruby -rubygems -Ilib/ -S rspec spec/
47 %endif
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
52 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
53 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc README.md Changelog.md LICENSE.md
61 %{ruby_vendorlibdir}/rspec/expectations.rb
62 %{ruby_vendorlibdir}/rspec/expectations
63 %{ruby_vendorlibdir}/rspec/matchers.rb
64 %{ruby_vendorlibdir}/rspec/matchers
65 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.07836 seconds and 3 git commands to generate.