]> git.pld-linux.org Git - packages/ruby-rest-client.git/blob - ruby-rest-client.spec
package gemspec
[packages/ruby-rest-client.git] / ruby-rest-client.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define gem_name rest-client
6 Summary:        Simple REST client for Ruby
7 Name:           ruby-%{gem_name}
8 Version:        1.6.7
9 Release:        3
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://gems.rubyforge.org/gems/%{gem_name}-%{version}.gem
13 # Source0-md5:  1f2d6b3b6ceb88e3ee2b327f5e508c22
14 URL:            https://github.com/rest-client/rest-client
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 BuildRequires:  sed >= 4.0
18 %if %{with tests}
19 BuildRequires:  ruby-mime-types >= 1.16
20 BuildRequires:  ruby-netrc
21 BuildRequires:  ruby-rspec
22 BuildRequires:  ruby-webmock >= 0.9.1
23 %endif
24 Requires:       ruby-mime-types >= 1.16
25 Requires:       ruby-netrc
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 A simple Simple HTTP and REST client for Ruby, inspired by the Sinatra
31 microframework style of specifying actions: get, put, post, delete.
32
33 %prep
34 %setup -q -n %{gem_name}-%{version}
35 %{__sed} -i -e '1 s,#!.*ruby,#!%{__ruby},' bin/*
36
37 %build
38 # write .gemspec
39 %__gem_helper spec
40
41 %if %{with tests}
42 # TODO: According to comment in %%{PATCH0}, at least one test does not passes on
43 # R1.9.3. I gon't go to investigate further ATM.
44 rspec spec | grep -e "188 examples, [34] failures"
45 %endif
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir},%{_bindir}}
50 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
51 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
52 cp -p %{gem_name}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc README.rdoc history.md
60 %attr(755,root,root) %{_bindir}/restclient
61 %{ruby_vendorlibdir}/rest-client.rb
62 %{ruby_vendorlibdir}/rest_client.rb
63 %{ruby_vendorlibdir}/restclient.rb
64 %{ruby_vendorlibdir}/restclient
65 %{ruby_specdir}/%{gem_name}-%{version}.gemspec
This page took 0.11327 seconds and 3 git commands to generate.