]> git.pld-linux.org Git - packages/ruby-rest-client.git/blob - ruby-rest-client.spec
044df1f0cda06eabdee27c28fada24a2e17ee1d8
[packages/ruby-rest-client.git] / ruby-rest-client.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define gem_name rest-client
6 Summary:        Simple REST client for Ruby
7 Name:           ruby-%{gem_name}
8 Version:        1.6.7
9 Release:        2
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://gems.rubyforge.org/gems/%{gem_name}-%{version}.gem
13 # Source0-md5:  1f2d6b3b6ceb88e3ee2b327f5e508c22
14 URL:            http://github.com/archiloque/rest-client
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-mime-types >= 1.16
19 BuildRequires:  ruby-netrc
20 BuildRequires:  ruby-rspec
21 BuildRequires:  ruby-webmock >= 0.9.1
22 %endif
23 Requires:       ruby-mime-types >= 1.16
24 Requires:       ruby-netrc
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 A simple Simple HTTP and REST client for Ruby, inspired by the Sinatra
30 microframework style of specifying actions: get, put, post, delete.
31
32 %prep
33 %setup -q -n %{gem_name}-%{version}
34
35 %build
36 %if %{with tests}
37 # TODO: According to comment in %%{PATCH0}, at least one test does not passes on
38 # R1.9.3. I gon't go to investigate further ATM.
39 rspec spec | grep -e "188 examples, [34] failures"
40 %endif
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
45 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
46 cp -a bin/* $RPM_BUILD_ROOT%{_bindir}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README.rdoc history.md
54 %attr(755,root,root) %{_bindir}/restclient
55 %{ruby_vendorlibdir}/rest-client.rb
56 %{ruby_vendorlibdir}/rest_client.rb
57 %{ruby_vendorlibdir}/restclient.rb
58 %{ruby_vendorlibdir}/restclient
This page took 0.098092 seconds and 2 git commands to generate.