]> git.pld-linux.org Git - packages/ruby-require_all.git/blob - ruby-require_all.spec
new, version 1.2.1
[packages/ruby-require_all.git] / ruby-require_all.spec
1 %define pkgname require_all
2 Summary:        A wonderfully simple way to load your code
3 Name:           ruby-%{pkgname}
4 Version:        1.2.1
5 Release:        1
6 License:        GPL or MIT
7 Group:          Development/Languages
8 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
9 # Source0-md5:  e1b78e9e38833e514bbd323e8e377917
10 URL:            http://github.com/jarmo/require_all
11 BuildRequires:  rpm-rubyprov
12 BuildRequires:  rpmbuild(macros) >= 1.656
13 BuildArch:      noarch
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 A wonderfully simple way to load your code.
18
19 The easiest way to use require_all is to just point it at a directory
20 containing a bunch of .rb files. These files can be nested under
21 subdirectories as well:
22
23 require_all 'lib'
24
25 %prep
26 %setup -q -n %{pkgname}-%{version}
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{_bindir}}
31 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
32
33 %clean
34 rm -rf $RPM_BUILD_ROOT
35
36 %files
37 %defattr(644,root,root,755)
38 %doc README.textile CHANGES LICENSE
39 %{ruby_vendorlibdir}/%{pkgname}.rb
This page took 0.111435 seconds and 3 git commands to generate.