]> git.pld-linux.org Git - packages/ruby-rbtree.git/blob - ruby-rbtree.spec
c0ffcb7c969472fe84693ae0cbcf4008761d868e
[packages/ruby-rbtree.git] / ruby-rbtree.spec
1 Summary:        Ruby/RBTree
2 Name:           ruby-rbtree
3 Version:        0.3.0
4 Release:        2
5 License:        BSD
6 Group:          Development/Languages
7 Source0:        http://rubyforge.org/frs/download.php/67118/rbtree-%{version}.tar.gz
8 # Source0-md5:  1bb99fba5b15bcfeaae75271c3c60043
9 URL:            http://raa.ruby-lang.org/project/ruby-rbtree/
10 BuildRequires:  rpm-rubyprov
11 BuildRequires:  rpmbuild(macros) >= 1.665
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 RBTree is a sorted associative collection that is implemented with
16 Red-Black Tree. The elements of RBTree are ordered and its interface
17 is the almost same as Hash, so simply you can consider RBTree sorted
18 Hash.
19
20 %prep
21 %setup -qn rbtree-%{version}
22
23 %build
24 %{__ruby} extconf.rb \
25         --vendor
26
27 %{__make} \
28         CC="%{__cc}" \
29         LDFLAGS="%{rpmldflags}" \
30         CFLAGS="%{rpmcflags} -fPIC"
31
32 %install
33 rm -rf $RPM_BUILD_ROOT
34 %{__make} -j1 install \
35         DESTDIR=$RPM_BUILD_ROOT
36
37 %clean
38 rm -rf $RPM_BUILD_ROOT
39
40 %files
41 %defattr(644,root,root,755)
42 %doc ChangeLog LICENSE README test.rb
43 %attr(755,root,root) %{ruby_vendorarchdir}/rbtree.so
This page took 0.042244 seconds and 2 git commands to generate.