]> git.pld-linux.org Git - packages/ruby-rbnacl.git/blob - ruby-rbnacl.spec
8ed361f23ae815981870b9fd1e762c09cb2c7394
[packages/ruby-rbnacl.git] / ruby-rbnacl.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build without tests
4
5 %define pkgname rbnacl
6 Summary:        Ruby binding to the Networking and Cryptography (NaCl) library
7 Name:           ruby-%{pkgname}
8 Version:        3.3.0
9 Release:        1
10 License:        MIT
11 Group:          Development/Languages
12 Source0:        http://rubygems.org/downloads/%{pkgname}-%{version}.gem
13 # Source0-md5:  3dba0a3d90b99caafb743e0e83d6dedf
14 URL:            https://github.com/cryptosphere/rbnacl
15 BuildRequires:  rpm-rubyprov
16 BuildRequires:  rpmbuild(macros) >= 1.656
17 %if %{with tests}
18 BuildRequires:  ruby-rake
19 BuildRequires:  ruby-rspec < 3.1
20 BuildRequires:  ruby-rspec >= 3.0.0
21 BuildRequires:  ruby-rubocop
22 %endif
23 Requires:       ruby-ffi
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The Networking and Cryptography (NaCl) library provides a high-level
29 toolkit for building cryptographic systems and protocols
30
31 %prep
32 %setup -q -n %{pkgname}-%{version}
33
34 %build
35 # write .gemspec
36 %__gem_helper spec
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{ruby_vendorlibdir},%{ruby_specdir}}
41 cp -a lib/* $RPM_BUILD_ROOT%{ruby_vendorlibdir}
42 cp -p %{pkgname}-%{version}.gemspec $RPM_BUILD_ROOT%{ruby_specdir}
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 %defattr(644,root,root,755)
49 %{ruby_vendorlibdir}/%{pkgname}.rb
50 %{ruby_vendorlibdir}/%{pkgname}
51 %{ruby_specdir}/%{pkgname}-%{version}.gemspec
This page took 0.100671 seconds and 2 git commands to generate.